summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilly-JL2022-05-25 08:44:37 +0200
committerWilly-JL2022-05-25 08:44:37 +0200
commitd45f10a8ea3c0af18c7185f2a6f624a2c7e7c30a (patch)
tree2bff44500fdf46a719077a94a255a850c84a7b75
parent6a99fe78bea35704839ecd5323df8ce98473c865 (diff)
downloadaur-d45f10a8ea3c0af18c7185f2a6f624a2c7e7c30a.tar.gz
Add utility to bump pkgver
-rw-r--r--.gitignore1
-rwxr-xr-xbump-pkgver.sh13
2 files changed, 14 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
index e4f9ba3007cf..296ac64b98d7 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!.SRCINFO
!PKGBUILD
!.gitignore
+!bump-pkgver.sh
diff --git a/bump-pkgver.sh b/bump-pkgver.sh
new file mode 100755
index 000000000000..76230f73945b
--- /dev/null
+++ b/bump-pkgver.sh
@@ -0,0 +1,13 @@
+#!/bin/bash
+
+set -e
+
+makepkg -sf
+pkgver=$(grep "pkgver=" PKGBUILD | cut -d = -f 2)
+sed -i "s/pkgver =.*/pkgver = $pkgver/g" .SRCINFO
+git add .SRCINFO PKGBUILD
+git status
+echo "Do you want to commit and push these stages changes? (Enter to confirm, Ctrl+C to abort)"
+read
+git commit -m "Bump to v$pkgver"
+git push