summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Wojdyła2023-12-17 15:39:34 +0100
committerMichał Wojdyła2023-12-17 15:39:34 +0100
commita5a5f345c199842e22d90b90d63d67c31280a14e (patch)
tree546c2389ff70f5ba7f3e86f7534cba88d88b1b15
parent7d130834615797666132cabbc5dfa3061ea94c56 (diff)
downloadaur-a5a5f345c199842e22d90b90d63d67c31280a14e.tar.gz
update to 1.9.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
2 files changed, 21 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e00573f65d2c..7000683ef815 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = ios-webkit-debug-proxy
pkgdesc = DevTools proxy (WebKit Remote Debugging) for iOS devices (Safari Remote Web Inspector)
- pkgver = 1.8.8
+ pkgver = 1.9.0
pkgrel = 1
url = https://github.com/google/ios-webkit-debug-proxy
arch = i686
arch = x86_64
license = BSD
depends = libimobiledevice
- source = https://github.com/google/ios-webkit-debug-proxy/archive/v1.8.8/ios-webkit-debug-proxy-1.8.8.tar.gz
- sha256sums = 5b743276f7fbcd145e6212e892867304c5e49e7c75c0f4a331ec6deb6a8d5b3e
+ source = https://github.com/google/ios-webkit-debug-proxy/archive/v1.9.0/ios-webkit-debug-proxy-1.9.0.tar.gz
+ source = https://github.com/google/ios-webkit-debug-proxy/commit/5ba30a2a67f39d25025cadf37c0eafb2e2d2d0a8.patch
+ source = https://github.com/google/ios-webkit-debug-proxy/commit/94e4625ea648ece730d33d13224881ab06ad0fce.patch
+ sha256sums = ba9bb2feaa976ad999e9e405d8cd8794cdf3546130a79f4785235200ead3c96c
+ sha256sums = 5a499ee2cebf64fe3a75683ff8245948345b64acdc946abaa693a62bb146f7d2
+ sha256sums = 5dea08f3f0fac8f5d1a0014ab404da386120f192d5ed14f9e231afe7ef1a2208
pkgname = ios-webkit-debug-proxy
-
diff --git a/PKGBUILD b/PKGBUILD
index e9063d58782c..5d6178996972 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,25 @@
-# Maintainer: Tung Ha <tunght13488[at]gmail[dot]com>
+# Maintainer: Michał Wojdyła < micwoj9292 at gmail dot com >
+# Contributor: Tung Ha <tunght13488[at]gmail[dot]com>
pkgname=ios-webkit-debug-proxy
-pkgver=1.8.8
+pkgver=1.9.0
pkgrel=1
pkgdesc="DevTools proxy (WebKit Remote Debugging) for iOS devices (Safari Remote Web Inspector)"
url="https://github.com/google/ios-webkit-debug-proxy"
arch=('i686' 'x86_64')
license=('BSD')
depends=('libimobiledevice')
-source=("https://github.com/google/ios-webkit-debug-proxy/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('5b743276f7fbcd145e6212e892867304c5e49e7c75c0f4a331ec6deb6a8d5b3e')
+source=("https://github.com/google/ios-webkit-debug-proxy/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
+ "https://github.com/google/ios-webkit-debug-proxy/commit/5ba30a2a67f39d25025cadf37c0eafb2e2d2d0a8.patch"
+ "https://github.com/google/ios-webkit-debug-proxy/commit/94e4625ea648ece730d33d13224881ab06ad0fce.patch")
+sha256sums=('ba9bb2feaa976ad999e9e405d8cd8794cdf3546130a79f4785235200ead3c96c'
+ '5a499ee2cebf64fe3a75683ff8245948345b64acdc946abaa693a62bb146f7d2'
+ '5dea08f3f0fac8f5d1a0014ab404da386120f192d5ed14f9e231afe7ef1a2208')
+prepare() {
+ cd ios-webkit-debug-proxy-$pkgver
+ patch -p1 -i ../5ba30a2a67f39d25025cadf37c0eafb2e2d2d0a8.patch
+ patch -p1 -i ../94e4625ea648ece730d33d13224881ab06ad0fce.patch
+}
build() {
cd ios-webkit-debug-proxy-$pkgver