summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernard Baeyens2015-07-16 11:33:52 +0200
committerBernard Baeyens2015-07-16 11:33:52 +0200
commit4f16f6b25ac8a07b3f393fc5d0fe43917d6ef6b6 (patch)
treea75caaa4c98521461afe26ef278cdd22bb0f7d56
downloadaur-4f16f6b25ac8a07b3f393fc5d0fe43917d6ef6b6.tar.gz
Initial import and rebuild
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
-rw-r--r--ipager-1.1.0-20120429.patch117
-rw-r--r--ipager.install12
4 files changed, 180 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac6c27728573
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ipager
+ pkgdesc = a lightweight beautiful pager from Fluxbox
+ pkgver = 1.1.0
+ pkgrel = 10
+ url = http://fluxbox.org/screenshots/
+ install = ipager.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = patch
+ makedepends = scons
+ depends = imlib2
+ depends = libxmu
+ source = http://slackware.org.uk/slacky/slackware-13.0/desktop/ipager/1.1.0/src/ipager-1.1.0.tar.gz
+ source = ipager-1.1.0-20120429.patch
+ md5sums = d74409836f5c31eb55a55f00783b1f6f
+ md5sums = 073682d8f76e1e91b9d3f2415f4a6c52
+
+pkgname = ipager
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f63e11a29a96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Bernard Baeyens (berbae) <berbae52 at sfr dot fr>
+# Contributor: DonVla <donvla@users.sourceforge.net>
+
+pkgname=ipager
+pkgver=1.1.0
+pkgrel=10
+pkgdesc="a lightweight beautiful pager from Fluxbox"
+arch=('i686' 'x86_64')
+license=('MIT')
+#url="http://www.useperl.ru/ipager/index.en.html"
+url="http://fluxbox.org/screenshots/"
+depends=('imlib2' 'libxmu')
+makedepends=('patch' 'scons')
+#source=(http://www.useperl.ru/ipager/src/ipager-$pkgver.tar.gz ipager-1.1.0-20120429.patch)
+source=(http://slackware.org.uk/slacky/slackware-13.0/desktop/ipager/1.1.0/src/ipager-1.1.0.tar.gz ipager-1.1.0-20120429.patch)
+install=$pkgname.install
+md5sums=('d74409836f5c31eb55a55f00783b1f6f' '073682d8f76e1e91b9d3f2415f4a6c52')
+
+build() {
+cd $srcdir/$pkgname-$pkgver
+patch -p0 < $srcdir/ipager-1.1.0-20120429.patch
+scons
+}
+
+package() {
+cd $srcdir/$pkgname-$pkgver
+scons PREFIX=/usr DESTDIR=$pkgdir install
+install -d -m 755 $pkgdir/usr/share/ipager/themes
+install -m 644 themes/*.conf $pkgdir/usr/share/ipager/themes
+}
+# vim:set ts=2 sw=2 et:
diff --git a/ipager-1.1.0-20120429.patch b/ipager-1.1.0-20120429.patch
new file mode 100644
index 000000000000..68a27874e539
--- /dev/null
+++ b/ipager-1.1.0-20120429.patch
@@ -0,0 +1,117 @@
+--- SConstruct.orig 2005-11-06 05:23:24.000000000 -0600
++++ SConstruct 2012-04-29 06:59:11.927253922 -0500
+@@ -7,15 +7,16 @@
+ ###############################################
+ # options
+ ipager_optfile = [ 'scons.opts', 'user.opts' ]
+-ipager_options = Options(ipager_optfile)
+-ipager_options.AddOptions(
+- BoolOption('debug', 'build debug version', 0),
+- BoolOption('debug_events', 'debug xserve events', 0),
+
+- BoolOption('xinerama', 'support xinerama', 0),
++ipager_options = Variables(ipager_optfile)
++ipager_options.AddVariables(
++ BoolVariable('debug', 'build debug version', 0),
++ BoolVariable('debug_events', 'debug xserve events', 0),
+
+- PathOption('PREFIX', 'install-path base', '/usr/local'),
+- PathOption('DESTDIR', 'install to $DESTDIR/$PREFIX', '/')
++ BoolVariable('xinerama', 'support xinerama', 0),
++
++ PathVariable('PREFIX', 'install-path base', '/usr'),
++ PathVariable('DESTDIR', 'install to $DESTDIR/$PREFIX', '/')
+ )
+
+
+@@ -31,10 +32,10 @@
+ ipager_env = Environment(options = ipager_options, ENV = os.environ)
+
+ ipager_env.Append(
+- CPPFLAGS = [ '-Wall' ],
+- CPPPATH = [ '/usr/X11R6/include' ],
+- LIBPATH = ['/usr/X11R6/lib']
+- )
++ CPPFLAGS = [ '-Wall', '-march=native', '-O' ],
++ CPPPATH = [ '/usr/include' ],
++ LIBPATH = [ '/usr/lib' ]
++)
+
+ ipager_options.Update(ipager_env)
+
+@@ -115,11 +116,10 @@
+ else:
+ print "yes"
+ ipager_env.AppendUnique(
+- CPPPATH = imlib2_env.Dictionary()['CPPPATH'],
+- CCFLAGS = imlib2_env.Dictionary()['CCFLAGS'],
+- LIBPATH = imlib2_env.Dictionary()['LIBPATH'],
+- LIBS = imlib2_env.Dictionary()['LIBS']
+-
++ CPPPATH = imlib2_env.Dictionary().get('CPPPATH'),
++ CCFLAGS = imlib2_env.Dictionary().get('CCFLAGS'),
++ LIBPATH = imlib2_env.Dictionary().get('LIBPATH'),
++ LIBS = imlib2_env.Dictionary().get('LIBS')
+ )
+
+ conf.Finish()
+--- iconfig.cpp.orig 2012-04-28 19:34:36.902151855 -0500
++++ iconfig.cpp 2012-04-28 18:31:28.000000000 -0500
+@@ -30,11 +30,11 @@
+ #include <iostream>
+ #include <fstream>
+ #include <sstream>
+-
++#include <cstdlib>
+ #include <sys/stat.h>
+ #include <sys/types.h>
+
+-
++using namespace std;
+
+ template <class T>
+ bool from_string(T &t,
+--- ipager.cpp.orig 2012-04-28 19:34:36.928818549 -0500
++++ ipager.cpp 2012-04-28 18:43:26.000000000 -0500
+@@ -31,6 +31,7 @@
+
+ #include <iostream>
+ #include <string>
++#include <unistd.h>
+ using namespace std;
+
+ #include "pager.h"
+--- pager.cpp.orig 2012-04-28 19:34:36.928818549 -0500
++++ pager.cpp 2012-04-28 19:07:28.000000000 -0500
+@@ -266,13 +266,13 @@
+ /* Window updates go here */
+ if (m_window_update.updateNetWindowList())
+ updateNetWindowList();
+- if (m_window_update.displayIcons())
+- if (m_window_update.motion())
++ if (m_window_update.displayIcons()) {
++ if (m_window_update.motion()) {
+ displayIcons(m_window_update.getX(), m_window_update.getY());
+- else
++ } else {
+ displayIcons();
+-
+-
++ }
++ }
+
+ /* ImLib updates go here */
+
+--- wm.cpp.orig 2012-04-28 19:34:36.928818549 -0500
++++ wm.cpp 2012-04-28 18:42:07.000000000 -0500
+@@ -27,7 +27,9 @@
+
+ #include <time.h>
+ #include "atoms.h"
++#include <cstdlib>
+
++using namespace std;
+
+ WM * WM::m_instance = 0;
+ bool WM::x_error = false;
+ \ No newline at end of file
diff --git a/ipager.install b/ipager.install
new file mode 100644
index 000000000000..9512184608c0
--- /dev/null
+++ b/ipager.install
@@ -0,0 +1,12 @@
+# Contributor: DonVla <donvla@users.sourceforge.net>
+# ipager install file
+
+post_install() {
+ printf "\n"
+ printf "==> IPager creates a default config file \"$HOME/.ipager/ipager.conf\"\n"
+ printf "==> You can define other config file via \"-c\" command line option.\n"
+ printf "==> \"$> ipager -c /usr/share/ipager/themes/other.config\"\n"
+ printf "\n"
+}
+
+# vim:set ts=2 sw=2 et: