summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConrad Hoffmann2020-02-02 12:50:13 +0100
committerConrad Hoffmann2020-02-02 12:50:13 +0100
commita742e05237cd06768de1c62409a1d0a0470cff77 (patch)
treec6d1fbda0596f09d9abccd6df080c682c60bf813
downloadaur-a742e05237cd06768de1c62409a1d0a0470cff77.tar.gz
Initial release
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..59f65b638069
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ipcalc-redhat
+ pkgdesc = Redhat's modernized ipcalc fork with IPv6 support
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://gitlab.com/ipcalc/ipcalc
+ arch = x86_64
+ license = GPL
+ makedepends = meson
+ depends = glibc
+ conflicts = ipcalc
+ source = https://gitlab.com/ipcalc/ipcalc/-/archive/0.4.0/ipcalc-0.4.0.tar.gz
+ sha256sums = 2f2f9429b7da40079b3f67aad4b57003fd86a21d5f7325fca435767e90b5fc22
+
+pkgname = ipcalc-redhat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bf68b251885
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Conrad Hoffmann <ch@bitfehler.net>
+
+pkgname=ipcalc-redhat
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="Redhat's modernized ipcalc fork with IPv6 support"
+arch=('x86_64')
+url="https://gitlab.com/ipcalc/ipcalc"
+license=('GPL')
+conflicts=('ipcalc')
+depends=('glibc')
+makedepends=('meson')
+source=("https://gitlab.com/ipcalc/ipcalc/-/archive/${pkgver}/ipcalc-${pkgver}.tar.gz")
+sha256sums=('2f2f9429b7da40079b3f67aad4b57003fd86a21d5f7325fca435767e90b5fc22')
+
+build() {
+ cd "$srcdir/ipcalc-$pkgver"
+ meson setup build -Duse_maxminddb=disabled -Duse_geoip=disabled
+ ninja -C build
+}
+
+package() {
+ cd "$srcdir/ipcalc-$pkgver"
+ install -m755 -Dt "${pkgdir}/usr/bin/" build/ipcalc
+ install -m644 -Dt "${pkgdir}/usr/share/licenses/ipcalc/" COPYING
+ install -m644 -Dt "${pkgdir}/usr/share/man/man1/" ipcalc.1
+}