summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaymond Li2020-01-28 16:41:40 -0500
committerRaymond Li2020-01-28 16:41:40 -0500
commit20815a673b7ca0bdbb6360f0dc85605a761c0fd8 (patch)
tree3672fea283dff1f3b5a09c97bedc096a48686b12
parent454534727425f04282166aefd2c08014f9b89883 (diff)
downloadaur-20815a673b7ca0bdbb6360f0dc85605a761c0fd8.tar.gz
Fix ln to existing file
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5519566a36f7..0c6a86cd4715 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = ipetitions-bot
pkgdesc = A bot to get signatures for iPetitions
pkgver = 1.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Raymo111/iPetitions-Bot
arch = any
license = GPL3
source = https://github.com/Raymo111/iPetitions-Bot/archive/v1.3.tar.gz
- sha256sums = 4c852c3770b1ef4e271b6b43f9397b1f955970295ca2aeee329d21942f41d9ef
+ sha256sums = 49c0686192e4eedec3d77b37a8b23e94cf3e0bb1ab5138919348f2fdfbab99f1
pkgname = ipetitions-bot
diff --git a/PKGBUILD b/PKGBUILD
index 14c51abdc084..456673888042 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Raymo111 <hi@raymond.li>
pkgname=ipetitions-bot
pkgver=1.3
-pkgrel=1
+pkgrel=2
pkgdesc="A bot to get signatures for iPetitions"
arch=('any')
url="https://github.com/Raymo111/iPetitions-Bot"
license=('GPL3')
source=("https://github.com/Raymo111/iPetitions-Bot/archive/v$pkgver.tar.gz")
-sha256sums=('4c852c3770b1ef4e271b6b43f9397b1f955970295ca2aeee329d21942f41d9ef')
+sha256sums=('49c0686192e4eedec3d77b37a8b23e94cf3e0bb1ab5138919348f2fdfbab99f1')
package() {
cd "iPetitions-Bot-$pkgver"
@@ -17,7 +17,6 @@ package() {
chmod +x "$pkgdir/usr/lib/$pkgname/bot.sh"
cp -f formfind.pl "$pkgdir/usr/lib/$pkgname"
mkdir -p "$pkgdir/usr/bin"
- rm -rf "$pkgdir/usr/bin/$pkgname"
- ln -s "$pkgdir/usr/lib/$pkgname/bot.sh" "$pkgdir/usr/bin/$pkgname"
+ ln -sf "$pkgdir/usr/lib/$pkgname/bot.sh" "$pkgdir/usr/bin/$pkgname"
chmod +x "$pkgdir/usr/bin/$pkgname"
}