summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaymond Li2020-01-28 16:37:20 -0500
committerRaymond Li2020-01-28 16:37:20 -0500
commit454534727425f04282166aefd2c08014f9b89883 (patch)
tree44d1818a8a22014a27df854b12a2100379ac3e1c
parentb44c4f477ae372593fbfc57a7ec3bee512d2eea3 (diff)
downloadaur-454534727425f04282166aefd2c08014f9b89883.tar.gz
Revamped interface with options
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14c870a7bd19..5519566a36f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = ipetitions-bot
pkgdesc = A bot to get signatures for iPetitions
- pkgver = 1.2
+ pkgver = 1.3
pkgrel = 1
- url = https://github.com/Raymo111/iPetitions-Bot/blob/master/README.md
+ url = https://github.com/Raymo111/iPetitions-Bot
arch = any
license = GPL3
- source = https://github.com/Raymo111/iPetitions-Bot/archive/v1.2.tar.gz
- sha256sums = 3429d13ac81a1af8332acb666b461958dd337b8d9bf28aac419c391b3faba888
+ source = https://github.com/Raymo111/iPetitions-Bot/archive/v1.3.tar.gz
+ sha256sums = 4c852c3770b1ef4e271b6b43f9397b1f955970295ca2aeee329d21942f41d9ef
pkgname = ipetitions-bot
diff --git a/PKGBUILD b/PKGBUILD
index cc2a13f2df94..14c51abdc084 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Raymo111 <hi@raymond.li>
pkgname=ipetitions-bot
-pkgver=1.2
+pkgver=1.3
pkgrel=1
pkgdesc="A bot to get signatures for iPetitions"
arch=('any')
-url="https://github.com/Raymo111/iPetitions-Bot/blob/master/README.md"
+url="https://github.com/Raymo111/iPetitions-Bot"
license=('GPL3')
source=("https://github.com/Raymo111/iPetitions-Bot/archive/v$pkgver.tar.gz")
-sha256sums=('3429d13ac81a1af8332acb666b461958dd337b8d9bf28aac419c391b3faba888')
+sha256sums=('4c852c3770b1ef4e271b6b43f9397b1f955970295ca2aeee329d21942f41d9ef')
package() {
cd "iPetitions-Bot-$pkgver"
@@ -17,6 +17,7 @@ package() {
chmod +x "$pkgdir/usr/lib/$pkgname/bot.sh"
cp -f formfind.pl "$pkgdir/usr/lib/$pkgname"
mkdir -p "$pkgdir/usr/bin"
+ rm -rf "$pkgdir/usr/bin/$pkgname"
ln -s "$pkgdir/usr/lib/$pkgname/bot.sh" "$pkgdir/usr/bin/$pkgname"
chmod +x "$pkgdir/usr/bin/$pkgname"
}