summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaymond Li2019-11-16 15:47:39 -0500
committerRaymond Li2019-11-16 15:47:39 -0500
commitbce71cadf524418f17ddfeef465507230546c899 (patch)
tree4c0a5032008329058aa9f9b6863d9e1b1981ecd4
downloadaur-bce71cadf524418f17ddfeef465507230546c899.tar.gz
Initial commit v1.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e76ed55f06c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = ipetitions-bot
+ pkgdesc = A bot to get signatures for iPetitions
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/Raymo111/iPetitions-Bot/blob/master/README.md
+ arch = any
+ license = GPL3
+ source = https://github.com/Raymo111/iPetitions-Bot/archive/v1.1.tar.gz
+ sha256sums = 4890e9374e8cbc46049cdb7a2f7aaa3c05319f0934d9932cb9df107931af5b90
+
+pkgname = ipetitions-bot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87f70d818e1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Raymo111 <hi@raymond.li>
+pkgname=ipetitions-bot
+pkgver=1.1
+pkgrel=1
+pkgdesc="A bot to get signatures for iPetitions"
+arch=('any')
+url="https://github.com/Raymo111/iPetitions-Bot/blob/master/README.md"
+license=('GPL3')
+source=("https://github.com/Raymo111/iPetitions-Bot/archive/v${pkgver}.tar.gz")
+sha256sums=('4890e9374e8cbc46049cdb7a2f7aaa3c05319f0934d9932cb9df107931af5b90')
+
+package() {
+ cd "iPetitions-Bot-$pkgver"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ mkdir -p "$pkgdir/usr/lib/$pkgname"
+ cp -f bot.sh "$pkgdir/usr/lib/$pkgname"
+ chmod +x "$pkgdir/usr/lib/$pkgname/bot.sh"
+ cp -f formfind.pl "$pkgdir/usr/lib/$pkgname"
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s "$pkgdir/usr/lib/$pkgname/bot.sh" "$pkgdir/usr/bin/$pkgname"
+ chmod +x "$pkgdir/usr/bin/$pkgname"
+}