summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramtoaer2021-03-15 14:18:15 +0800
committeramtoaer2021-03-15 14:18:15 +0800
commit0c55235b7cbdba7dc54e2fdd088a6c6de0833c84 (patch)
tree5a020601f5491f62b986289095bbe8f3ba385a42
parent94a0712ec51aaa20f48bff3187a61a2c0ab2cf5f (diff)
downloadaur-0c55235b7cbdba7dc54e2fdd088a6c6de0833c84.tar.gz
update e-mail address and package version
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
2 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49d40324d856..ed0dca7b4a72 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = ipgw-bin
pkgdesc = Northeastern University Gateway Client
- pkgver = 1.3.0
- pkgrel = 2
+ pkgver = 0.1.1
+ pkgrel = 1
+ epoch = 1
url = https://github.com/neucn/ipgw
arch = x86_64
license = MIT
- source = ipgw_linux::https://github.com/neucn/ipgw/releases/download/v1.3.0/ipgw_linux
- source = LICENSE::https://raw.githubusercontent.com/neucn/ipgw/old-v1/LICENSE
- md5sums = beb7191bfbfc60de70a411461c64f473
- md5sums = fdd05dfe38c1cd8695958d07c347dbfc
+ source = ipgw_linux::https://github.com/neucn/ipgw/releases/download/v0.1.1/ipgw-linux-amd64.zip
+ source = LICENSE::https://raw.githubusercontent.com/neucn/ipgw/master/LICENSE
+ md5sums = 33462f0d1180909368d410b33857f41f
+ md5sums = 82fc1432415e7f3a2581dff2acb762e5
pkgname = ipgw-bin
diff --git a/PKGBUILD b/PKGBUILD
index 4424b9241809..3bb31b47f1c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
-# Maintainer: amtoaer <amtoaer@outlook.com>
+# Maintainer: amtoaer <amtoaer@gmail.com>
pkgname=ipgw-bin
-pkgver=1.3.0
-pkgrel=2
+pkgver=0.1.1
+pkgrel=1
+# update from 1.3.0 to 0.1.1
+epoch=1
pkgdesc="Northeastern University Gateway Client"
arch=('x86_64')
url="https://github.com/neucn/ipgw"
license=('MIT')
source=(
- "ipgw_linux::https://github.com/neucn/ipgw/releases/download/v$pkgver/ipgw_linux"
- "LICENSE::https://raw.githubusercontent.com/neucn/ipgw/old-v1/LICENSE"
+ "ipgw_linux::https://github.com/neucn/ipgw/releases/download/v$pkgver/ipgw-linux-amd64.zip"
+ "LICENSE::https://raw.githubusercontent.com/neucn/ipgw/master/LICENSE"
)
md5sums=(
- 'beb7191bfbfc60de70a411461c64f473'
- 'fdd05dfe38c1cd8695958d07c347dbfc'
+ '33462f0d1180909368d410b33857f41f'
+ '82fc1432415e7f3a2581dff2acb762e5'
)
-package(){
- install -D -m 755 $srcdir/ipgw_linux $pkgdir/usr/bin/ipgw
+package() {
+ install -D -m 755 $srcdir/ipgw $pkgdir/usr/bin/ipgw
install -D -m 644 $srcdir/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}