summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2020-07-07 19:08:54 -0400
committergraysky2020-07-07 19:08:54 -0400
commit514fa6aaaea15f494d0c7a0a7098de29e69db8dd (patch)
tree633e83db06afc5a3285d56d52672135503629717
parent3171d91a7a766b607ce08263ddc3309b40b042ac (diff)
downloadaur-514fa6aaaea15f494d0c7a0a7098de29e69db8dd.tar.gz
Update to 4.0.0-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65b6e13b92a0..ce27125242b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = iphonebackuptools
pkgdesc = Extract messages, notes, photo locations and more from unencrypted iOS backups
- pkgver = 1.78
- pkgrel = 3
+ pkgver = 4.0.0
+ pkgrel = 1
url = https://github.com/richinfante/iphonebackuptools
arch = any
license = MIT
@@ -9,9 +9,9 @@ pkgbase = iphonebackuptools
makedepends = python
depends = nodejs
depends = sqlite
- noextract = c5573a3e5446ea420a56d2477ef78550cee224fb.tar.gz
- source = https://github.com/richinfante/iphonebackuptools/archive/c5573a3e5446ea420a56d2477ef78550cee224fb.tar.gz
- sha256sums = 6cc52d2fe0b09a5b5fa8f9f80f4de77d9cc7dbf130057432a7267c9093372828
+ noextract = .tar.gz
+ source = https://github.com/richinfante/iphonebackuptools/archive/4.0.0.tar.gz
+ sha256sums = 93e5edbd66d483a9ebbbd7c41d627e26c68803e915d0e9234c5bbbb01e2f1771
pkgname = iphonebackuptools
diff --git a/PKGBUILD b/PKGBUILD
index 672a67c03d98..eb541b66e856 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,24 @@
# Maintainer: graysky <graysky AT archlinux DOT us>
pkgname=iphonebackuptools
-_commit=c5573a3e5446ea420a56d2477ef78550cee224fb
-_short=78
# work around until upstream versions
# https://github.com/richinfante/iphonebackuptools/issues/68
-pkgver=1.$_short
-pkgrel=3
+pkgver=4.0.0
+pkgrel=1
pkgdesc="Extract messages, notes, photo locations and more from unencrypted iOS backups"
arch=('any')
url="https://github.com/richinfante/iphonebackuptools"
license=(MIT)
depends=(nodejs sqlite)
makedepends=(npm python)
-source=(https://github.com/richinfante/iphonebackuptools/archive/"$_commit.tar.gz")
+source=(https://github.com/richinfante/iphonebackuptools/archive/"$pkgver.tar.gz")
noextract=("$_commit.tar.gz")
-sha256sums=('6cc52d2fe0b09a5b5fa8f9f80f4de77d9cc7dbf130057432a7267c9093372828')
+sha256sums=('93e5edbd66d483a9ebbbd7c41d627e26c68803e915d0e9234c5bbbb01e2f1771')
package() {
- npm install -g --user root --prefix "$pkgdir"/usr "$srcdir/$_commit.tar.gz"
+ npm install -g --user root --prefix "$pkgdir"/usr "$srcdir/$pkgver.tar.gz"
# Fix permissions
find "$pkgdir/usr" -type d -exec chmod 755 '{}' +
- chown -R root:root "${pkgdir}"
+ chown -R root:root "$pkgdir"
}