summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorshtrom2010-12-21 02:13:56 +0000
committerOlivier Mehani2015-07-01 14:53:29 +1000
commit0f2778dfd417461f8c37bcc5de605fca623bfaa7 (patch)
tree252a7efdc69702a1d5de843003b95de83967d418
parent0b12d04a14d11692b4cd52b39e89a713351424f1 (diff)
downloadaur-0f2778dfd417461f8c37bcc5de605fca623bfaa7.tar.gz
[ipkg*] Updates by vadmium@AUR
git-svn-id: svn+ssh://scm.narf.ssji.net/svn/archlinux-packages@271 df209809-8e4a-0410-9a64-c169741eb0fc
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD31
-rw-r--r--python-param.patch27
3 files changed, 53 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c51893d5408..0504c2326b22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = ipkg-utils
pkgdesc = The Itsy Package Management System utils
pkgver = 050831
- pkgrel = 1
+ pkgrel = 2
url = http://handhelds.org/moin/moin.cgi/Ipkg
- arch = i686
+ arch = any
license = GPL
- makedepends = python
+ makedepends = python2
+ depends = python2
source = http://www.handhelds.org/download/packages/ipkg-utils/ipkg-utils-050831.tar.gz
source = ipkg-utils-050831.destdir.patch
+ source = python-param.patch
md5sums = 4ede7edd4bcb69d9a0b74af2f68fd6da
md5sums = f53ad35c8ea36dd42aeb2edf0c81df34
+ md5sums = 09ae06c8f5c3be87eb41d003fdcf63c1
pkgname = ipkg-utils
diff --git a/PKGBUILD b/PKGBUILD
index 520521ca33a5..6cd020b0073d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,22 +5,31 @@
pkgname=ipkg-utils
pkgver=050831
-pkgrel=1
+pkgrel=2
pkgdesc="The Itsy Package Management System utils"
url="http://handhelds.org/moin/moin.cgi/Ipkg"
source=(http://www.handhelds.org/download/packages/${pkgname}/${pkgname}-${pkgver}.tar.gz
-ipkg-utils-050831.destdir.patch)
-makedepends=(python)
-md5sums=('4ede7edd4bcb69d9a0b74af2f68fd6da'
-'f53ad35c8ea36dd42aeb2edf0c81df34')
-arch=('i686')
+ipkg-utils-050831.destdir.patch
+python-param.patch
+)
+depends=(python2)
+makedepends=(python2)
+
+arch=('any')
license=('GPL')
build() {
- cd $startdir/src/$pkgname-$pkgver
- patch -Np1 < $startdir/src/ipkg-utils-050831.destdir.patch
- make || exit 2
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -Np1 < ../ipkg-utils-050831.destdir.patch
+ patch -p1 < ../python-param.patch
+ make
+}
- mkdir -p $startdir/pkg/usr/bin
- make DESTDIR=$startdir/pkg PREFIX=/usr install || exit 3
+package() {
+ make -C "$srcdir/$pkgname-$pkgver" DESTDIR="$pkgdir" PREFIX=/usr \
+ install
}
+
+md5sums=('4ede7edd4bcb69d9a0b74af2f68fd6da'
+ 'f53ad35c8ea36dd42aeb2edf0c81df34'
+ '09ae06c8f5c3be87eb41d003fdcf63c1')
diff --git a/python-param.patch b/python-param.patch
new file mode 100644
index 000000000000..b06ffcf9f55d
--- /dev/null
+++ b/python-param.patch
@@ -0,0 +1,27 @@
+PYTHON parameter for python executable, and use python2 by default, by
+vadmium@aur
+--- ipkg-utils-050831/Makefile
++++ ipkg-utils-050831/Makefile
+@@ -1,4 +1,5 @@
+ UTILS = ipkg-build ipkg-upload
++PYTHON=python2
+ DESTDIR=
+
+ PREFIX=/usr/local
+@@ -6,7 +7,7 @@ PREFIX=/usr/local
+ all: build
+
+ build: ipkg-compare-versions
+- python setup.py build
++ $(PYTHON) setup.py build
+
+ ipkg-compare-versions: ipkg-compare-versions.c
+ $(CC) $(CFLAGS) -o ipkg-compare-versions ipkg-compare-versions.c
+@@ -14,7 +15,7 @@ ipkg-compare-versions: ipkg-compare-vers
+ install: ${UTILS}
+ mkdir -p $(DESTDIR)$(PREFIX)/bin
+ cp ${UTILS} $(DESTDIR)$(PREFIX)/bin
+- python setup.py install --root=$(DESTDIR)
++ $(PYTHON) setup.py install --root=$(DESTDIR)
+ chmod agu+rx ipkg-make-index
+ cp -f ipkg-make-index $(DESTDIR)$(PREFIX)/bin