summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormehani2007-03-22 17:19:02 +0000
committerOlivier Mehani2015-07-01 14:52:49 +1000
commit387d853d70245cc86e9bfc4998c5e3b8644cc4f0 (patch)
treede45363704c834f2ec70bfe52474b12522a1cd27
downloadaur-387d853d70245cc86e9bfc4998c5e3b8644cc4f0.tar.gz
Working package.
git-svn-id: svn+ssh://scm.narf.ssji.net/svn/archlinux-packages@54 df209809-8e4a-0410-9a64-c169741eb0fc
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
-rw-r--r--ipkg-utils-050831.destdir.patch24
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf004470953e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ipkg-utils
+ pkgdesc = The Itsy Package Management System utils
+ pkgver = 050831
+ pkgrel = 1
+ url = http://handhelds.org/moin/moin.cgi/Ipkg
+ makedepends = python
+ source = http://www.handhelds.org/download/packages/ipkg-utils/ipkg-utils-050831.tar.gz
+ source = ipkg-utils-050831.destdir.patch
+ md5sums = 4ede7edd4bcb69d9a0b74af2f68fd6da
+ md5sums = f53ad35c8ea36dd42aeb2edf0c81df34
+
+pkgname = ipkg-utils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a8b9ca28592
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: Olivier Mehani <olivier.mehani@inria.fr>
+# $Id$
+# Mostly based on the Gentoo ebuild
+# http://sources.gentoo.org/viewcvs.py/gentoo-x86/app-arch/ipkg-utils/ipkg-utils-1.7.050831.ebuild?rev=1.3&view=markup
+
+pkgname=ipkg-utils
+pkgver=050831
+pkgrel=1
+pkgdesc="The Itsy Package Management System utils"
+url="http://handhelds.org/moin/moin.cgi/Ipkg"
+source=(http://www.handhelds.org/download/packages/${pkgname}/${pkgname}-${pkgver}.tar.gz
+ipkg-utils-050831.destdir.patch)
+makedepends=(python)
+md5sums=('4ede7edd4bcb69d9a0b74af2f68fd6da'
+'f53ad35c8ea36dd42aeb2edf0c81df34')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ patch -Np1 < $startdir/src/ipkg-utils-050831.destdir.patch
+ make || exit 2
+
+ mkdir -p $startdir/pkg/usr/bin
+ make DESTDIR=$startdir/pkg PREFIX=/usr install || exit 3
+}
diff --git a/ipkg-utils-050831.destdir.patch b/ipkg-utils-050831.destdir.patch
new file mode 100644
index 000000000000..8ecf263da1c4
--- /dev/null
+++ b/ipkg-utils-050831.destdir.patch
@@ -0,0 +1,24 @@
+diff -urN ipkg-utils-050831.orig/Makefile ipkg-utils-050831/Makefile
+--- ipkg-utils-050831.orig/Makefile 2004-12-28 16:32:11.000000000 +0100
++++ ipkg-utils-050831/Makefile 2007-03-22 18:09:00.000000000 +0100
+@@ -1,4 +1,5 @@
+ UTILS = ipkg-build ipkg-upload
++DESTDIR=
+
+ PREFIX=/usr/local
+
+@@ -11,10 +12,11 @@
+ $(CC) $(CFLAGS) -o ipkg-compare-versions ipkg-compare-versions.c
+
+ install: ${UTILS}
+- cp ${UTILS} $(PREFIX)/bin
+- python setup.py install
++ mkdir -p $(DESTDIR)$(PREFIX)/bin
++ cp ${UTILS} $(DESTDIR)$(PREFIX)/bin
++ python setup.py install --root=$(DESTDIR)
+ chmod agu+rx ipkg-make-index
+- cp -f ipkg-make-index $(PREFIX)/bin
++ cp -f ipkg-make-index $(DESTDIR)$(PREFIX)/bin
+
+ binary: build
+ mkdir -p ipkg-build-binary/usr/bin