summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLenovsky2019-05-28 22:56:49 +0200
committerLenovsky2019-05-28 22:56:49 +0200
commit590031b63b3c8157b59586260015ea964a9037e9 (patch)
tree831c26daf4d346d0470a6c1511a236167e9ee0e6
downloadaur-ipman.tar.gz
Initial upload
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7be9f7e2efb4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ipman
+ pkgdesc = Allows managing Lenovo Ideapad battery charging thresholds
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/Lenovsky/ipman
+ arch = any
+ license = custom:unlicense
+ depends = bash
+ source = https://github.com/Lenovsky/ipman/archive/v0.1.0.tar.gz
+ sha256sums = b0dce7038c64619f69562e956f49a20c85dd01b60f6f480215574884e8a5486c
+
+pkgname = ipman
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3aa2b2803484
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Lenovsky <lenovsky@pm.me>
+
+pkgname=ipman
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Allows managing Lenovo Ideapad battery charging thresholds"
+arch=('any')
+url="https://github.com/Lenovsky/${pkgname}"
+license=('custom:unlicense')
+depends=('bash')
+source=("https://github.com/Lenovsky/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('b0dce7038c64619f69562e956f49a20c85dd01b60f6f480215574884e8a5486c')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}