summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJianqiu Zhang2020-06-15 14:37:07 -0700
committerJianqiu Zhang2020-06-15 14:37:07 -0700
commit0a521b720df3bd6443b23fe29a697eb824502de5 (patch)
tree616734ca8ddf56cba376dc8b1153322277dea76d
parente0bdb25bf6c0be8170e84ed077eba2f91f8f916d (diff)
downloadaur-0a521b720df3bd6443b23fe29a697eb824502de5.tar.gz
Finish checking package
Signed-off-by: Jianqiu Zhang <zhangjianqiu13@gmail.com>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97ac05ae4683..b2d2c2907298 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,8 @@ pkgbase = ipmctl-git
makedepends = cmake
makedepends = git
makedepends = python3
+ makedepends = ndctl
+ depends = ndctl
source = ipmctl-git::git+https://github.com/intel/ipmctl
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 27c6eeca1b02..0330f1a168d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@ pkgdesc="util for configuring and managing Intel Optane DC persistent memory mod
arch=('x86_64')
url="https://github.com/intel/ipmctl"
license=(GPL3)
-depends=()
-makedepends=("cmake" "git" "python3")
+depends=("ndctl")
+makedepends=("cmake" "git" "python3" "ndctl")
source=(${pkgname}::git+https://github.com/intel/ipmctl)
md5sums=('SKIP')
@@ -33,6 +33,8 @@ build() {
package() {
cd $srcdir/$pkgname/build
make install
+ mv $pkgdir/usr/etc $pkgdir/etc
+ mv $pkgdir/usr/var $pkgdir/var
}
# vim:set ts=2 sw=2 et: