diff options
author | Gregory Gleason | 2020-12-17 14:54:11 -0700 |
---|---|---|
committer | Gregory Gleason | 2020-12-17 14:54:11 -0700 |
commit | dd31a7d2bbb996ebf25deff1ac1468edbff96763 (patch) | |
tree | fd92e373c7ea6f2d26bb87e9f00d67395538b333 | |
parent | 72b9767563a4c2abd19b6ca5d9c4061a04782772 (diff) | |
download | aur-dd31a7d2bbb996ebf25deff1ac1468edbff96763.tar.gz |
Added license, changed pkgrel to match ipmicfg build number
-rw-r--r-- | PKGBUILD | 23 |
1 files changed, 15 insertions, 8 deletions
@@ -4,24 +4,31 @@ pkgname=ipmicfg pkgver=1.32.0 -_pkghash=200910 -pkgrel=1 +pkgrel=200910 pkgdesc="Supermicro IPMI configuration tool" -makedepends=('unzip') +makedepends=("unzip" "python-html2text") depends=("glibc") -arch=('x86_64') -license=('custom:"Super Micro Computer"') +arch=("x86_64") +license=("custom:Super Micro Computer") url="http://www.supermicro.com/products/nfo/ipmi.cfm" -source=("https://www.supermicro.com/wftp/utility/IPMICFG/IPMICFG_${pkgver}_build.${_pkghash}.zip") -sha256sums=('f484080aaa1bbb60327249e0818acf3671588c0f6fb3c46e53cc60636a586b33') +source=( + "https://www.supermicro.com/wftp/utility/IPMICFG/IPMICFG_${pkgver}_build.${pkgrel}.zip" + "https://www.supermicro.com/about/policies/disclaimer.cfm" + ) +sha256sums=( + "f484080aaa1bbb60327249e0818acf3671588c0f6fb3c46e53cc60636a586b33" + "SKIP" + ) package() { install -d -m 755 "${pkgdir}/usr/lib/ipmicfg" install -d -m 755 "${pkgdir}/usr/bin" - cp -dpr --no-preserve=ownership "${srcdir}/IPMICFG_${pkgver}_build.${_pkghash}/Linux/64bit/"* ${pkgdir}/usr/lib/ipmicfg + cp -dpr --no-preserve=ownership "${srcdir}/IPMICFG_${pkgver}_build.${pkgrel}/Linux/64bit/"* ${pkgdir}/usr/lib/ipmicfg chmod a+rx ${pkgdir}/usr/lib/ipmicfg/IPMICFG-Linux.${CARCH} ln -s /usr/lib/ipmicfg/IPMICFG-Linux.${CARCH} ${pkgdir}/usr/bin/ipmicfg + html2text --ignore-emphasis --ignore-links "${srcdir}/disclaimer.cfm" | sed "s/\\\./\./g" > LICENSE + install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE" } |