summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBaptiste Jonglez2015-06-25 11:36:43 +0200
committerBaptiste Jonglez2015-06-25 11:36:43 +0200
commit520717dbb41472915edb5aae4828a3334a571d4f (patch)
tree8c34a0bd7aef340064f9bffda75032014a7f4c4e
downloadaur-520717dbb41472915edb5aae4828a3334a571d4f.tar.gz
Initial upload: iproute-mptcp 0.88-1
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD54
-rw-r--r--iproute2-fhs.patch75
-rw-r--r--unwanted-link-help.patch17
4 files changed, 175 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..94484550cab8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = iproute-mptcp
+ pkgdesc = IP Routing Utilities, with Multipath TCP support
+ pkgver = 0.88
+ pkgrel = 1
+ url = http://multipath-tcp.org/pmwiki.php/Users/Tools
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = glibc
+ depends = iptables
+ provides = iproute2
+ conflicts = iproute2
+ options = staticlibs
+ options = !makeflags
+ backup = etc/iproute2/ematch_map
+ backup = etc/iproute2/rt_dsfield
+ backup = etc/iproute2/rt_protos
+ backup = etc/iproute2/rt_realms
+ backup = etc/iproute2/rt_scopes
+ backup = etc/iproute2/rt_tables
+ source = https://github.com/multipath-tcp/iproute-mptcp/archive/v0.88.tar.gz
+ source = iproute2-fhs.patch
+ source = unwanted-link-help.patch
+ sha256sums = 4e5fd7bde263a60c7b6da89030e24a6bcc7564cfab1a90b150ea3c92c5efc263
+ sha256sums = 2a1ff211f1fcc57bf92dd3d19190ba72d094c4a4e82d409ba7f80d857778f0df
+ sha256sums = 3f72492554a5417c13b2b6f6222c158319ce91c0b6c25fd651f49add493323a7
+
+pkgname = iproute-mptcp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2700bc7ca731
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Baptiste Jonglez <baptiste--aur at jonglez dot org>
+pkgname=iproute-mptcp
+pkgver=0.88
+pkgrel=1
+pkgdesc="IP Routing Utilities, with Multipath TCP support"
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="http://multipath-tcp.org/pmwiki.php/Users/Tools"
+depends=('glibc' 'iptables')
+provides=('iproute2')
+conflicts=('iproute2')
+options=('staticlibs' '!makeflags')
+backup=('etc/iproute2/ematch_map' 'etc/iproute2/rt_dsfield' 'etc/iproute2/rt_protos' \
+ 'etc/iproute2/rt_realms' 'etc/iproute2/rt_scopes' 'etc/iproute2/rt_tables')
+source=("https://github.com/multipath-tcp/$pkgname/archive/v$pkgver.tar.gz"
+ "iproute2-fhs.patch"
+ "unwanted-link-help.patch")
+sha256sums=('4e5fd7bde263a60c7b6da89030e24a6bcc7564cfab1a90b150ea3c92c5efc263'
+ '2a1ff211f1fcc57bf92dd3d19190ba72d094c4a4e82d409ba7f80d857778f0df'
+ '3f72492554a5417c13b2b6f6222c158319ce91c0b6c25fd651f49add493323a7')
+
+prepare() {
+ cd $srcdir/$pkgname-$pkgver
+
+ # set correct fhs structure
+ patch -Np1 -i "$srcdir/iproute2-fhs.patch"
+
+ # allow operations on links called "h", "he", "hel", "help"
+ patch -Np1 -i "$srcdir/unwanted-link-help.patch"
+
+ # do not treat warnings as errors
+ sed -i 's/-Werror//' Makefile
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+
+ # libnetlink isn't installed, install it FS#19385
+ install -Dm644 include/libnetlink.h "$pkgdir/usr/include/libnetlink.h"
+ install -Dm644 lib/libnetlink.a "$pkgdir/usr/lib/libnetlink.a"
+
+ # usrmove
+ cd "$pkgdir"
+ mv usr/sbin usr/bin
+}
diff --git a/iproute2-fhs.patch b/iproute2-fhs.patch
new file mode 100644
index 000000000000..add3635ca587
--- /dev/null
+++ b/iproute2-fhs.patch
@@ -0,0 +1,75 @@
+diff -Naur iproute2-3.4.0/Makefile iproute2-3.4.0.new/Makefile
+--- iproute2-3.4.0/Makefile 2012-05-21 23:12:19.000000000 +0200
++++ iproute2-3.4.0.new/Makefile 2012-06-18 10:23:53.896760158 +0200
+@@ -1,7 +1,8 @@
+ ROOTDIR=$(DESTDIR)
+ PREFIX=/usr
+ LIBDIR=$(PREFIX)/lib
+-SBINDIR=/sbin
++SBINDIR=/usr/sbin
++SHAREDIR=/usr/share
+ CONFDIR=/etc/iproute2
+ DATADIR=$(PREFIX)/share
+ DOCDIR=$(DATADIR)/doc/iproute2
+diff -Naur iproute2-3.4.0/netem/Makefile iproute2-3.4.0.new/netem/Makefile
+--- iproute2-3.4.0/netem/Makefile 2012-05-21 23:12:19.000000000 +0200
++++ iproute2-3.4.0.new/netem/Makefile 2012-06-18 10:23:53.896760158 +0200
+@@ -20,9 +20,9 @@
+ $(HOSTCC) $(CCOPTS) -I../include -o $@ $@.c -lm
+
+ install: all
+- mkdir -p $(DESTDIR)$(LIBDIR)/tc
++ mkdir -p $(DESTDIR)$(SHAREDIR)/tc
+ for i in $(DISTDATA); \
+- do install -m 644 $$i $(DESTDIR)$(LIBDIR)/tc; \
++ do install -m 644 $$i $(DESTDIR)$(SHAREDIR)/tc; \
+ done
+
+ clean:
+diff -Naur iproute2-3.4.0/tc/Makefile iproute2-3.4.0.new/tc/Makefile
+--- iproute2-3.4.0/tc/Makefile 2012-05-21 23:12:19.000000000 +0200
++++ iproute2-3.4.0.new/tc/Makefile 2012-06-18 10:23:53.893426840 +0200
+@@ -105,18 +105,11 @@
+ $(AR) rcs $@ $(TCLIB)
+
+ install: all
+- mkdir -p $(MODDESTDIR)
++ mkdir -p $(DESTDIR)$(LIBDIR)/tc
+ install -m 0755 tc $(DESTDIR)$(SBINDIR)
+ for i in $(TCSO); \
+- do install -m 755 $$i $(MODDESTDIR); \
++ do install -m 755 $$i $(DESTDIR)$(LIBDIR)/tc; \
+ done
+- if [ ! -f $(MODDESTDIR)/m_ipt.so ]; then \
+- if [ -f $(MODDESTDIR)/m_xt.so ]; \
+- then ln -s m_xt.so $(MODDESTDIR)/m_ipt.so ; \
+- elif [ -f $(MODDESTDIR)/m_xt_old.so ]; \
+- then ln -s m_xt_old.so $(MODDESTDIR)/m_ipt.so ; \
+- fi; \
+- fi
+
+ clean:
+ rm -f $(TCOBJ) $(TCLIB) libtc.a tc *.so emp_ematch.yacc.h; \
+diff -Naur iproute2-3.4.0/tc/tc_util.c iproute2-3.4.0.new/tc/tc_util.c
+--- iproute2-3.4.0/tc/tc_util.c 2012-05-21 23:12:19.000000000 +0200
++++ iproute2-3.4.0.new/tc/tc_util.c 2012-06-18 10:23:53.893426840 +0200
+@@ -24,8 +24,8 @@
+ #include "utils.h"
+ #include "tc_util.h"
+
+-#ifndef LIBDIR
+-#define LIBDIR "/usr/lib"
++#ifndef SHAREDIR
++#define SHAREDIR "/usr/share"
+ #endif
+
+ const char *get_tc_lib(void)
+@@ -34,7 +34,7 @@
+
+ lib_dir = getenv("TC_LIB_DIR");
+ if (!lib_dir)
+- lib_dir = LIBDIR "/tc/";
++ lib_dir = SHAREDIR "/tc/";
+
+ return lib_dir;
+ }
diff --git a/unwanted-link-help.patch b/unwanted-link-help.patch
new file mode 100644
index 000000000000..8abe9e39d961
--- /dev/null
+++ b/unwanted-link-help.patch
@@ -0,0 +1,17 @@
+diff -ru iproute2-3.10.0.orig/ip/iplink.c iproute2-3.10.0/ip/iplink.c
+--- iproute2-3.10.0.orig/ip/iplink.c 2013-08-08 13:53:33.000000000 -0700
++++ iproute2-3.10.0/ip/iplink.c 2013-08-08 13:55:03.179865309 -0700
+@@ -467,11 +467,11 @@
+ addattr_l(&req->n, sizeof(*req), IFLA_NUM_RX_QUEUES,
+ &numrxqueues, 4);
+ } else {
++ if (matches(*argv, "help") == 0)
++ usage();
+ if (strcmp(*argv, "dev") == 0) {
+ NEXT_ARG();
+ }
+- if (matches(*argv, "help") == 0)
+- usage();
+ if (*dev)
+ duparg2("dev", *argv);
+ *dev = *argv;