summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBaptiste Jonglez2016-03-30 11:59:54 +0200
committerBaptiste Jonglez2016-03-30 12:08:03 +0200
commit70ea17b7d1027aeb988cb2357a511e5f9a4bddf1 (patch)
tree102b42c3b4c3fa399c27dbeadcb8d0198ca2b6be
parent520717dbb41472915edb5aae4828a3334a571d4f (diff)
downloadaur-70ea17b7d1027aeb988cb2357a511e5f9a4bddf1.tar.gz
iproute-mptcp: Update to 0.90
This version is based on upstream version v4.1.1 Also pick up some changes from the iproute2 arch package: - add linux-atm as a makedepends - refresh iproute2-fhs.patch
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD34
-rw-r--r--iproute2-fhs.patch132
3 files changed, 98 insertions, 80 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94484550cab8..2e296a7e2c19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Mar 30 10:07:50 UTC 2016
pkgbase = iproute-mptcp
pkgdesc = IP Routing Utilities, with Multipath TCP support
- pkgver = 0.88
+ pkgver = 0.90
pkgrel = 1
url = http://multipath-tcp.org/pmwiki.php/Users/Tools
arch = i686
arch = x86_64
license = GPL2
+ makedepends = linux-atm
depends = glibc
depends = iptables
+ optdepends = linux-atm: ATM support
provides = iproute2
conflicts = iproute2
options = staticlibs
@@ -18,11 +22,11 @@ pkgbase = iproute-mptcp
backup = etc/iproute2/rt_realms
backup = etc/iproute2/rt_scopes
backup = etc/iproute2/rt_tables
- source = https://github.com/multipath-tcp/iproute-mptcp/archive/v0.88.tar.gz
+ source = https://github.com/multipath-tcp/iproute-mptcp/archive/v0.90.tar.gz
source = iproute2-fhs.patch
source = unwanted-link-help.patch
- sha256sums = 4e5fd7bde263a60c7b6da89030e24a6bcc7564cfab1a90b150ea3c92c5efc263
- sha256sums = 2a1ff211f1fcc57bf92dd3d19190ba72d094c4a4e82d409ba7f80d857778f0df
+ sha256sums = d52af6789539eee5ab5e7a9ede2646bb0cb0bfe034ecc98a73a21317bb3ad1da
+ sha256sums = fa569bd5be8c6c47d43e84b8836436e15cec3347326aa896bb55a8babe9cb0bd
sha256sums = 3f72492554a5417c13b2b6f6222c158319ce91c0b6c25fd651f49add493323a7
pkgname = iproute-mptcp
diff --git a/PKGBUILD b/PKGBUILD
index 2700bc7ca731..9ff6cecadb97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,56 @@
# Maintainer: Baptiste Jonglez <baptiste--aur at jonglez dot org>
pkgname=iproute-mptcp
-pkgver=0.88
+pkgver=0.90
pkgrel=1
pkgdesc="IP Routing Utilities, with Multipath TCP support"
arch=('i686' 'x86_64')
license=('GPL2')
url="http://multipath-tcp.org/pmwiki.php/Users/Tools"
depends=('glibc' 'iptables')
+makedepends=('linux-atm')
+optdepends=('linux-atm: ATM support')
provides=('iproute2')
conflicts=('iproute2')
options=('staticlibs' '!makeflags')
backup=('etc/iproute2/ematch_map' 'etc/iproute2/rt_dsfield' 'etc/iproute2/rt_protos' \
'etc/iproute2/rt_realms' 'etc/iproute2/rt_scopes' 'etc/iproute2/rt_tables')
source=("https://github.com/multipath-tcp/$pkgname/archive/v$pkgver.tar.gz"
- "iproute2-fhs.patch"
- "unwanted-link-help.patch")
-sha256sums=('4e5fd7bde263a60c7b6da89030e24a6bcc7564cfab1a90b150ea3c92c5efc263'
- '2a1ff211f1fcc57bf92dd3d19190ba72d094c4a4e82d409ba7f80d857778f0df'
+ "iproute2-fhs.patch"
+ "unwanted-link-help.patch")
+sha256sums=('d52af6789539eee5ab5e7a9ede2646bb0cb0bfe034ecc98a73a21317bb3ad1da'
+ 'fa569bd5be8c6c47d43e84b8836436e15cec3347326aa896bb55a8babe9cb0bd'
'3f72492554a5417c13b2b6f6222c158319ce91c0b6c25fd651f49add493323a7')
prepare() {
- cd $srcdir/$pkgname-$pkgver
+ cd "${srcdir}/${pkgname}-${pkgver}"
# set correct fhs structure
- patch -Np1 -i "$srcdir/iproute2-fhs.patch"
+ patch -Np1 -i "${srcdir}/iproute2-fhs.patch"
# allow operations on links called "h", "he", "hel", "help"
- patch -Np1 -i "$srcdir/unwanted-link-help.patch"
+ patch -Np1 -i "${srcdir}/unwanted-link-help.patch"
# do not treat warnings as errors
sed -i 's/-Werror//' Makefile
}
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "${srcdir}/${pkgname}-${pkgver}"
./configure
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="$pkgdir" install
+ make DESTDIR="${pkgdir}" install
# libnetlink isn't installed, install it FS#19385
- install -Dm644 include/libnetlink.h "$pkgdir/usr/include/libnetlink.h"
- install -Dm644 lib/libnetlink.a "$pkgdir/usr/lib/libnetlink.a"
+ install -Dm644 include/libnetlink.h "${pkgdir}/usr/include/libnetlink.h"
+ install -Dm644 lib/libnetlink.a "${pkgdir}/usr/lib/libnetlink.a"
- # usrmove
- cd "$pkgdir"
- mv usr/sbin usr/bin
+ # move binaries
+ cd "${pkgdir}"
+ mv sbin usr/bin
}
diff --git a/iproute2-fhs.patch b/iproute2-fhs.patch
index add3635ca587..f632b64a7a99 100644
--- a/iproute2-fhs.patch
+++ b/iproute2-fhs.patch
@@ -1,75 +1,87 @@
-diff -Naur iproute2-3.4.0/Makefile iproute2-3.4.0.new/Makefile
---- iproute2-3.4.0/Makefile 2012-05-21 23:12:19.000000000 +0200
-+++ iproute2-3.4.0.new/Makefile 2012-06-18 10:23:53.896760158 +0200
-@@ -1,7 +1,8 @@
- ROOTDIR=$(DESTDIR)
- PREFIX=/usr
- LIBDIR=$(PREFIX)/lib
--SBINDIR=/sbin
-+SBINDIR=/usr/sbin
-+SHAREDIR=/usr/share
- CONFDIR=/etc/iproute2
- DATADIR=$(PREFIX)/share
- DOCDIR=$(DATADIR)/doc/iproute2
-diff -Naur iproute2-3.4.0/netem/Makefile iproute2-3.4.0.new/netem/Makefile
---- iproute2-3.4.0/netem/Makefile 2012-05-21 23:12:19.000000000 +0200
-+++ iproute2-3.4.0.new/netem/Makefile 2012-06-18 10:23:53.896760158 +0200
-@@ -20,9 +20,9 @@
+diff --git a/Makefile b/Makefile
+index 67176be..6549447 100644
+--- a/Makefile
++++ b/Makefile
+@@ -13,7 +13,7 @@ DBM_INCLUDE:=$(DESTDIR)/usr/include
+
+ SHARED_LIBS = y
+
+-DEFINES= -DRESOLVE_HOSTNAMES -DLIBDIR=\"$(LIBDIR)\"
++DEFINES= -DRESOLVE_HOSTNAMES -DLIBDIR=\"$(LIBDIR)\" -DDATADIR=\"$(DATADIR)\"
+ ifneq ($(SHARED_LIBS),y)
+ DEFINES+= -DNO_SHARED_LIBS
+ endif
+diff --git a/netem/Makefile b/netem/Makefile
+index e52e125..5b4d283 100644
+--- a/netem/Makefile
++++ b/netem/Makefile
+@@ -20,9 +20,9 @@ stats: stats.c
$(HOSTCC) $(CCOPTS) -I../include -o $@ $@.c -lm
install: all
- mkdir -p $(DESTDIR)$(LIBDIR)/tc
-+ mkdir -p $(DESTDIR)$(SHAREDIR)/tc
++ mkdir -p $(DESTDIR)$(DATADIR)/tc
for i in $(DISTDATA); \
- do install -m 644 $$i $(DESTDIR)$(LIBDIR)/tc; \
-+ do install -m 644 $$i $(DESTDIR)$(SHAREDIR)/tc; \
++ do install -m 644 $$i $(DESTDIR)$(DATADIR)/tc; \
done
clean:
-diff -Naur iproute2-3.4.0/tc/Makefile iproute2-3.4.0.new/tc/Makefile
---- iproute2-3.4.0/tc/Makefile 2012-05-21 23:12:19.000000000 +0200
-+++ iproute2-3.4.0.new/tc/Makefile 2012-06-18 10:23:53.893426840 +0200
-@@ -105,18 +105,11 @@
- $(AR) rcs $@ $(TCLIB)
-
- install: all
-- mkdir -p $(MODDESTDIR)
-+ mkdir -p $(DESTDIR)$(LIBDIR)/tc
- install -m 0755 tc $(DESTDIR)$(SBINDIR)
- for i in $(TCSO); \
-- do install -m 755 $$i $(MODDESTDIR); \
-+ do install -m 755 $$i $(DESTDIR)$(LIBDIR)/tc; \
- done
-- if [ ! -f $(MODDESTDIR)/m_ipt.so ]; then \
-- if [ -f $(MODDESTDIR)/m_xt.so ]; \
-- then ln -s m_xt.so $(MODDESTDIR)/m_ipt.so ; \
-- elif [ -f $(MODDESTDIR)/m_xt_old.so ]; \
-- then ln -s m_xt_old.so $(MODDESTDIR)/m_ipt.so ; \
-- fi; \
-- fi
+diff --git a/tc/q_netem.c b/tc/q_netem.c
+index cd990a0..7d4e71f 100644
+--- a/tc/q_netem.c
++++ b/tc/q_netem.c
+@@ -113,7 +113,7 @@ static int get_distribution(const char *type, __s16 *data, int maxdata)
+ char *line = NULL;
+ char name[128];
- clean:
- rm -f $(TCOBJ) $(TCLIB) libtc.a tc *.so emp_ematch.yacc.h; \
-diff -Naur iproute2-3.4.0/tc/tc_util.c iproute2-3.4.0.new/tc/tc_util.c
---- iproute2-3.4.0/tc/tc_util.c 2012-05-21 23:12:19.000000000 +0200
-+++ iproute2-3.4.0.new/tc/tc_util.c 2012-06-18 10:23:53.893426840 +0200
-@@ -24,8 +24,8 @@
- #include "utils.h"
- #include "tc_util.h"
-
--#ifndef LIBDIR
--#define LIBDIR "/usr/lib"
-+#ifndef SHAREDIR
-+#define SHAREDIR "/usr/share"
+- snprintf(name, sizeof(name), "%s/%s.dist", get_tc_lib(), type);
++ snprintf(name, sizeof(name), "%s/%s.dist", get_tc_datadir(), type);
+ if ((f = fopen(name, "r")) == NULL) {
+ fprintf(stderr, "No distribution data for %s (%s: %s)\n",
+ type, name, strerror(errno));
+diff --git a/tc/tc_util.c b/tc/tc_util.c
+index aa6de24..22bb6d5 100644
+--- a/tc/tc_util.c
++++ b/tc/tc_util.c
+@@ -32,6 +32,10 @@
+ #define LIBDIR "/usr/lib"
#endif
- const char *get_tc_lib(void)
-@@ -34,7 +34,7 @@
-
- lib_dir = getenv("TC_LIB_DIR");
- if (!lib_dir)
-- lib_dir = LIBDIR "/tc/";
-+ lib_dir = SHAREDIR "/tc/";
++#ifndef DATADIR
++#define DATADIR "/usr/share"
++#endif
++
+ static struct db_names *cls_names = NULL;
+ #define NAMES_DB "/etc/iproute2/tc_cls"
+@@ -73,6 +77,17 @@ const char *get_tc_lib(void)
return lib_dir;
}
+
++const char *get_tc_datadir(void)
++{
++ const char *data_dir;
++
++ data_dir = getenv("TC_DATA_DIR");
++ if (!data_dir)
++ data_dir = DATADIR "/tc/";
++
++ return data_dir;
++}
++
+ int get_qdisc_handle(__u32 *h, const char *str)
+ {
+ __u32 maj;
+diff --git a/tc/tc_util.h b/tc/tc_util.h
+index 61e60b1..6d448de 100644
+--- a/tc/tc_util.h
++++ b/tc/tc_util.h
+@@ -55,6 +55,7 @@ struct exec_util {
+ };
+
+ extern const char *get_tc_lib(void);
++extern const char *get_tc_datadir(void);
+
+ extern struct qdisc_util *get_qdisc_kind(const char *str);
+ extern struct filter_util *get_filter_kind(const char *str);