summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-29 13:13:32 +0200
committerChristian Hesse2015-06-29 13:13:32 +0200
commit63af27d674da0b7c43be0676258de375fa2793dd (patch)
tree044d7d924ba8a97644894f4005f565e34175e722
downloadaur-63af27d674da0b7c43be0676258de375fa2793dd.tar.gz
initial import of iproute2-git 4.1.0.r41.g0c4a90c-2
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD56
-rw-r--r--unwanted-link-help.patch17
3 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56afa872cc78
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = iproute2-git
+ pkgdesc = IP Routing Utilities - git checkout
+ pkgver = 4.1.0.r41.g0c4a90c
+ pkgrel = 2
+ url = http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = linux-atm
+ depends = glibc
+ depends = iptables
+ depends = libmnl
+ optdepends = linux-atm: ATM support
+ provides = iproute2
+ conflicts = iproute2
+ conflicts = iproute
+ backup = etc/iproute2/ematch_map
+ backup = etc/iproute2/rt_dsfield
+ backup = etc/iproute2/rt_protos
+ backup = etc/iproute2/rt_realms
+ backup = etc/iproute2/rt_scopes
+ backup = etc/iproute2/rt_tables
+ source = git://git.kernel.org/pub/scm/linux/kernel/git/shemminger/iproute2.git
+ source = unwanted-link-help.patch
+ sha256sums = SKIP
+ sha256sums = 3f72492554a5417c13b2b6f6222c158319ce91c0b6c25fd651f49add493323a7
+
+pkgname = iproute2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..235d64b2b542
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+# Contributor: Ronald van Haren <ronald.archlinux.org>
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
+
+pkgname=iproute2-git
+pkgver=4.1.0.r41.g0c4a90c
+pkgrel=2
+pkgdesc='IP Routing Utilities - git checkout'
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2"
+depends=('glibc' 'iptables' 'libmnl')
+makedepends=('git' 'linux-atm')
+optdepends=('linux-atm: ATM support')
+provides=('iproute2')
+conflicts=('iproute2' 'iproute')
+backup=('etc/iproute2/ematch_map' 'etc/iproute2/rt_dsfield' 'etc/iproute2/rt_protos' \
+ 'etc/iproute2/rt_realms' 'etc/iproute2/rt_scopes' 'etc/iproute2/rt_tables')
+source=('git://git.kernel.org/pub/scm/linux/kernel/git/shemminger/iproute2.git'
+ 'unwanted-link-help.patch')
+sha256sums=('SKIP'
+ '3f72492554a5417c13b2b6f6222c158319ce91c0b6c25fd651f49add493323a7')
+
+
+pkgver() {
+ cd iproute2/
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ else
+ echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ fi
+}
+
+prepare() {
+ cd iproute2/
+
+ # allow operations on links called "h", "he", "hel", "help"
+ patch -Np1 -i "${srcdir}/unwanted-link-help.patch"
+
+ # do not treat warnings as errors
+ sed -i 's/-Werror//' Makefile
+}
+
+build() {
+ cd iproute2/
+
+ ./configure
+}
+
+package() {
+ cd iproute2/
+
+ make DESTDIR="${pkgdir}" SBINDIR="/usr/bin/" install
+}
+
diff --git a/unwanted-link-help.patch b/unwanted-link-help.patch
new file mode 100644
index 000000000000..8abe9e39d961
--- /dev/null
+++ b/unwanted-link-help.patch
@@ -0,0 +1,17 @@
+diff -ru iproute2-3.10.0.orig/ip/iplink.c iproute2-3.10.0/ip/iplink.c
+--- iproute2-3.10.0.orig/ip/iplink.c 2013-08-08 13:53:33.000000000 -0700
++++ iproute2-3.10.0/ip/iplink.c 2013-08-08 13:55:03.179865309 -0700
+@@ -467,11 +467,11 @@
+ addattr_l(&req->n, sizeof(*req), IFLA_NUM_RX_QUEUES,
+ &numrxqueues, 4);
+ } else {
++ if (matches(*argv, "help") == 0)
++ usage();
+ if (strcmp(*argv, "dev") == 0) {
+ NEXT_ARG();
+ }
+- if (matches(*argv, "help") == 0)
+- usage();
+ if (*dev)
+ duparg2("dev", *argv);
+ *dev = *argv;