summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-09-30 15:27:37 +0200
committerChristian Hesse2015-09-30 15:27:37 +0200
commitfdbd5aaf99a86c9d7aece8524a20381a47d41933 (patch)
treef074c06fd2cecaaa8ddb1b04d8b4f32620c690b2
parent63af27d674da0b7c43be0676258de375fa2793dd (diff)
downloadaur-fdbd5aaf99a86c9d7aece8524a20381a47d41933.tar.gz
commit iproute2-git 4.2.0.r44.g8fe9839-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD23
2 files changed, 13 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56afa872cc78..cf02c35ab372 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = iproute2-git
pkgdesc = IP Routing Utilities - git checkout
- pkgver = 4.1.0.r41.g0c4a90c
- pkgrel = 2
+ pkgver = 4.2.0.r44.g8fe9839
+ pkgrel = 1
url = http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2
arch = i686
arch = x86_64
@@ -22,9 +22,7 @@ pkgbase = iproute2-git
backup = etc/iproute2/rt_scopes
backup = etc/iproute2/rt_tables
source = git://git.kernel.org/pub/scm/linux/kernel/git/shemminger/iproute2.git
- source = unwanted-link-help.patch
sha256sums = SKIP
- sha256sums = 3f72492554a5417c13b2b6f6222c158319ce91c0b6c25fd651f49add493323a7
pkgname = iproute2-git
diff --git a/PKGBUILD b/PKGBUILD
index 235d64b2b542..e564be4f1464 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Judd Vinet <jvinet@zeroflux.org>
pkgname=iproute2-git
-pkgver=4.1.0.r41.g0c4a90c
-pkgrel=2
+pkgver=4.2.0.r44.g8fe9839
+pkgrel=1
pkgdesc='IP Routing Utilities - git checkout'
arch=('i686' 'x86_64')
license=('GPL2')
@@ -16,28 +16,27 @@ provides=('iproute2')
conflicts=('iproute2' 'iproute')
backup=('etc/iproute2/ematch_map' 'etc/iproute2/rt_dsfield' 'etc/iproute2/rt_protos' \
'etc/iproute2/rt_realms' 'etc/iproute2/rt_scopes' 'etc/iproute2/rt_tables')
-source=('git://git.kernel.org/pub/scm/linux/kernel/git/shemminger/iproute2.git'
- 'unwanted-link-help.patch')
-sha256sums=('SKIP'
- '3f72492554a5417c13b2b6f6222c158319ce91c0b6c25fd651f49add493323a7')
-
+source=('git://git.kernel.org/pub/scm/linux/kernel/git/shemminger/iproute2.git')
+sha256sums=('SKIP')
pkgver() {
cd iproute2/
if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
- echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ printf '%s.r%s.g%s' \
+ "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG})" \
+ "$(git rev-list --count ${GITTAG}..)" \
+ "$(git log -1 --format='%h')"
else
- echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ printf '0.r%s.g%s' \
+ "$(git rev-list --count master)" \
+ "$(git log -1 --format='%h')"
fi
}
prepare() {
cd iproute2/
- # allow operations on links called "h", "he", "hel", "help"
- patch -Np1 -i "${srcdir}/unwanted-link-help.patch"
-
# do not treat warnings as errors
sed -i 's/-Werror//' Makefile
}