summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2016-04-24 18:53:35 +0200
committerNicolas Iooss2016-04-24 18:53:35 +0200
commit00e61f716ddda10ba31acab96ee159524d15cbd0 (patch)
treee08b349fcc2c69a259fc6c1e1e8251a68f5c367a
parent80d9902891149d47685a678f464b9e20c07da25d (diff)
downloadaur-00e61f716ddda10ba31acab96ee159524d15cbd0.tar.gz
iproute2-selinux 4.5.0-2 update
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD15
-rw-r--r--tc.patch58
-rw-r--r--unwanted-link-help.patch17
4 files changed, 12 insertions, 93 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2b37fc041a2..5373ab98db69 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = iproute2-selinux
pkgdesc = IP Routing Utilities with SELinux support
- pkgver = 4.1.1
- pkgrel = 1
+ pkgver = 4.5.0
+ pkgrel = 2
url = http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2
arch = i686
arch = x86_64
@@ -13,7 +13,7 @@ pkgbase = iproute2-selinux
depends = libselinux
optdepends = linux-atm: ATM support
provides = iproute
- provides = iproute2=4.1.1-1
+ provides = iproute2=4.5.0-2
conflicts = iproute
conflicts = iproute2
replaces = iproute
@@ -25,14 +25,13 @@ pkgbase = iproute2-selinux
backup = etc/iproute2/rt_realms
backup = etc/iproute2/rt_scopes
backup = etc/iproute2/rt_tables
- source = http://www.kernel.org/pub/linux/utils/net/iproute2/iproute2-4.1.1.tar.xz
- source = http://www.kernel.org/pub/linux/utils/net/iproute2/iproute2-4.1.1.tar.sign
+ source = http://www.kernel.org/pub/linux/utils/net/iproute2/iproute2-4.5.0.tar.xz
+ source = http://www.kernel.org/pub/linux/utils/net/iproute2/iproute2-4.5.0.tar.sign
source = iproute2-fhs.patch
- source = unwanted-link-help.patch
- sha1sums = 750c17e720b43041c23fed7b8cf0118c0e841036
+ validpgpkeys = 9F6FC345B05BE7E766B83C8F80A77F6095CDE47E
+ sha1sums = f6271aaf9b24b9c465622bea8a29a883034d8d49
sha1sums = SKIP
sha1sums = 2dc6d8f1a2495a0d51eaa303dcc78ecc0c477935
- sha1sums = 3b1335f4025f657f388fbf4e5a740871e3129c2a
pkgname = iproute2-selinux
diff --git a/PKGBUILD b/PKGBUILD
index 0626b07fe48c..70873848467a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# SELinux Maintainer: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
pkgname=iproute2-selinux
-pkgver=4.1.1
-pkgrel=1
+pkgver=4.5.0
+pkgrel=2
pkgdesc="IP Routing Utilities with SELinux support"
arch=('i686' 'x86_64')
license=('GPL2')
@@ -22,12 +22,10 @@ backup=('etc/iproute2/ematch_map' 'etc/iproute2/rt_dsfield' 'etc/iproute2/rt_pro
'etc/iproute2/rt_realms' 'etc/iproute2/rt_scopes' 'etc/iproute2/rt_tables')
validpgpkeys=('9F6FC345B05BE7E766B83C8F80A77F6095CDE47E') # Stephen Hemminger
source=("http://www.kernel.org/pub/linux/utils/net/${pkgname/-selinux}/${pkgname/-selinux}-$pkgver.tar."{xz,sign}
- iproute2-fhs.patch
- unwanted-link-help.patch)
-sha1sums=('750c17e720b43041c23fed7b8cf0118c0e841036'
+ iproute2-fhs.patch)
+sha1sums=('f6271aaf9b24b9c465622bea8a29a883034d8d49'
'SKIP'
- '2dc6d8f1a2495a0d51eaa303dcc78ecc0c477935'
- '3b1335f4025f657f388fbf4e5a740871e3129c2a')
+ '2dc6d8f1a2495a0d51eaa303dcc78ecc0c477935')
prepare() {
cd "${srcdir}/${pkgname/-selinux}-${pkgver}"
@@ -35,9 +33,6 @@ prepare() {
# set correct fhs structure
patch -Np1 -i "${srcdir}/iproute2-fhs.patch"
- # allow operations on links called "h", "he", "hel", "help"
- patch -Np1 -i "${srcdir}/unwanted-link-help.patch"
-
# do not treat warnings as errors
sed -i 's/-Werror//' Makefile
diff --git a/tc.patch b/tc.patch
deleted file mode 100644
index 587150f2c5ba..000000000000
--- a/tc.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From 46679bbbe89699016d31486de7599590d02a5054 Mon Sep 17 00:00:00 2001
-From: Vadim Kochan <vadim4j@gmail.com>
-Date: Mon, 20 Apr 2015 08:33:32 +0300
-Subject: tc util: Fix possible buffer overflow when print class id
-
-Use correct handle buffer length.
-
-Signed-off-by: Vadim Kochan <vadim4j@gmail.com>
-
-diff --git a/tc/tc_util.c b/tc/tc_util.c
-index 1d3153d..dc2b70f 100644
---- a/tc/tc_util.c
-+++ b/tc/tc_util.c
-@@ -128,30 +128,31 @@ ok:
- return 0;
- }
-
--int print_tc_classid(char *buf, int len, __u32 h)
-+int print_tc_classid(char *buf, int blen, __u32 h)
- {
-- char handle[40] = {};
-+ SPRINT_BUF(handle) = {};
-+ int hlen = SPRINT_BSIZE - 1;
-
- if (h == TC_H_ROOT)
- sprintf(handle, "root");
- else if (h == TC_H_UNSPEC)
-- snprintf(handle, len, "none");
-+ snprintf(handle, hlen, "none");
- else if (TC_H_MAJ(h) == 0)
-- snprintf(handle, len, ":%x", TC_H_MIN(h));
-+ snprintf(handle, hlen, ":%x", TC_H_MIN(h));
- else if (TC_H_MIN(h) == 0)
-- snprintf(handle, len, "%x:", TC_H_MAJ(h) >> 16);
-+ snprintf(handle, hlen, "%x:", TC_H_MAJ(h) >> 16);
- else
-- snprintf(handle, len, "%x:%x", TC_H_MAJ(h) >> 16, TC_H_MIN(h));
-+ snprintf(handle, hlen, "%x:%x", TC_H_MAJ(h) >> 16, TC_H_MIN(h));
-
- if (use_names) {
- char clname[IDNAME_MAX] = {};
-
- if (id_to_name(cls_names, h, clname))
-- snprintf(buf, len, "%s#%s", clname, handle);
-+ snprintf(buf, blen, "%s#%s", clname, handle);
- else
-- snprintf(buf, len, "%s", handle);
-+ snprintf(buf, blen, "%s", handle);
- } else {
-- snprintf(buf, len, "%s", handle);
-+ snprintf(buf, blen, "%s", handle);
- }
-
- return 0;
---
-cgit v0.10.2
-
-
diff --git a/unwanted-link-help.patch b/unwanted-link-help.patch
deleted file mode 100644
index 8abe9e39d961..000000000000
--- a/unwanted-link-help.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff -ru iproute2-3.10.0.orig/ip/iplink.c iproute2-3.10.0/ip/iplink.c
---- iproute2-3.10.0.orig/ip/iplink.c 2013-08-08 13:53:33.000000000 -0700
-+++ iproute2-3.10.0/ip/iplink.c 2013-08-08 13:55:03.179865309 -0700
-@@ -467,11 +467,11 @@
- addattr_l(&req->n, sizeof(*req), IFLA_NUM_RX_QUEUES,
- &numrxqueues, 4);
- } else {
-+ if (matches(*argv, "help") == 0)
-+ usage();
- if (strcmp(*argv, "dev") == 0) {
- NEXT_ARG();
- }
-- if (matches(*argv, "help") == 0)
-- usage();
- if (*dev)
- duparg2("dev", *argv);
- *dev = *argv;