summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2014-05-25 22:14:06 +0200
committerNicolas Iooss2014-05-30 12:01:12 +0200
commit1976e29223e76e9f73af69a89a58adbf7f7cf782 (patch)
tree776f424c5ed30bd150f508b6d751e010b222fc7b
downloadaur-1976e29223e76e9f73af69a89a58adbf7f7cf782.tar.gz
Add iproute2-selinux 3.14.0-1 package
"ss" program requires iproute2 package to be compiled with SELinux support to enable "ss -Z" and "ss -z".
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD62
-rw-r--r--iproute2-fhs.patch75
-rw-r--r--unwanted-link-help.patch17
4 files changed, 189 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f507bfe993f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = iproute2-selinux
+ pkgdesc = IP Routing Utilities with SELinux support
+ pkgver = 3.14.0
+ pkgrel = 1
+ url = http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2
+ arch = i686
+ arch = x86_64
+ groups = base
+ license = GPL2
+ makedepends = linux-atm
+ depends = glibc
+ depends = iptables
+ optdepends = linux-atm: ATM support
+ provides = iproute
+ provides = iproute2=3.14.0-1
+ conflicts = iproute
+ conflicts = iproute2
+ replaces = iproute
+ options = staticlibs
+ options = !makeflags
+ backup = etc/iproute2/ematch_map
+ backup = etc/iproute2/rt_dsfield
+ backup = etc/iproute2/rt_protos
+ backup = etc/iproute2/rt_realms
+ backup = etc/iproute2/rt_scopes
+ backup = etc/iproute2/rt_tables
+ source = http://www.kernel.org/pub/linux/utils/net/iproute2/iproute2-3.14.0.tar.xz
+ source = iproute2-fhs.patch
+ source = unwanted-link-help.patch
+ sha1sums = 0b7d9db9e17da77a5bd8c2c75f6ddd607449ba3e
+ sha1sums = 35b8cf2dc94b73eccad427235c07596146cd6f6c
+ sha1sums = 3b1335f4025f657f388fbf4e5a740871e3129c2a
+
+pkgname = iproute2-selinux
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba69dcfdb8a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# $Id: PKGBUILD 210619 2014-04-15 20:43:33Z ronald $
+# Maintainer: Ronald van Haren <ronald.archlinux.org>
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
+# SELinux Contributor: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
+
+pkgname=iproute2-selinux
+pkgver=3.14.0
+pkgrel=1
+pkgdesc="IP Routing Utilities with SELinux support"
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2"
+depends=('glibc' 'iptables')
+makedepends=('linux-atm')
+optdepends=('linux-atm: ATM support')
+groups=('base')
+provides=('iproute' "${pkgname/-selinux}=${pkgver}-${pkgrel}")
+conflicts=('iproute' "${pkgname/-selinux}")
+replaces=('iproute')
+options=('staticlibs' '!makeflags')
+backup=('etc/iproute2/ematch_map' 'etc/iproute2/rt_dsfield' 'etc/iproute2/rt_protos' \
+ 'etc/iproute2/rt_realms' 'etc/iproute2/rt_scopes' 'etc/iproute2/rt_tables')
+source=(http://www.kernel.org/pub/linux/utils/net/${pkgname/-selinux}/${pkgname/-selinux}-$pkgver.tar.xz
+ iproute2-fhs.patch
+ unwanted-link-help.patch)
+sha1sums=('0b7d9db9e17da77a5bd8c2c75f6ddd607449ba3e'
+ '35b8cf2dc94b73eccad427235c07596146cd6f6c'
+ '3b1335f4025f657f388fbf4e5a740871e3129c2a')
+
+prepare() {
+ cd $srcdir/${pkgname/-selinux}-$pkgver
+
+ # set correct fhs structure
+ patch -Np1 -i "$srcdir/iproute2-fhs.patch"
+
+ # allow operations on links called "h", "he", "hel", "help"
+ patch -Np1 -i "$srcdir/unwanted-link-help.patch"
+
+ # do not treat warnings as errors
+ sed -i 's/-Werror//' Makefile
+}
+
+build() {
+ cd "$srcdir/${pkgname/-selinux}-$pkgver"
+
+ ./configure --with-selinux
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname/-selinux}-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+
+ # libnetlink isn't installed, install it FS#19385
+ install -Dm644 include/libnetlink.h "$pkgdir/usr/include/libnetlink.h"
+ install -Dm644 lib/libnetlink.a "$pkgdir/usr/lib/libnetlink.a"
+
+ # usrmove
+ cd "$pkgdir"
+ mv usr/sbin usr/bin
+}
diff --git a/iproute2-fhs.patch b/iproute2-fhs.patch
new file mode 100644
index 000000000000..add3635ca587
--- /dev/null
+++ b/iproute2-fhs.patch
@@ -0,0 +1,75 @@
+diff -Naur iproute2-3.4.0/Makefile iproute2-3.4.0.new/Makefile
+--- iproute2-3.4.0/Makefile 2012-05-21 23:12:19.000000000 +0200
++++ iproute2-3.4.0.new/Makefile 2012-06-18 10:23:53.896760158 +0200
+@@ -1,7 +1,8 @@
+ ROOTDIR=$(DESTDIR)
+ PREFIX=/usr
+ LIBDIR=$(PREFIX)/lib
+-SBINDIR=/sbin
++SBINDIR=/usr/sbin
++SHAREDIR=/usr/share
+ CONFDIR=/etc/iproute2
+ DATADIR=$(PREFIX)/share
+ DOCDIR=$(DATADIR)/doc/iproute2
+diff -Naur iproute2-3.4.0/netem/Makefile iproute2-3.4.0.new/netem/Makefile
+--- iproute2-3.4.0/netem/Makefile 2012-05-21 23:12:19.000000000 +0200
++++ iproute2-3.4.0.new/netem/Makefile 2012-06-18 10:23:53.896760158 +0200
+@@ -20,9 +20,9 @@
+ $(HOSTCC) $(CCOPTS) -I../include -o $@ $@.c -lm
+
+ install: all
+- mkdir -p $(DESTDIR)$(LIBDIR)/tc
++ mkdir -p $(DESTDIR)$(SHAREDIR)/tc
+ for i in $(DISTDATA); \
+- do install -m 644 $$i $(DESTDIR)$(LIBDIR)/tc; \
++ do install -m 644 $$i $(DESTDIR)$(SHAREDIR)/tc; \
+ done
+
+ clean:
+diff -Naur iproute2-3.4.0/tc/Makefile iproute2-3.4.0.new/tc/Makefile
+--- iproute2-3.4.0/tc/Makefile 2012-05-21 23:12:19.000000000 +0200
++++ iproute2-3.4.0.new/tc/Makefile 2012-06-18 10:23:53.893426840 +0200
+@@ -105,18 +105,11 @@
+ $(AR) rcs $@ $(TCLIB)
+
+ install: all
+- mkdir -p $(MODDESTDIR)
++ mkdir -p $(DESTDIR)$(LIBDIR)/tc
+ install -m 0755 tc $(DESTDIR)$(SBINDIR)
+ for i in $(TCSO); \
+- do install -m 755 $$i $(MODDESTDIR); \
++ do install -m 755 $$i $(DESTDIR)$(LIBDIR)/tc; \
+ done
+- if [ ! -f $(MODDESTDIR)/m_ipt.so ]; then \
+- if [ -f $(MODDESTDIR)/m_xt.so ]; \
+- then ln -s m_xt.so $(MODDESTDIR)/m_ipt.so ; \
+- elif [ -f $(MODDESTDIR)/m_xt_old.so ]; \
+- then ln -s m_xt_old.so $(MODDESTDIR)/m_ipt.so ; \
+- fi; \
+- fi
+
+ clean:
+ rm -f $(TCOBJ) $(TCLIB) libtc.a tc *.so emp_ematch.yacc.h; \
+diff -Naur iproute2-3.4.0/tc/tc_util.c iproute2-3.4.0.new/tc/tc_util.c
+--- iproute2-3.4.0/tc/tc_util.c 2012-05-21 23:12:19.000000000 +0200
++++ iproute2-3.4.0.new/tc/tc_util.c 2012-06-18 10:23:53.893426840 +0200
+@@ -24,8 +24,8 @@
+ #include "utils.h"
+ #include "tc_util.h"
+
+-#ifndef LIBDIR
+-#define LIBDIR "/usr/lib"
++#ifndef SHAREDIR
++#define SHAREDIR "/usr/share"
+ #endif
+
+ const char *get_tc_lib(void)
+@@ -34,7 +34,7 @@
+
+ lib_dir = getenv("TC_LIB_DIR");
+ if (!lib_dir)
+- lib_dir = LIBDIR "/tc/";
++ lib_dir = SHAREDIR "/tc/";
+
+ return lib_dir;
+ }
diff --git a/unwanted-link-help.patch b/unwanted-link-help.patch
new file mode 100644
index 000000000000..8abe9e39d961
--- /dev/null
+++ b/unwanted-link-help.patch
@@ -0,0 +1,17 @@
+diff -ru iproute2-3.10.0.orig/ip/iplink.c iproute2-3.10.0/ip/iplink.c
+--- iproute2-3.10.0.orig/ip/iplink.c 2013-08-08 13:53:33.000000000 -0700
++++ iproute2-3.10.0/ip/iplink.c 2013-08-08 13:55:03.179865309 -0700
+@@ -467,11 +467,11 @@
+ addattr_l(&req->n, sizeof(*req), IFLA_NUM_RX_QUEUES,
+ &numrxqueues, 4);
+ } else {
++ if (matches(*argv, "help") == 0)
++ usage();
+ if (strcmp(*argv, "dev") == 0) {
+ NEXT_ARG();
+ }
+- if (matches(*argv, "help") == 0)
+- usage();
+ if (*dev)
+ duparg2("dev", *argv);
+ *dev = *argv;