summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2020-01-25 09:15:59 +0100
committerNicolas Iooss2020-01-25 09:15:59 +0100
commit42d4c8ed3cf131e765632daa6f7517e82f175312 (patch)
treedf3bfd12623cdfacbe72a74a66df938b3b674a35
parentfc9fc3770d90ffd3d1982ba0515d2dd351de6a29 (diff)
downloadaur-42d4c8ed3cf131e765632daa6f7517e82f175312.tar.gz
iproute2-selinux 5.4.0-2 update
-rw-r--r--.SRCINFO6
-rw-r--r--0002-ss-fix-end-of-line-printing.patch39
-rw-r--r--PKGBUILD13
3 files changed, 52 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 966ee40dfa03..7c523635ccd7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = iproute2-selinux
pkgdesc = IP Routing Utilities with SELinux support
pkgver = 5.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://git.kernel.org/pub/scm/network/iproute2/iproute2.git
arch = x86_64
groups = selinux
@@ -13,7 +13,7 @@ pkgbase = iproute2-selinux
depends = libselinux
optdepends = linux-atm: ATM support
provides = iproute
- provides = iproute2=5.4.0-1
+ provides = iproute2=5.4.0-2
conflicts = iproute2
options = staticlibs
backup = etc/iproute2/ematch_map
@@ -25,10 +25,12 @@ pkgbase = iproute2-selinux
source = https://www.kernel.org/pub/linux/utils/net/iproute2/iproute2-5.4.0.tar.xz
source = https://www.kernel.org/pub/linux/utils/net/iproute2/iproute2-5.4.0.tar.sign
source = 0001-make-iproute2-fhs-compliant.patch
+ source = 0002-ss-fix-end-of-line-printing.patch
validpgpkeys = 9F6FC345B05BE7E766B83C8F80A77F6095CDE47E
sha256sums = fe97aa60a0d4c5ac830be18937e18dc3400ca713a33a89ad896ff1e3d46086ae
sha256sums = SKIP
sha256sums = f60fefe4c17d3b768824bb50ae6416292bcebba06d73452e23f4147b46b827d3
+ sha256sums = 79cb0378988c7f58c2769a3333bae95b94cbd867c8d88e7331df8f5038d2cc6a
pkgname = iproute2-selinux
diff --git a/0002-ss-fix-end-of-line-printing.patch b/0002-ss-fix-end-of-line-printing.patch
new file mode 100644
index 000000000000..600aeed57f8e
--- /dev/null
+++ b/0002-ss-fix-end-of-line-printing.patch
@@ -0,0 +1,39 @@
+From 9eee92a41ae630b2c9e92ae2875ca56801c96b73 Mon Sep 17 00:00:00 2001
+From: Brian Vazquez <brianvv@google.com>
+Date: Wed, 4 Dec 2019 13:32:28 -0800
+Subject: ss: fix end-of-line printing in misc/ss.c
+
+The previous change to ss to show header broke the printing of
+end-of-line for the last entry.
+
+Tested:
+
+diff <(./ss.old -nltp) <(misc/ss -nltp)
+38c38
+< LISTEN 0 128 [::1]:35417 [::]:* users:(("foo",pid=65254,fd=116))
+\ No newline at end of file
+
+Signed-off-by: Stephen Hemminger <stephen@networkplumber.org>
+---
+ misc/ss.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/misc/ss.c b/misc/ss.c
+index c58e5c4d..95f1d37a 100644
+--- a/misc/ss.c
++++ b/misc/ss.c
+@@ -1290,6 +1290,11 @@ static void render(void)
+
+ token = buf_token_next(token);
+ }
++ /* Deal with final end-of-line when the last non-empty field printed
++ * is not the last field.
++ */
++ if (line_started)
++ printf("\n");
+
+ buf_free_all();
+ current_field = columns;
+--
+cgit 1.2-0.3.lf.el7
+
diff --git a/PKGBUILD b/PKGBUILD
index 2d93f3abf958..537e0140fc19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=iproute2-selinux
pkgver=5.4.0
-pkgrel=1
+pkgrel=2
pkgdesc='IP Routing Utilities with SELinux support'
arch=('x86_64')
license=('GPL2')
@@ -28,16 +28,21 @@ makedepends=('linux-atm')
options=('staticlibs')
validpgpkeys=('9F6FC345B05BE7E766B83C8F80A77F6095CDE47E') # Stephen Hemminger
source=("https://www.kernel.org/pub/linux/utils/net/${pkgname/-selinux}/${pkgname/-selinux}-${pkgver}.tar."{xz,sign}
- '0001-make-iproute2-fhs-compliant.patch')
+ '0001-make-iproute2-fhs-compliant.patch'
+ '0002-ss-fix-end-of-line-printing.patch')
sha256sums=('fe97aa60a0d4c5ac830be18937e18dc3400ca713a33a89ad896ff1e3d46086ae'
'SKIP'
- 'f60fefe4c17d3b768824bb50ae6416292bcebba06d73452e23f4147b46b827d3')
+ 'f60fefe4c17d3b768824bb50ae6416292bcebba06d73452e23f4147b46b827d3'
+ '79cb0378988c7f58c2769a3333bae95b94cbd867c8d88e7331df8f5038d2cc6a')
prepare() {
cd "${srcdir}/${pkgname/-selinux}-${pkgver}"
# set correct fhs structure
- patch -Np1 -i "${srcdir}/0001-make-iproute2-fhs-compliant.patch"
+ patch -Np1 -i "${srcdir}"/0001-make-iproute2-fhs-compliant.patch
+
+ # ss: fix end-of-line printing
+ patch -Np1 -i "${srcdir}"/0002-ss-fix-end-of-line-printing.patch
# do not treat warnings as errors
sed -i 's/-Werror//' Makefile