summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2022-12-17 12:42:14 +0100
committerNicolas Iooss2022-12-17 12:42:14 +0100
commit8891d0b8e037cacb554e0cc524668bf41caaac9e (patch)
treeb033eb01a277c68a6f872db8afc5963c0f847114
parent533de3cd9c5d8e87e37d4c7b161ef7becae2164b (diff)
downloadaur-8891d0b8e037cacb554e0cc524668bf41caaac9e.tar.gz
iproute2-selinux 6.1.0-3 update
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
-rw-r--r--bdb5.3.patch22
3 files changed, 44 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62713d331249..80594da0fa62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = iproute2-selinux
pkgdesc = IP Routing Utilities with SELinux support
- pkgver = 6.0.0
- pkgrel = 1
+ pkgver = 6.1.0
+ pkgrel = 3
url = https://git.kernel.org/pub/scm/network/iproute2/iproute2.git
arch = x86_64
arch = aarch64
@@ -13,11 +13,11 @@ pkgbase = iproute2-selinux
depends = libelf
depends = libbpf
depends = libselinux
- optdepends = db: userspace arp daemon
+ optdepends = db5.3: userspace arp daemon
optdepends = libcap: tipc
optdepends = linux-atm: ATM support
provides = iproute
- provides = iproute2=6.0.0-1
+ provides = iproute2=6.1.0-3
conflicts = iproute2
options = staticlibs
backup = etc/iproute2/bpf_pinning
@@ -29,12 +29,14 @@ pkgbase = iproute2-selinux
backup = etc/iproute2/rt_realms
backup = etc/iproute2/rt_scopes
backup = etc/iproute2/rt_tables
- source = https://www.kernel.org/pub/linux/utils/net/iproute2/iproute2-6.0.0.tar.xz
- source = https://www.kernel.org/pub/linux/utils/net/iproute2/iproute2-6.0.0.tar.sign
+ source = https://www.kernel.org/pub/linux/utils/net/iproute2/iproute2-6.1.0.tar.xz
+ source = https://www.kernel.org/pub/linux/utils/net/iproute2/iproute2-6.1.0.tar.sign
source = 0001-make-iproute2-fhs-compliant.patch
+ source = bdb5.3.patch
validpgpkeys = 9F6FC345B05BE7E766B83C8F80A77F6095CDE47E
- sha256sums = 523139e9e72aec996374fa2de74be4c53d2dd05589488934d21ff97bae19580a
+ sha256sums = 5ce12a0fec6b212725ef218735941b2dab76244db7e72646a76021b0537b43ab
sha256sums = SKIP
sha256sums = 758b82bd61ed7512d215efafd5fab5ae7a28fbfa6161b85e2ce7373285e56a5d
+ sha256sums = 908de44ee99bf78669e7c513298fc2a22ca9d7e816a8f99788b1e9b091035cf4
pkgname = iproute2-selinux
diff --git a/PKGBUILD b/PKGBUILD
index 1ed8e15e6024..867d7b2663e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,15 +7,16 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgname=iproute2-selinux
-pkgver=6.0.0
-pkgrel=1
+pkgver=6.1.0
+pkgrel=3
pkgdesc='IP Routing Utilities with SELinux support'
arch=('x86_64' 'aarch64')
license=('GPL2')
groups=('selinux')
url='https://git.kernel.org/pub/scm/network/iproute2/iproute2.git'
depends=('glibc' 'iptables' 'libelf' 'libbpf' 'libselinux')
-optdepends=('db: userspace arp daemon'
+makedepends=('db5.3')
+optdepends=('db5.3: userspace arp daemon'
'libcap: tipc'
'linux-atm: ATM support')
provides=('iproute' "${pkgname/-selinux}=${pkgver}-${pkgrel}")
@@ -33,10 +34,12 @@ makedepends=('linux-atm')
options=('staticlibs')
validpgpkeys=('9F6FC345B05BE7E766B83C8F80A77F6095CDE47E') # Stephen Hemminger
source=("https://www.kernel.org/pub/linux/utils/net/${pkgname/-selinux}/${pkgname/-selinux}-${pkgver}.tar."{xz,sign}
- '0001-make-iproute2-fhs-compliant.patch')
-sha256sums=('523139e9e72aec996374fa2de74be4c53d2dd05589488934d21ff97bae19580a'
+ '0001-make-iproute2-fhs-compliant.patch'
+ 'bdb5.3.patch')
+sha256sums=('5ce12a0fec6b212725ef218735941b2dab76244db7e72646a76021b0537b43ab'
'SKIP'
- '758b82bd61ed7512d215efafd5fab5ae7a28fbfa6161b85e2ce7373285e56a5d')
+ '758b82bd61ed7512d215efafd5fab5ae7a28fbfa6161b85e2ce7373285e56a5d'
+ '908de44ee99bf78669e7c513298fc2a22ca9d7e816a8f99788b1e9b091035cf4')
prepare() {
cd "${srcdir}/${pkgname/-selinux}-${pkgver}"
@@ -44,6 +47,9 @@ prepare() {
# set correct fhs structure
patch -Np1 -i "${srcdir}"/0001-make-iproute2-fhs-compliant.patch
+ # use Berkeley DB 5.3
+ patch -Np1 -i "${srcdir}"/bdb5.3.patch
+
# do not treat warnings as errors
sed -i 's/-Werror//' Makefile
@@ -57,7 +63,7 @@ build() {
# ./configure auto-detects SELinux as a build dependency for "ss":
# https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/tree/configure?h=v5.14.0#n373
./configure
- make
+ make DBM_INCLUDE='/usr/include/db5.3'
}
package() {
diff --git a/bdb5.3.patch b/bdb5.3.patch
new file mode 100644
index 000000000000..82c0694a7a45
--- /dev/null
+++ b/bdb5.3.patch
@@ -0,0 +1,22 @@
+--- aaa/configure 2022-12-13 01:08:01.607329918 +0100
++++ bbb/configure 2022-12-13 01:08:58.083857594 +0100
+@@ -433,7 +433,7 @@
+ return 0;
+ }
+ EOF
+- if $CC -I$INCLUDE -o $TMPDIR/dbtest $TMPDIR/dbtest.c -ldb >/dev/null 2>&1; then
++ if $CC -I$INCLUDE -I/usr/include/db5.3 -o $TMPDIR/dbtest $TMPDIR/dbtest.c -ldb-5.3 >/dev/null 2>&1; then
+ echo "HAVE_BERKELEY_DB:=y" >>$CONFIG
+ echo "yes"
+ else
+--- aaa/misc/Makefile 2022-12-13 12:21:04.709608051 +0100
++++ bbb/misc/Makefile 2022-12-13 12:21:19.966264418 +0100
+@@ -25,7 +25,7 @@
+ $(QUIET_CC)$(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o rtacct rtacct.c $(LDLIBS) -lm
+
+ arpd: arpd.c
+- $(QUIET_CC)$(CC) $(CFLAGS) -I$(DBM_INCLUDE) $(CPPFLAGS) $(LDFLAGS) -o arpd arpd.c $(LDLIBS) -ldb
++ $(QUIET_CC)$(CC) $(CFLAGS) -I$(DBM_INCLUDE) $(CPPFLAGS) $(LDFLAGS) -o arpd arpd.c $(LDLIBS) -ldb-5.3
+
+ ssfilter.tab.c: ssfilter.y
+ $(QUIET_YACC)$(YACC) -b ssfilter ssfilter.y