summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormax.bra2016-12-16 22:01:03 +0100
committermax.bra2016-12-16 22:01:03 +0100
commit3ee721542ba5176c2dcceced666b300fc621c3b4 (patch)
treef2e7f130b730540bf59670c519ca747b8ae92a49
parentd595e7262d2f21cebae2d330e66d582c00004a44 (diff)
downloadaur-3ee721542ba5176c2dcceced666b300fc621c3b4.tar.gz
v. 3.5
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac4bddda4f01..4135703f0f89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ipscan
pkgdesc = Angry IP Scanner (or simply ipscan) is an open-source and cross-platform network scanner designed to be fast and simple to use. It scans IP addresses and ports as well as has many other features.
- pkgver = 3.4.2
+ pkgver = 3.5
pkgrel = 1
url = http://www.angryziber.com
arch = i686
@@ -10,18 +10,17 @@ pkgbase = ipscan
noextract = ipscan.png
noextract = ipscan
noextract = ipscan.desktop
- noextract = ipscan-linux-3.4.2.jar
- noextract = ipscan-linux64-3.4.2.jar
+ noextract = ipscan-linux64-3.5.jar
source = ipscan.png
source = ipscan
source = ipscan.desktop
md5sums = 59de9b8055fe037c77bf8339eee31b85
md5sums = 5b1c941c32a444803677a2061aa55a70
md5sums = 6a8f7a0fb70cf2c801ff5422870609f9
- source_i686 = http://downloads.sourceforge.net/project/ipscan/ipscan3-binary/3.4.2/ipscan-linux-3.4.2.jar
- md5sums_i686 = 37aa7d182817d2cccaddb843b0e946e1
- source_x86_64 = http://downloads.sourceforge.net/project/ipscan/ipscan3-binary/3.4.2/ipscan-linux64-3.4.2.jar
- md5sums_x86_64 = be202c9d60671c6069a8a93377b27692
+ source_i686 = https://github.com/angryziber/ipscan/releases/download/3.5/ipscan-linux64-3.5.jar
+ md5sums_i686 = d9e4bda4f4ed7b4b3682bcd689a3db9d
+ source_x86_64 = https://github.com/angryziber/ipscan/releases/download/3.5/ipscan-linux64-3.5.jar
+ md5sums_x86_64 = c80ff3f37a6a982151bd7f31fbfd6e16
pkgname = ipscan
diff --git a/PKGBUILD b/PKGBUILD
index 79a5759c6c15..7b9eb46e0ac1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Maintainer: max.bra <max dot bra at alice dot it>
pkgname=ipscan
-pkgver=3.4.2
-_pkgintver=3.4.2
+pkgver=3.5
+_pkgintver=3.5
pkgrel=1
pkgdesc='Angry IP Scanner (or simply ipscan) is an open-source and cross-platform network scanner designed to be fast and simple to use. It scans IP addresses and ports as well as has many other features.'
arch=('i686' 'x86_64')
@@ -16,17 +16,17 @@ depends=('java-runtime>=6')
source=(ipscan.png \
ipscan \
- ipscan.desktop )
-source_i686+=(http://downloads.sourceforge.net/project/ipscan/ipscan3-binary/$_pkgintver/ipscan-linux-$_pkgintver.jar)
-source_x86_64+=(http://downloads.sourceforge.net/project/ipscan/ipscan3-binary/$_pkgintver/ipscan-linux64-$_pkgintver.jar)
+ ipscan.desktop)
+source_i686+=(https://github.com/angryziber/ipscan/releases/download/$_pkgintver/ipscan-$_intarch-$_pkgintver.jar)
+source_x86_64+=(https://github.com/angryziber/ipscan/releases/download/$_pkgintver/ipscan-$_intarch-$_pkgintver.jar)
md5sums=('59de9b8055fe037c77bf8339eee31b85'
'5b1c941c32a444803677a2061aa55a70'
'6a8f7a0fb70cf2c801ff5422870609f9')
-md5sums_i686=('37aa7d182817d2cccaddb843b0e946e1')
-md5sums_x86_64=('be202c9d60671c6069a8a93377b27692')
+md5sums_i686=('d9e4bda4f4ed7b4b3682bcd689a3db9d')
+md5sums_x86_64=('c80ff3f37a6a982151bd7f31fbfd6e16')
-noextract=($(for i in ${source[@]}; do basename $i; done) ipscan-linux-$_pkgintver.jar ipscan-linux64-$_pkgintver.jar)
+noextract=($(for i in ${source[@]}; do basename $i; done) ipscan-$_intarch-$_pkgintver.jar)
build() {
/bin/true