summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormax.bra2015-06-08 12:15:22 +0200
committermax.bra2015-06-08 12:15:22 +0200
commit75596dca4306eed3e508ca254d53f74da5a510f6 (patch)
tree8221e646760226a6b49a6fe4612291be3212a1f3
downloadaur-75596dca4306eed3e508ca254d53f74da5a510f6.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD42
-rwxr-xr-xipscan2
-rw-r--r--ipscan.desktop12
-rw-r--r--ipscan.pngbin0 -> 4557 bytes
5 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7eb129849efd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = ipscan
+ pkgdesc = Angry IP Scanner (or simply ipscan) is an open-source and cross-platform network scanner designed to be fast and simple to use. It scans IP addresses and ports as well as has many other features.
+ pkgver = 3.3.2
+ pkgrel = 2
+ url = http://www.angryziber.com
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = java-runtime>=6
+ noextract = ipscan.png
+ noextract = ipscan
+ noextract = ipscan.desktop
+ noextract = ipscan-linux-3.3.2.jar
+ noextract = ipscan-linux64-3.3.2.jar
+ source = ipscan.png
+ source = ipscan
+ source = ipscan.desktop
+ md5sums = 59de9b8055fe037c77bf8339eee31b85
+ md5sums = 5b1c941c32a444803677a2061aa55a70
+ md5sums = 6a8f7a0fb70cf2c801ff5422870609f9
+ source_i686 = http://downloads.sourceforge.net/project/ipscan/ipscan3-binary/3.3.2/ipscan-linux-3.3.2.jar
+ md5sums_i686 = 6be98cb45385736d52c11dac5af0fc69
+ source_x86_64 = http://downloads.sourceforge.net/project/ipscan/ipscan3-binary/3.3.2/ipscan-linux64-3.3.2.jar
+ md5sums_x86_64 = f6cbc4ca4109d6cdb32a0f31723a20db
+
+pkgname = ipscan
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e740db188cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Contributor: Rorschach <r0schach@lavabit.com>
+# Maintainer: max.bra <max dot bra at alice dot it>
+
+pkgname=ipscan
+pkgver=3.3.2
+_pkgintver=3.3.2
+pkgrel=2
+pkgdesc='Angry IP Scanner (or simply ipscan) is an open-source and cross-platform network scanner designed to be fast and simple to use. It scans IP addresses and ports as well as has many other features.'
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="http://www.angryziber.com"
+depends=('java-runtime>=6')
+
+[[ $CARCH == "i686" ]] && _intarch=linux
+[[ $CARCH == "x86_64" ]] && _intarch=linux64
+
+source=(ipscan.png \
+ ipscan \
+ ipscan.desktop )
+source_i686+=(http://downloads.sourceforge.net/project/ipscan/ipscan3-binary/$_pkgintver/ipscan-linux-$_pkgintver.jar)
+source_x86_64+=(http://downloads.sourceforge.net/project/ipscan/ipscan3-binary/$_pkgintver/ipscan-linux64-$_pkgintver.jar)
+
+md5sums=('59de9b8055fe037c77bf8339eee31b85'
+ '5b1c941c32a444803677a2061aa55a70'
+ '6a8f7a0fb70cf2c801ff5422870609f9')
+md5sums_i686=('6be98cb45385736d52c11dac5af0fc69')
+md5sums_x86_64=('f6cbc4ca4109d6cdb32a0f31723a20db')
+
+noextract=($(for i in ${source[@]}; do basename $i; done) ipscan-linux-$_pkgintver.jar ipscan-linux64-$_pkgintver.jar)
+
+build() {
+ /bin/true
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm755 $pkgname $pkgdir/usr/bin/$pkgname || return 1
+ install -Dm644 $pkgname.png $pkgdir/usr/share/pixmaps/$pkgname.png || return 1
+ install -Dm644 $pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop || return 1
+ install -Dm644 $pkgname-$_intarch-$_pkgintver.jar $pkgdir/usr/share/java/$pkgname/$pkgname-$_intarch-$_pkgintver.jar || return 1
+}
+
diff --git a/ipscan b/ipscan
new file mode 100755
index 000000000000..3f3ce1d35318
--- /dev/null
+++ b/ipscan
@@ -0,0 +1,2 @@
+#!/bin/sh
+java -jar /usr/share/java/ipscan/ipscan*.jar "$@"
diff --git a/ipscan.desktop b/ipscan.desktop
new file mode 100644
index 000000000000..742c30a95413
--- /dev/null
+++ b/ipscan.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Angry IP Scanner
+Comment=Fast and friendly network scanner
+GenericName=Fast and friendly network scanner
+Exec=/usr/bin/ipscan
+Terminal=false
+Type=Application
+Icon=ipscan
+Categories=Application;Network;Internet;
+StartupWMClass=Angry IP Scanner
+StartupNotify=true
diff --git a/ipscan.png b/ipscan.png
new file mode 100644
index 000000000000..3e0c47fc11c9
--- /dev/null
+++ b/ipscan.png
Binary files differ