summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgoreleaserbot2023-12-26 10:55:47 -0700
committergoreleaserbot2023-12-26 10:55:47 -0700
commit7731116e61f81c5c49ac94853e7b1498f5887d39 (patch)
treeab4faf2224e7b3d01c652f5aededb32eb189c2f6
downloadaur-7731116e61f81c5c49ac94853e7b1498f5887d39.tar.gz
Update to v3.1.441
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD44
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e487e68c553b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ipswd-bin
+ pkgdesc = ipsw - Daemon
+ pkgver = 3.1.441
+ pkgrel = 1
+ url = https://github.com/blacktop/ipsw
+ license = MIT
+ conflicts = ipsw
+ provides = ipsw
+ arch = aarch64
+ source_aarch64 = https://github.com/blacktop/ipsw/releases/download/v3.1.441/ipswd_3.1.441_linux_arm64.tar.gz
+ sha256sums_aarch64 = 4c2bdbd533da7e789bd133eaecd104606f59bd7fd7fdefa72cf55c6c735b29a1
+ arch = x86_64
+ source_x86_64 = https://github.com/blacktop/ipsw/releases/download/v3.1.441/ipswd_3.1.441_linux_x86_64.tar.gz
+ sha256sums_x86_64 = 67ef02d6b7f29496c5bbfce69f051a4bec727f2bcec9e75712f0181ec7ab0951
+
+pkgname = ipswd-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7992875f6134
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# This file was generated by GoReleaser. DO NOT EDIT.
+# Maintainer: Blacktop <https://github.com/blacktop>
+
+pkgname='ipswd-bin'
+pkgver=3.1.441
+pkgrel=1
+pkgdesc='ipsw - Daemon'
+url='https://github.com/blacktop/ipsw'
+arch=('aarch64' 'x86_64')
+license=('MIT')
+provides=('ipsw')
+conflicts=('ipsw')
+backup=('etc/ipsw.conf')
+
+source_aarch64=("${pkgname}_${pkgver}_aarch64.tar.gz::https://github.com/blacktop/ipsw/releases/download/v3.1.441/ipswd_3.1.441_linux_arm64.tar.gz")
+sha256sums_aarch64=('4c2bdbd533da7e789bd133eaecd104606f59bd7fd7fdefa72cf55c6c735b29a1')
+
+source_x86_64=("${pkgname}_${pkgver}_x86_64.tar.gz::https://github.com/blacktop/ipsw/releases/download/v3.1.441/ipswd_3.1.441_linux_x86_64.tar.gz")
+sha256sums_x86_64=('67ef02d6b7f29496c5bbfce69f051a4bec727f2bcec9e75712f0181ec7ab0951')
+
+package() {
+ cd ipswd_${pkgver}_linux_${CHOST%%-*}
+
+ # bin
+ install -Dm755 "./ipswd" "${pkgdir}/usr/bin/ipswd"
+
+ # license
+ install -Dm644 "./LICENSE" "${pkgdir}/usr/share/licenses/ipswd/LICENSE"
+
+ # completions
+ mkdir -p "${pkgdir}/usr/share/bash-completion/completions/"
+ mkdir -p "${pkgdir}/usr/share/zsh/site-functions/"
+ mkdir -p "${pkgdir}/usr/share/fish/vendor_completions.d/"
+ install -Dm644 "./completions/ipswd/_bash" "${pkgdir}/usr/share/bash-completion/completions/ipswd"
+ install -Dm644 "./completions/ipswd/_zsh" "${pkgdir}/usr/share/zsh/site-functions/_ipswd"
+ install -Dm644 "./completions/ipswd/_fish" "${pkgdir}/usr/share/fish/vendor_completions.d/ipswd.fish"
+
+ # man pages
+ install -Dm644 "./manpages/ipswd.1.gz" "${pkgdir}/usr/share/man/man1/ipswd.1.gz"
+
+ # config
+ mkdir -p "${pkgdir}/etc"
+ install -Dm644 "./config.example.yml" "${pkgdir}/etc/ipsw.conf"
+}