summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2018-08-07 20:26:20 +0700
committerKonstantin Shalygin2018-08-07 20:26:20 +0700
commit59e8fe3b6b168e9c2ac88b449c193600e27dd0c8 (patch)
tree61ff8673c98ec3cb3d5b705f14a57ab0bdfeec11
parentef062104a4c3722edec636a506bfd57b0649bbe9 (diff)
downloadaur-59e8fe3b6b168e9c2ac88b449c193600e27dd0c8.tar.gz
Allow to define custom linux_localversion.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
-rw-r--r--ipt_iftag.install3
3 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12c7b299d069..ae76266eaae4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue Aug 7 12:35:00 UTC 2018
+# Tue Aug 7 13:25:55 UTC 2018
pkgbase = ipt_iftag
pkgdesc = Netfilter extension that can operate on groups of interfaces.
pkgver = 9.abea132
diff --git a/PKGBUILD b/PKGBUILD
index 7df81e11fc62..6b52078158ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,11 @@ makedepends=('git' 'libtool' 'gcc' 'gzip' 'gawk' 'sed')
source=("${pkgname}::git+${url}")
sha256sums=('SKIP')
install="${pkgname}.install"
+# define 'lts' for linux-lts package
_linux_custom="ARCH"
-_kernver="`pacman -Ql linux| awk '/(\/modules\/)([0-9.-])+-(.*)-'${_linux_custom}'\/$/ {print $2}'`"
+# define '-lts' for linux-lts package
+_linux_localversion=""
+_kernver="`pacman -Ql linux${_linux_localversion} | awk '/(\/modules\/)([0-9.-])+-(.*)-'${_linux_custom}'\/$/ {print $2}'`"
pkgver() {
cd "${srcdir}/${pkgname}"
diff --git a/ipt_iftag.install b/ipt_iftag.install
index 4ce6a8b84a05..7e23df41c074 100644
--- a/ipt_iftag.install
+++ b/ipt_iftag.install
@@ -1,6 +1,7 @@
post_install() {
linux_custom="ARCH"
- kernver="`pacman -Ql linux|gawk 'match($0, /^(.*)modules\/([0-9.-]+-(.*)-'${linux_custom}')\/$/, a) {print a[2]}'`"
+ linux_localversion=""
+ kernver="`pacman -Ql linux${linux_localversion} | gawk 'match($0, /^(.*)modules\/([0-9.-]+-(.*)-'${linux_custom}')\/$/, a) {print a[2]}'`"
echo -e "Probe modules"
depmod ${kernver}
}