summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorK-Guan2015-09-06 23:45:25 +0800
committerK-Guan2015-09-06 23:45:25 +0800
commitdc657916b88244a49b46a38cd67f03c3cdfa7d15 (patch)
treee8716990f3a1c4dd0e2e66b287c8b4939ca743cd
downloadaur-dc657916b88244a49b46a38cd67f03c3cdfa7d15.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rwxr-xr-xPKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..780fba6ec13b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = iptux
+ pkgdesc = A software for sharing in LAN
+ pkgver = 0.6.2
+ pkgrel = 1
+ url = https://github.com/iptux-src/iptux/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = make
+ depends = autoconf
+ depends = libtool
+ depends = automake
+ source = https://codeload.github.com/iptux-src/iptux/tar.gz/v0.6.2
+ sha256sums = d567096d97b3b168dde1510f0ca00a13c6f8bb596131c234482377d7d8fb211b
+
+pkgname = iptux
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..4292144ef5ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Kevin Guan <KevinGuan.gm@gmail.com>
+
+pkgname=iptux
+pkgver=0.6.2
+pkgrel=1
+pkgdesc="A software for sharing in LAN"
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="https://github.com/iptux-src/iptux/"
+depends=('make' 'autoconf' 'libtool' 'automake')
+source=(https://codeload.github.com/iptux-src/${pkgname}/tar.gz/v${pkgver})
+sha256sums=('d567096d97b3b168dde1510f0ca00a13c6f8bb596131c234482377d7d8fb211b')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}/" install
+}