summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAzure Zeng2023-09-15 00:54:39 +0800
committerAzure Zeng2023-09-15 00:54:39 +0800
commit3a0f5e0a8644556f0e9e73210b70fab05491d806 (patch)
tree9332b7ef462cbc27196f75568d7ab9078ce9c77d
downloadaur-3a0f5e0a8644556f0e9e73210b70fab05491d806.tar.gz
Initial commit
-rw-r--r--PKGBUILD23
-rw-r--r--iputils-ping6-symlink-1.0.0-1-any.pkg.tar.zstbin0 -> 14683 bytes
2 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f836f26511fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Azure Zeng <weedycn at outlook.com>
+
+pkgname=iputils-ping6-symlink
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Provide ping4 and ping6 symbolic links for compatibility purpose'
+arch=('any')
+url='https://github.com/iputils/iputils'
+license=('Apache License 2.0')
+depends=('iputils')
+provides=('ping4' 'ping6')
+#conflicts=()
+
+package() {
+ install -d "$pkgdir/usr/bin"
+ install -d "$pkgdir/usr/share/man/man8"
+
+ local _curFile
+ for _curFile in ping4 ping6; do
+ ln -s ping "$pkgdir/usr/bin/$_curFile"
+ ln -s ping.8.gz "$pkgdir/usr/share/man/man8/$_curFile".8.gz
+ done
+}
diff --git a/iputils-ping6-symlink-1.0.0-1-any.pkg.tar.zst b/iputils-ping6-symlink-1.0.0-1-any.pkg.tar.zst
new file mode 100644
index 000000000000..c18559eea24d
--- /dev/null
+++ b/iputils-ping6-symlink-1.0.0-1-any.pkg.tar.zst
Binary files differ