summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Kaspar Rudert (mortzu)2015-05-21 15:51:49 +0200
committerMoritz Kaspar Rudert (mortzu)2015-05-21 15:51:49 +0200
commit2d5d44af8d201a23595dd6fa9fdecef93e33a6f9 (patch)
treeee403683df9dda4ade8fc1a41f18b0d94aaf9aa5
downloadaur-2d5d44af8d201a23595dd6fa9fdecef93e33a6f9.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD40
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c50d3692982a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ipv6calc
+ pkgdesc = Small utility to manipulate, convert and calculate (more than) IPv6 addresses
+ pkgver = 0.97.4
+ pkgrel = 1
+ url = http://www.deepspace6.net/projects/ipv6calc.html
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ checkdepends = perl-digest-sha1
+ checkdepends = perl-uri
+ options = !buildflags
+ source = ftp://ftp.bieringer.de/pub/linux/IPv6/ipv6calc/ipv6calc-0.97.4.tar.gz
+ md5sums = a7414ca72f66eb6d515b58c687705d55
+
+pkgname = ipv6calc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1caba1a1d26e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+pkgname=ipv6calc
+pkgver=0.97.4
+pkgrel=1
+pkgdesc='Small utility to manipulate, convert and calculate (more than) IPv6 addresses'
+url='http://www.deepspace6.net/projects/ipv6calc.html'
+license=('GPL2')
+source=("ftp://ftp.bieringer.de/pub/linux/IPv6/ipv6calc/ipv6calc-${pkgver}.tar.gz")
+md5sums=('a7414ca72f66eb6d515b58c687705d55')
+arch=('i686' 'x86_64')
+checkdepends=('perl-digest-sha1' 'perl-uri')
+options=('!buildflags')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+
+ # Run autotools.
+ autoconf
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ # Configure the build.
+ ./configure \
+ --prefix="${pkgdir}/usr"
+
+ sed -i -e "s#\${prefix}#$pkgdir/usr#g" man/Makefile
+
+ # Build it!
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ # Install the program.
+ make install
+}
+
+# vim:set ts=2 sw=2 et: