summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpyamsoft2018-03-07 20:58:37 -0800
committerpyamsoft2018-03-07 20:58:37 -0800
commit4703aac0c8a03fcbfe0b079225385c007b2dd7ae (patch)
treebca42fe5c0398e2e3fc585b4fe409fb7542d2765
parentbca6d7d8f96eb9dd55659238445328c5b63c89e4 (diff)
downloadaur-4703aac0c8a03fcbfe0b079225385c007b2dd7ae.tar.gz
Rewrite in Python
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 972934d5415d..1735545da73b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,19 @@
pkgbase = ipwaiter-git
pkgdesc = ipwaiter serves iptables
- pkgver = r36.01c7de0
+ pkgver = r37.6cacc54
pkgrel = 1
url = https://github.com/pyamsoft/ipwaiter
arch = any
license = GPLv2
makedepends = git
depends = iptables
+ depends = git
+ depends = python
+ depends = python-setuptools
+ depends = python-sh
provides = ipwaiter
conflicts = ipwaiter
- source = ipwaiter::git+https://github.com/pyamsoft/ipwaiter
+ source = ipwaiter::git+https://github.com/pyamsoft/ipwaiter#branch=master
sha256sums = SKIP
pkgname = ipwaiter-git
diff --git a/PKGBUILD b/PKGBUILD
index 5068e99b16fa..dd7c0d47960f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgname=ipwaiter-git
# shellcheck disable=SC2034
pkgdesc="ipwaiter serves iptables"
# shellcheck disable=SC2034
-pkgver=r36.01c7de0
+pkgver=r37.6cacc54
# shellcheck disable=SC2034
pkgrel=1
# shellcheck disable=SC2034
@@ -16,7 +16,7 @@ arch=('any')
# shellcheck disable=SC2034
makedepends=('git')
# shellcheck disable=SC2034
-depends=('iptables')
+depends=('iptables' 'git' 'python' 'python-setuptools' 'python-sh')
# shellcheck disable=SC2034
optdepends=()
# shellcheck disable=SC2034
@@ -35,6 +35,8 @@ url="https://github.com/pyamsoft/ipwaiter"
sha256sums=('SKIP')
# shellcheck disable=SC2034
source=("${_gitname}::git+${url}")
+# shellcheck disable=SC2034
+source=("${_gitname}::git+${url}#branch=master")
###############################################################################
@@ -58,6 +60,6 @@ package() {
}
# shellcheck disable=SC2154
- DESTDIR="${pkgdir}" ./install.sh
+ python setup.py install --root="${pkgdir}" --optimize=1
}