summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpyamsoft2018-03-07 21:14:51 -0800
committerpyamsoft2018-03-07 21:14:51 -0800
commit76f05996801f84f6e194d1818f05559f921cb408 (patch)
tree59ca34312a66c60eed81772e7264d281da0c8f79
parent0877edc37a82b7d4c52dafc62ea50b07356cc399 (diff)
downloadaur-76f05996801f84f6e194d1818f05559f921cb408.tar.gz
Fix PKGBUILD, ship service file
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3ea3ae43fe0..c64b6aa1cc3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ipwaiter-git
pkgdesc = ipwaiter serves iptables
- pkgver = r54.3d6d381
+ pkgver = r59.3160091
pkgrel = 1
url = https://github.com/pyamsoft/ipwaiter
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 2f170fbb154c..1071f7dd9266 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgname=ipwaiter-git
# shellcheck disable=SC2034
pkgdesc="ipwaiter serves iptables"
# shellcheck disable=SC2034
-pkgver=r54.3d6d381
+pkgver=r59.3160091
# shellcheck disable=SC2034
pkgrel=1
# shellcheck disable=SC2034
@@ -61,5 +61,10 @@ package() {
# shellcheck disable=SC2154
python setup.py install --root="${pkgdir}" --optimize=1
+
+ # Install the systemd service file
+ mkdir -p "${pkgdir}"/usr/lib/systemd/system/
+ cp conf/systemd/ipwaiter.service "${pkgdir}"/usr/lib/systemd/system/
+ chmod 644 "${pkgdir}"/usr/lib/systemd/system/ipwaiter.service
}