summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpyamsoft2017-12-30 14:37:12 -0800
committerpyamsoft2017-12-30 14:37:12 -0800
commita332da3f075fe091e1bf20f768f46823ae48d700 (patch)
treeeab7b48b7a67e4e312b9d29f835570803f8740d2
downloadaur-a332da3f075fe091e1bf20f768f46823ae48d700.tar.gz
Initial commit of ipwaiter
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD63
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..220a40025d80
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ipwaiter-git
+ pkgdesc = ipwaiter serves iptables
+ pkgver = r9.0f0d49d
+ pkgrel = 1
+ url = https://github.com/pyamsoft/ipwaiter.git
+ arch = any
+ license = GPLv2
+ makedepends = git
+ depends = iptables
+ provides = ipwaiter
+ conflicts = ipwaiter
+ source = ipwaiter::git+https://github.com/pyamsoft/ipwaiter.git#branch=master
+ sha256sums = SKIP
+
+pkgname = ipwaiter-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efd53823f59d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+##
+# Maintainer: pyamsoft <pyam(dot)soft(at)gmail(dot)com>
+##
+
+_gitname=ipwaiter
+# shellcheck disable=SC2034
+pkgname=ipwaiter-git
+# shellcheck disable=SC2034
+pkgdesc="ipwaiter serves iptables"
+# shellcheck disable=SC2034
+pkgver=r9.0f0d49d
+# shellcheck disable=SC2034
+pkgrel=1
+# shellcheck disable=SC2034
+arch=('any')
+# shellcheck disable=SC2034
+makedepends=('git')
+# shellcheck disable=SC2034
+depends=('iptables')
+# shellcheck disable=SC2034
+optdepends=()
+# shellcheck disable=SC2034
+provides=('ipwaiter')
+# shellcheck disable=SC2034
+conflicts=('ipwaiter')
+# shellcheck disable=SC2034
+license=('GPLv2')
+url="https://github.com/pyamsoft/ipwaiter.git"
+
+##
+# The SHA256 is constantly changing since this is
+# pulled from git so skip the verification check
+##
+# shellcheck disable=SC2034
+sha256sums=('SKIP')
+# shellcheck disable=SC2034
+source=("${_gitname}::git+${url}#branch=master")
+
+###############################################################################
+
+pkgver() {
+ # shellcheck disable=SC2154
+ cd "$srcdir/$_gitname" || {
+ msg "Could not cd into $srcdir/$_gitname"
+ return 1
+ }
+ # From
+ # https://wiki.archlinux.org/index.php/VCS_package_guidelines#The_pkgver.28.29_function
+ # If there are no tags then use number of revisions since beginning of the history:
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ # shellcheck disable=SC2154
+ cd "$srcdir/$_gitname" || {
+ msg "Could not cd into $srcdir/$_gitname"
+ return 1
+ }
+
+ # shellcheck disable=SC2154
+ DESTDIR="${pkgdir}" ./install.sh
+}
+