summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpyamsoft2018-03-07 21:22:58 -0800
committerpyamsoft2018-03-07 21:22:58 -0800
commitc3a55d9c487e587c05e7a50deaa0737fc315f6e1 (patch)
treef67ae0678d2b2e7b10f2546b4647a2896cdb575a
parent76f05996801f84f6e194d1818f05559f921cb408 (diff)
downloadaur-c3a55d9c487e587c05e7a50deaa0737fc315f6e1.tar.gz
Revert back to old style install script for system files
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c64b6aa1cc3b..9fe5891205a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ipwaiter-git
pkgdesc = ipwaiter serves iptables
- pkgver = r59.3160091
+ pkgver = r61.0a509fa
pkgrel = 1
url = https://github.com/pyamsoft/ipwaiter
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 1071f7dd9266..0bdb8dce4a13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgname=ipwaiter-git
# shellcheck disable=SC2034
pkgdesc="ipwaiter serves iptables"
# shellcheck disable=SC2034
-pkgver=r59.3160091
+pkgver=r61.0a509fa
# shellcheck disable=SC2034
pkgrel=1
# shellcheck disable=SC2034
@@ -59,12 +59,11 @@ package() {
return 1
}
- # shellcheck disable=SC2154
- python setup.py install --root="${pkgdir}" --optimize=1
+ # The install script will run
+ # python setup.py install --root="${pkgdir}" --optimize=1
+ # as well as install system files to the correct locations
- # Install the systemd service file
- mkdir -p "${pkgdir}"/usr/lib/systemd/system/
- cp conf/systemd/ipwaiter.service "${pkgdir}"/usr/lib/systemd/system/
- chmod 644 "${pkgdir}"/usr/lib/systemd/system/ipwaiter.service
+ # shellcheck disable=SC2154
+ DESTDIR="${pkgdir}" ./install.sh
}