summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2015-11-01 18:11:58 -0500
committerChris Severance2015-11-01 18:11:58 -0500
commit18403780d78a24aafa17a759384e9bf4c1f9699f (patch)
treedadf6b7694f7c2fe318dbd199e750784bcc6372a
downloadaur-18403780d78a24aafa17a759384e9bf4c1f9699f.tar.gz
Initial Import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD48
-rw-r--r--ipwatchd.service10
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f2cba8ed5e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ipwatchd
+ pkgdesc = IP conflict detection daemon
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = http://ipwatchd.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libpcap
+ depends = libnet
+ optdepends = ipwatchd-gnotify: provide conflict notifications to the GNOME desktop environment
+ backup = etc/ipwatchd.conf
+ source = http://downloads.sourceforge.net/sourceforge/ipwatchd/ipwatchd-1.2.1.tar.gz
+ source = ipwatchd.service
+ sha256sums = f20d0f0ee956112a25fc7ecdb10e7b4277d0842b48d194ac8552373e29087646
+ sha256sums = 2fbf3937bcab45adce253fb5aea31f93064748e9b8b5023e8ec25a6245380fd6
+
+pkgname = ipwatchd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ebb1bdccf4c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: Alex Merry <dev@randomguy3.me.uk>
+
+set -u
+pkgname='ipwatchd'
+pkgver='1.2.1'
+pkgrel='1'
+pkgdesc='IP conflict detection daemon'
+arch=('i686' 'x86_64')
+url='http://ipwatchd.sourceforge.net/'
+license=('GPL')
+depends=('libpcap' 'libnet')
+optdepends=('ipwatchd-gnotify: provide conflict notifications to the GNOME desktop environment')
+backup=('etc/ipwatchd.conf')
+_verwatch=("http://sourceforge.net/projects/ipwatchd/files/${pkgname}/" '.*href="'"/projects/ipwatchd/files/${pkgname}/\([^/]\+\)/"'".*' 'f')
+source=("http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ 'ipwatchd.service')
+sha256sums=('f20d0f0ee956112a25fc7ecdb10e7b4277d0842b48d194ac8552373e29087646'
+ '2fbf3937bcab45adce253fb5aea31f93064748e9b8b5023e8ec25a6245380fd6')
+
+prepare() {
+ set -u
+ cd "${pkgname}-${pkgver}/src"
+ sed -i -e 's:/sbin:/bin:g' 'Makefile' 'ipwatchd.conf' scripts/*
+ set +u
+}
+
+build() {
+ set -u
+ cd "${pkgname}-${pkgver}/src"
+
+ make
+ set +u
+}
+
+package() {
+ set -u
+ cd "${pkgname}-${pkgver}/src"
+
+ make DESTDIR="${pkgdir}/" install
+ rm -rf "${pkgdir}/etc/init.d"
+
+ install -Dpm644 "${srcdir}/ipwatchd.service" -t "${pkgdir}/usr/lib/systemd/system/"
+ set +u
+}
+set +u
+
+# vim:set ts=2 sw=2 et:
diff --git a/ipwatchd.service b/ipwatchd.service
new file mode 100644
index 000000000000..76a3a3c6a11e
--- /dev/null
+++ b/ipwatchd.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=IP conflict detection daemon
+Documentation=man:ipwatchd(8) man:ipwatchd.conf(5) man:ipwatchd-script(1) http://ipwatchd.sourceforge.net/documentation
+
+[Service]
+ExecStart=/usr/bin/ipwatchd -c /etc/ipwatchd.conf
+PIDFile=/var/run/ipwatchd.pid
+
+[Install]
+WantedBy=multi-user.target