summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorasm0dey2018-11-11 23:43:09 +0300
committerasm0dey2018-11-11 23:43:09 +0300
commitcebf289244ce9ee02d05c6a84ab4e5e677204b5d (patch)
tree052d2b3c740517bc24a463be463ddb71f3771ec2
downloadaur-cebf289244ce9ee02d05c6a84ab4e5e677204b5d.tar.gz
Initial
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6aabd4df97e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ipython-7
+ pkgdesc = IPython provides a rich toolkit to help you make the most of using Python interactively
+ pkgver = 7.1.1
+ pkgrel = 1
+ url = https://ipython.readthedocs.io/en/stable/
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ depends = python-prompt_toolkit-2
+ depends = python-pygments
+ depends = python-traitlets
+ depends = python-pickleshare
+ depends = python-decorator
+ depends = python-jedi
+ provides = ipython
+ provides = ipython-7
+ conflicts = ipython
+ source = https://github.com/ipython/ipython/releases/download/7.1.1/ipython-7.1.1.tar.gz
+ md5sums = 4e1f459a7592101736d695751403bd4c
+
+pkgname = ipython-7
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1023040f97fa
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+ipython*
+src/
+pkg/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1260230f9fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: asm0dey <pavel.finkelshtein+AUR@gmail.com>
+
+pkgname=ipython-7
+pkgver=7.1.1
+pkgrel=1
+pkgdesc="IPython provides a rich toolkit to help you make the most of using Python interactively"
+url="https://ipython.readthedocs.io/en/stable/"
+arch=(any)
+license=('BSD')
+depends=(
+ 'python'
+ 'python-prompt_toolkit-2'
+ 'python-pygments'
+ 'python-traitlets'
+ 'python-pickleshare'
+ 'python-decorator'
+ 'python-jedi'
+)
+provides=('ipython' 'ipython-7')
+conflicts=('ipython')
+makedepends=('python-setuptools')
+source=("https://github.com/ipython/ipython/releases/download/$pkgver/ipython-$pkgver.tar.gz")
+md5sums=('4e1f459a7592101736d695751403bd4c')
+
+prepare() {
+ cp -a "${srcdir}/ipython-$pkgver" "${srcdir}/python-$pkgbase-$pkgver"
+}
+
+build() {
+ cd "${srcdir}/python-$pkgbase-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/python-$pkgbase-$pkgver"
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+}
+