summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDylan Delgado2021-03-13 23:29:14 -0500
committerDylan Delgado2021-03-13 23:29:14 -0500
commit5d86ea768672991c8feb2122170cf339a6e0f185 (patch)
tree4ac3584ad55efe340a785fe8314e2aa6cee00865
downloadaur-5d86ea768672991c8feb2122170cf339a6e0f185.tar.gz
Initial commit
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD51
2 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1d1d0ee6e79
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = ipython-git
+ pkgdesc = An enhanced Interactive Python shell - git version
+ pkgver = 7.12.0.r667.gd737c3250
+ pkgrel = 1
+ url = https://ipython.org
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ depends = python-traitlets
+ depends = python-pexpect
+ depends = sqlite
+ depends = python-pickleshare
+ depends = python-prompt_toolkit
+ depends = python-jedi
+ depends = python-pygments
+ depends = python-backcall
+ depends = python-stack-data
+ depends = python-executing
+ depends = python-asttokens
+ depends = python-pure-eval
+ optdepends = python-nose: for IPython's test suite
+ provides = ipython
+ conflicts = ipython
+ source = git://github.com/ipython/ipython.git
+ source = https://www.packal.org/sites/default/files/public/styles/icon_large/public/workflow-files/nkeimipynbworkflow/icon/icon.png
+ md5sums = SKIP
+ md5sums = 2901d65f1b1fe354e72850085cd1c072
+
+pkgname = ipython-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..667b8956dbfb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Dylan Delgado <dylan1496 at live dot com>
+
+pkgname=ipython-git
+pkgver=7.12.0.r667.gd737c3250
+pkgrel=1
+pkgdesc="An enhanced Interactive Python shell - git version"
+arch=('any')
+url="https://ipython.org"
+license=('BSD')
+depends=('python' 'python-traitlets' 'python-pexpect' 'sqlite'
+ 'python-pickleshare' 'python-prompt_toolkit'
+ 'python-jedi' 'python-pygments' 'python-backcall'
+ 'python-stack-data' 'python-executing' 'python-asttokens'
+ 'python-pure-eval')
+makedepends=('python-setuptools')
+optdepends=("python-nose: for IPython's test suite")
+conflicts=('ipython')
+provides=('ipython')
+
+# new optional thing: ipyparallel
+
+source=("git://github.com/ipython/ipython.git"
+ "https://www.packal.org/sites/default/files/public/styles/icon_large/public/workflow-files/nkeimipynbworkflow/icon/icon.png")
+md5sums=('SKIP'
+ '2901d65f1b1fe354e72850085cd1c072')
+_pkgname=ipython
+
+# confirm that an update does not break sage?
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ export PYTHONHASHSEED=0
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ install -Dm644 docs/source/about/license_and_copyright.rst "$pkgdir/usr/share/licenses/ipython/LICENSE"
+
+ cd "examples/IPython Kernel"
+ # FS#45120
+ sed -i 's/gnome-netstatus-idle/ipython/' *.desktop
+ install -Dm644 ipython.desktop "$pkgdir/usr/share/applications/ipython.desktop"
+ #install -Dm644 ipython-qtconsole.desktop "$pkgdir/usr/share/applications/ipython-qtconsole.desktop"
+ # FS#47046
+ install -Dm644 "$srcdir/icon.png" "$pkgdir/usr/share/pixmaps/ipython.png"
+
+ #cd $srcdir/ipython-$pkgver/IPython/qt/console/resources/icon/
+ #install -Dm644 IPythonConsole.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/ipython.svg"
+}