summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Berquist2018-06-20 23:38:44 -0400
committerEric Berquist2018-06-20 23:38:44 -0400
commit2d04d7ec2046060af90602c691ff191546619b66 (patch)
tree0f9c8429e94fe3fe5e96055414e07583203acae0
downloadaur-2d04d7ec2046060af90602c691ff191546619b66.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD20
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5993946ac0a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Jun 21 03:38:20 UTC 2018
+pkgbase = iqmol
+ pkgdesc = A molecular editor and visualization package with Q-Chem integration
+ pkgver = 2.11.0
+ pkgrel = 1
+ url = https://iqmol.org
+ arch = x86_64
+ license = GPL3
+ depends = qt5-base
+ depends = glu
+ provides = iqmol
+ conflicts = iqmol
+ source = iqmol_2.11.0.deb::http://iqmol.org/download.php?get=iqmol_2.11.0.deb
+ md5sums = 11f90cc7d0a1ba9f2cbd4f0ef7c23028
+
+pkgname = iqmol
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5fa83c7d2f2b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+# makepkg files
+*.xz
+iqmol
+
+# source files
+*.deb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87ecf0e2d23a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Eric Berquist <eric DOT berquist AT gmail>
+
+pkgname=iqmol
+pkgver=2.11.0
+pkgrel=1
+pkgdesc="A molecular editor and visualization package with Q-Chem integration"
+arch=('x86_64')
+url="https://iqmol.org"
+license=('GPL3')
+depends=('qt5-base' 'glu')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+source=("${pkgname}_${pkgver}.deb::http://iqmol.org/download.php?get=${pkgname}_${pkgver}.deb")
+md5sums=('11f90cc7d0a1ba9f2cbd4f0ef7c23028')
+
+package() {
+ msg2 "Extracting the data.tar.xz..."
+ bsdtar -xf data.tar.xz -C "${pkgdir}/"
+ find "${pkgdir}" -type d -exec chmod 755 '{}' +
+}