summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Berquist2019-08-22 00:41:27 -0400
committerEric Berquist2019-08-22 00:41:27 -0400
commit7906818709442d8e6cf8f79a9187a9e1336735b1 (patch)
tree44884f021297d9b489e7bdd04067369aac7f832d
parent15f08c6516835656d042966f965062e97f437eff (diff)
downloadaur-7906818709442d8e6cf8f79a9187a9e1336735b1.tar.gz
Fix mistakenly removing the desktop file
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eeccb6e37d78..e07a78631953 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = iqmol
pkgdesc = A molecular editor and visualization package with Q-Chem integration
pkgver = 2.13b
- pkgrel = 1
+ pkgrel = 2
url = https://iqmol.org
arch = x86_64
license = GPL3
@@ -11,8 +11,10 @@ pkgbase = iqmol
conflicts = iqmol
source = iqmol_2.13b.deb::http://iqmol.org/download.php?get=iqmol_2.13b.deb
source = iqmol.png
- md5sums = 2523dc7c85d5af0face568179f99ac8a
- md5sums = 82ebad946c038562090f20efa2160929
+ source = iqmol.desktop
+ sha256sums = 4a1e3649019cbc871730ffd37a4df654d213b330db69b56a48f585e779a04da3
+ sha256sums = 193ae2363115dcb66f3c92580579e1d2fd33dd6976ce2a8eb00beaffd9f8e9c5
+ sha256sums = 9a00b3c99fc8c6681c04b95429740ea00d532dc99c5b12e4e09984808c6f91a1
pkgname = iqmol
diff --git a/PKGBUILD b/PKGBUILD
index 506b73bb8963..fee8c1ce06e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=iqmol
pkgver=2.13b
-pkgrel=1
+pkgrel=2
pkgdesc="A molecular editor and visualization package with Q-Chem integration"
arch=('x86_64')
url="https://iqmol.org"
@@ -11,9 +11,11 @@ depends=('qt5-base' 'glu')
provides=("${pkgname}")
conflicts=("${pkgname}")
source=("${pkgname}_${pkgver}.deb::http://iqmol.org/download.php?get=${pkgname}_${pkgver}.deb"
- "${pkgname}.png")
-md5sums=('2523dc7c85d5af0face568179f99ac8a'
- '82ebad946c038562090f20efa2160929')
+ "${pkgname}.png"
+ "${pkgname}.desktop")
+sha256sums=('4a1e3649019cbc871730ffd37a4df654d213b330db69b56a48f585e779a04da3'
+ '193ae2363115dcb66f3c92580579e1d2fd33dd6976ce2a8eb00beaffd9f8e9c5'
+ '9a00b3c99fc8c6681c04b95429740ea00d532dc99c5b12e4e09984808c6f91a1')
package() {
bsdtar -xf data.tar.xz -C "${pkgdir}/"
@@ -21,6 +23,6 @@ package() {
find "${pkgdir}/" -exec chown root:root '{}' +
find "${pkgdir}/" -type d -exec chmod 755 '{}' +
# Icon and desktop files
- install -Dm644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
- install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
}