summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcos Ferreira2017-07-09 15:06:19 -0300
committerMarcos Ferreira2017-07-09 15:06:19 -0300
commit654f8f687677c6893433fea9567894ab24a07823 (patch)
treecdb5922a259ae8b26d9af751121028b942188f72
downloadaur-654f8f687677c6893433fea9567894ab24a07823.tar.gz
inital version
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5c04c113490
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = iqoption-bin
+ pkgdesc = Ultimate trading experience
+ pkgver = 752.10.1239
+ pkgrel = 1
+ url = https://iqoption.com
+ arch = x86_64
+ license = custom:iqoption
+ makedepends = binutils
+ makedepends = tar
+ depends = sdl2
+ depends = sdl2_image
+ depends = sdl2_mixer
+ depends = mesa
+ depends = libnotify
+ source = iqoption.deb::https://updates.iqoption.com/api/v1/build/current/pkg/LinuxGL
+ sha256sums = a221465ba7e585db01e3c8788a778b8382af99ef836fbfb75dd2645311809fde
+
+pkgname = iqoption-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..246fa343248d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Marcos Ferreira <merkkp at gmail dot com>
+
+pkgname="iqoption-bin"
+pkgver=752.10.1239
+pkgrel=1
+pkgdesc="Ultimate trading experience"
+arch=("x86_64")
+url="https://iqoption.com"
+license=("custom:iqoption")
+depends=("sdl2" "sdl2_image" "sdl2_mixer" "mesa" "libnotify")
+makedepends=("binutils" "tar")
+source=("iqoption.deb::https://updates.iqoption.com/api/v1/build/current/pkg/LinuxGL")
+sha256sums=("a221465ba7e585db01e3c8788a778b8382af99ef836fbfb75dd2645311809fde")
+
+prepare() {
+ tar xf control.tar.gz
+}
+
+pkgver() {
+ cat control | head -n 2 | tail -n 1 | cut -d' ' -f 2
+}
+
+package() {
+ tar xf data.tar.xz -C "${pkgdir}/"
+}
+
+# vim:set ts=2 sw=2 et: