summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2015-08-14 10:30:18 +1000
committerRhinoceros2015-08-14 10:30:18 +1000
commit91c3ebaabf9e8a5c0fb413b71f1d8cca34b299dc (patch)
tree203873718803e869aa3dd20137ac7da7618ffa79
parent4025ff3f60321e0716197d5340550ea2ca0922cd (diff)
downloadaur-91c3ebaabf9e8a5c0fb413b71f1d8cca34b299dc.tar.gz
Rename package to ir-lv2
* Add conflicts * Replace unecessary variable
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 592b43952987..0d50b490e277 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ir-lv2
pkgdesc = Real-time signal convolver especially suited for creating reverb effects
pkgver = 1.3.2
- pkgrel = 3
+ pkgrel = 1
url = http://factorial.hu/plugins/lv2/ir
arch = i686
arch = x86_64
@@ -12,7 +12,10 @@ pkgbase = ir-lv2
depends = libsamplerate
depends = gtk2>=2.16
provides = ir-lv2
- conflicts = ir-lv2
+ conflicts = ir-lv2-git
+ conflicts = lv2-ir
+ conflicts = lv2-ir-git
+ conflicts = ir.lv2
source = http://factorial.hu/system/files/ir.lv2-1.3.2.tar.gz
sha256sums = ef9053e7b6002ed9f0b9a95046ec61cfb7035c0b2159f0fdc98ad44403f802ca
diff --git a/PKGBUILD b/PKGBUILD
index 6bceac703f77..8c5a3007c241 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,28 @@
# Contributor: Bernardo Barros <bbarros*AT*xsounds*DOT*org>
pkgname=ir-lv2
-_pkgname=ir.lv2
pkgver=1.3.2
-pkgrel=3
+pkgrel=1
pkgdesc='Real-time signal convolver especially suited for creating reverb effects'
arch=('i686' 'x86_64')
url='http://factorial.hu/plugins/lv2/ir'
license=('GPL')
depends=('zita-convolver' 'libsamplerate' 'gtk2>=2.16')
provides=('ir-lv2')
-conflicts=('ir-lv2')
+conflicts=('ir-lv2-git' 'lv2-ir' 'lv2-ir-git' 'ir.lv2')
groups=('lv2-plugins')
makedepends=('lv2')
-source=("http://factorial.hu/system/files/${_pkgname}-${pkgver}.tar.gz")
+source=("http://factorial.hu/system/files/${pkgname/-/.}-${pkgver}.tar.gz")
sha256sums=('ef9053e7b6002ed9f0b9a95046ec61cfb7035c0b2159f0fdc98ad44403f802ca')
build() {
- cd "${_pkgname}-${pkgver}"
+ cd "${pkgname/-/.}-${pkgver}"
make
make convert4chan
}
package() {
- cd "${_pkgname}-${pkgver}"
+ cd "${pkgname/-/.}-${pkgver}"
make PREFIX="$pkgdir/usr" install
install -Dm755 convert4chan "$pkgdir/usr/bin/convert4chan"
install -Dm644 README "${pkgdir}"/usr/share/doc/$pkgname/README