summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre Choffet2015-09-02 16:38:20 -0400
committerPierre Choffet2015-09-02 16:43:37 -0400
commitdacf4feb32821ee1ae6e8b96e055bcb9b9df5575 (patch)
tree7ecc474a661db0acd76499479e35ca4199c65c09
downloadaur-dacf4feb32821ee1ae6e8b96e055bcb9b9df5575.tar.gz
Initial commit
Reimport package from AUR3. Update version to just released 1.1.6
-rw-r--r--.SRCINFO20
-rw-r--r--ChangeLog51
-rw-r--r--PKGBUILD68
3 files changed, 139 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c482316cbcd4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = irccd
+ pkgdesc = IRC client daemon
+ pkgver = 1.1.6
+ pkgrel = 1
+ url = http://projects.malikania.fr/irccd/
+ changelog = ChangeLog
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = cmake
+ makedepends = libircclient
+ depends = libxdg-basedir
+ depends = libircclient
+ backup = etc/irccd.conf
+ backup = etc/irccdctl.conf
+ source = http://releases.malikania.fr/irccd/irccd-1.1.6-source.tar.gz
+ md5sums = aae1c36c453a69add58ff5c31de997e6
+
+pkgname = irccd
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..1a68bac56e05
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,51 @@
+2015-09-02 Pierre Choffet <peuc@wanadoo.fr>
+ * 1.1.6-1 :
+ Upstream update to 1.1.6
+ Remove Lua dependency. It's now bundled with the sources.
+
+2015-02-27 Pierre Choffet <peuc@wanadoo.fr>
+ * 1.1.5-1 :
+ Upstream update to 1.1.5
+
+2014-03-28 Pierre Choffet <peuc@wanadoo.fr>
+ * 1.1.4-1 :
+ Upstream update to 1.1.4
+
+2014-03-24 Pierre Choffet <peuc@wanadoo.fr>
+ * 1.1.3-1 :
+ Upstream update to 1.1.3
+
+2014-02-24 Pierre Choffet <peuc@wanadoo.fr>
+ * 1.1.2-1 :
+ Upstream update to 1.1.2
+
+2014-02-24 Pierre Choffet <peuc@wanadoo.fr>
+ * 1.1.1-1 :
+ Upstream update to 1.1.1
+
+2014-01-30 Pierre Choffet <peuc@wanadoo.fr>
+
+ * 1.1-2 :
+ Fix missing systemd unit file installation
+
+ * 1.1-1 :
+ Upstream update to 1.1
+
+2013-11-02 Pierre Choffet <peuc@wanadoo.fr>
+
+ * 1.0.2-1 :
+ Upstream update to 1.0.2.
+ Add config files management
+
+2013-09-23 Pierre Choffet <peuc@wanadoo.fr>
+
+ * 1.0.1-3 :
+ Add license management.
+
+2013-09-18 Pierre Choffet <peuc@wanadoo.fr>
+
+ * 1.0.1-2 :
+ Fix build directories.
+
+ * 1.0.1-1 :
+ Initial PKGBUILD.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7d5ee9ba698
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# irccd packaging script for ArchLinux - Copyright (c) 2013-2015 Pierre Choffet
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+# THE SOFTWARE.
+
+pkgname=irccd
+pkgver=1.1.6
+pkgrel=1
+epoch=
+pkgdesc="IRC client daemon"
+arch=('i686' 'x86_64')
+url="http://projects.malikania.fr/irccd/"
+license=('custom')
+groups=()
+depends=('libxdg-basedir' 'libircclient')
+makedepends=('cmake' 'libircclient')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=("etc/irccd.conf" "etc/irccdctl.conf")
+options=()
+changelog="ChangeLog"
+source=("http://releases.malikania.fr/$pkgname/$pkgname-$pkgver-source.tar.gz")
+noextract=()
+md5sums=('aae1c36c453a69add58ff5c31de997e6')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver-source
+ mkdir _build
+ cd _build
+ cmake .. -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="/usr" -DETCDIR=../etc -DMANDIR=share/man -DDOCDIR=share/doc/irccd -DMODDIR=share/irccd/plugins
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver-source/_build
+ make DESTDIR="$pkgdir" install
+
+ cd ..
+ mkdir -p $pkgdir/usr/share/licenses/$pkgname
+ cp LICENSE $pkgdir/usr/share/licenses/$pkgname/
+
+ # Copy systemd unit
+ mkdir -p $pkgdir/usr/lib/systemd/system/
+ cp contrib/irccd.service $pkgdir/usr/lib/systemd/system/
+
+ # Copy default config files
+ cd $pkgdir/etc/
+ mv irccd.conf.sample irccd.conf
+ mv irccdctl.conf.sample irccdctl.conf
+}