summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Reimer2018-12-25 16:53:21 +0100
committerManuel Reimer2018-12-25 16:53:21 +0100
commit8479465dc8b873a46e45020f5a8b960577c373cb (patch)
treeb1a26a421c31644e00939eecf7a2bf990d7e28a0
downloadaur-irctl.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/d838c0f6a0a1cb23038921c7c8c20b7062909b95)
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD23
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f00f291075f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by makepkg 5.1.1
+# Tue Dec 25 15:53:20 UTC 2018
+pkgbase = irctl
+ pkgdesc = Command-line utilty to query and set properties of common remote control receivers
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/olebowle/irctl
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL3
+ depends = gcc-libs
+ depends = glibc
+ source = irctl-0.1.1.tar.gz::https://github.com/olebowle/irctl/archive/v0.1.1.tar.gz
+ md5sums = 994f3b0e0423afde8c87b522641e02a7
+
+pkgname = irctl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc98859c01d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Ole Ernst <olebowle[at]gmx[dot]com>
+pkgname=irctl
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Command-line utilty to query and set properties of common remote control receivers"
+url="https://github.com/olebowle/irctl"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL3')
+depends=('gcc-libs' 'glibc')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/olebowle/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('994f3b0e0423afde8c87b522641e02a7')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" PREFIX='/usr' install
+}