summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2024-01-24 20:18:09 +0800
committerlilac2024-01-24 20:18:09 +0800
commitf3faf46d990486509656e6a1277dba89c88e0902 (patch)
treec1d7e5a8c4405462430df607e7c0ac6de7ed09a3
parent9415e25d83b957606057ada6aac045ac5bceac20 (diff)
downloadaur-f3faf46d990486509656e6a1277dba89c88e0902.tar.gz
[lilac] updated to 1.14.0-4
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD20
2 files changed, 22 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17cdf4c8f790..328a909711d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,28 @@
pkgbase = iredis
pkgdesc = Terminal client for Redis with auto-completion and syntax highlighting.
- pkgver = 1.13.0
- pkgrel = 1
+ pkgver = 1.14.0
+ pkgrel = 4
url = https://github.com/laixintao/iredis
arch = any
license = BSD-3-Clause
makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-poetry
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
depends = python-redis
+ depends = python-packaging
depends = python-prompt_toolkit
depends = python-pygments
depends = python-mistune
depends = python-configobj
depends = python-click
depends = python-pendulum
- depends = python-importlib_resources
- depends = python-wcwidth
- source = https://files.pythonhosted.org/packages/source/i/iredis/iredis-1.13.0.tar.gz
- sha256sums = d1e4e7936d0be456f70a39abeb1c97d931f66ccd60e891f4fd796ffb06dfeaf9
+ source = https://files.pythonhosted.org/packages/source/i/iredis/iredis-1.14.0.tar.gz
+ sha256sums = 821336ab54e4cea7169ac51bd94f3daa45a3b9843b1adee1bf2ea3dd3230f184
pkgname = iredis
diff --git a/PKGBUILD b/PKGBUILD
index 6befa99f0ea2..3b6e37014df3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
_name=iredis
pkgname=iredis
-pkgver=1.13.0
-pkgrel=1
+pkgver=1.14.0
+pkgrel=4
pkgdesc="Terminal client for Redis with auto-completion and syntax highlighting."
arch=(any)
url="https://github.com/laixintao/iredis"
license=('BSD-3-Clause')
-depends=('python' 'python-redis' 'python-prompt_toolkit' 'python-pygments' 'python-mistune' 'python-configobj' 'python-click' 'python-pendulum' 'python-importlib_resources' 'python-wcwidth')
-makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/iredis-1.13.0.tar.gz")
-sha256sums=('d1e4e7936d0be456f70a39abeb1c97d931f66ccd60e891f4fd796ffb06dfeaf9')
+depends=('python' 'python-redis' 'python-packaging' 'python-prompt_toolkit' 'python-pygments' 'python-mistune' 'python-configobj' 'python-click' 'python-pendulum')
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel' 'python-poetry' 'python-build' 'python-installer' 'python-wheel')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/iredis-1.14.0.tar.gz")
+sha256sums=('821336ab54e4cea7169ac51bd94f3daa45a3b9843b1adee1bf2ea3dd3230f184')
build() {
- cd "$srcdir/iredis-1.13.0"
- python3 setup.py build
+ cd "$srcdir/iredis-1.14.0"
+ python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir/iredis-1.13.0"
- python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
+ cd "$srcdir/iredis-1.14.0"
+ python -m installer --destdir="$pkgdir" dist/*.whl
# make sure we don't install any world-writable or root-readable-only files
# we shouldn't need to fix ownership as we extract tarballs as a non-root user