summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIru Cai2016-10-02 18:40:39 +0800
committerIru Cai2016-10-02 18:40:39 +0800
commit66a2a0528bb65b3f0812f440e1991a1c96f19571 (patch)
tree0c39d7cfb21c1824b87aab62ded736516dc283d4
parent5b6b67862a0869d099538314d793179b0d39c09a (diff)
downloadaur-66a2a0528bb65b3f0812f440e1991a1c96f19571.tar.gz
add chromium patches
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--chromium-52.0.2743.116-unset-madv_free.patch15
-rw-r--r--chromium-cups-2.2.patch31
4 files changed, 64 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60089ee57ad5..78c3cae3f6d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon May 30 03:09:57 UTC 2016
+# Sun Oct 2 10:40:28 UTC 2016
pkgbase = iridium
pkgdesc = a free, open, and libre browser modification of the Chromium code base
pkgver = 51.1
- pkgrel = 3
+ pkgrel = 4
url = https://iridiumbrowser.de/
arch = i686
arch = x86_64
@@ -47,11 +47,15 @@ pkgbase = iridium
source = chromium-launcher-3.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v3.tar.gz
source = chromium.desktop
source = chromium-widevine.patch
+ source = chromium-52.0.2743.116-unset-madv_free.patch
+ source = chromium-cups-2.2.patch
source = fix_PNGImageDecoder.patch
sha256sums = 614a7cd4fe0a5ba57495fc7afbd407c0e5e59e8897d98c78f96f859e4c9bf80a
sha256sums = 8b01fb4efe58146279858a754d90b49e5a38c9a0b36a1f84cbb7d12f92b84c28
sha256sums = 028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9
sha256sums = 4660344789c45c9b9e52cb6d86f7cb6edb297b39320d04f6947e5216d6e5f64c
+ sha256sums = ed0229c19fff2fa1867499b5557d815b25ed2b81b21bccb5d10bd27cf747bac4
+ sha256sums = 6519cf913cb68e2def1bbf9210ef40a178b45bc9d325297c41b7a784ff57cc8e
sha256sums = 42086dbe5c68744a6bed4e4af6035defbd6e1dfc1c3f32a4711c5c953f938698
pkgname = iridium
diff --git a/PKGBUILD b/PKGBUILD
index f08bfe550369..df450090dfd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=iridium
pkgver=51.1
-pkgrel=3
+pkgrel=4
_launcher_ver=3
pkgdesc="a free, open, and libre browser modification of the Chromium code base"
arch=('i686' 'x86_64')
@@ -27,11 +27,15 @@ source=(https://downloads.iridiumbrowser.de/source/iridium-browser-${pkgver}.tar
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
chromium.desktop
chromium-widevine.patch
+ chromium-52.0.2743.116-unset-madv_free.patch
+ chromium-cups-2.2.patch
fix_PNGImageDecoder.patch)
sha256sums=('614a7cd4fe0a5ba57495fc7afbd407c0e5e59e8897d98c78f96f859e4c9bf80a'
'8b01fb4efe58146279858a754d90b49e5a38c9a0b36a1f84cbb7d12f92b84c28'
'028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9'
'4660344789c45c9b9e52cb6d86f7cb6edb297b39320d04f6947e5216d6e5f64c'
+ 'ed0229c19fff2fa1867499b5557d815b25ed2b81b21bccb5d10bd27cf747bac4'
+ '6519cf913cb68e2def1bbf9210ef40a178b45bc9d325297c41b7a784ff57cc8e'
'42086dbe5c68744a6bed4e4af6035defbd6e1dfc1c3f32a4711c5c953f938698')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
@@ -75,6 +79,13 @@ prepare() {
## https://groups.google.com/a/chromium.org/d/topic/chromium-packagers/BNGvJc08B6Q
#find third_party/icu -type f \! -regex '.*\.\(gyp\|gypi\|isolate\)' -delete
+ # Disable MADV_FREE (if set by glibc)
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1361157
+ patch -Np1 -i ../chromium-52.0.2743.116-unset-madv_free.patch
+
+ # Fix compiling with CUPS 2.2 backend
+ patch -Np0 -i ../chromium-cups-2.2.patch
+
# Use Python 2
find . -name '*.py' -exec sed -i -r 's|/usr/bin/python$|&2|g' {} +
# There are still a lot of relative calls which need a workaround
diff --git a/chromium-52.0.2743.116-unset-madv_free.patch b/chromium-52.0.2743.116-unset-madv_free.patch
new file mode 100644
index 000000000000..89659ced658e
--- /dev/null
+++ b/chromium-52.0.2743.116-unset-madv_free.patch
@@ -0,0 +1,15 @@
+diff -up chromium-52.0.2743.116/third_party/WebKit/Source/wtf/allocator/PageAllocator.cpp.madv_free chromium-52.0.2743.116/third_party/WebKit/Source/wtf/allocator/PageAllocator.cpp
+--- chromium-52.0.2743.116/third_party/WebKit/Source/wtf/PageAllocator.cpp.madv_free 2016-08-15 13:07:29.279655676 -0400
++++ chromium-52.0.2743.116/third_party/WebKit/Source/wtf/PageAllocator.cpp 2016-08-15 13:08:38.447317416 -0400
+@@ -41,6 +41,11 @@
+ #include <errno.h>
+ #include <sys/mman.h>
+
++#if OS(LINUX) && defined(MADV_FREE)
++// Added in Linux 4.5, but it breaks the sandbox.
++#undef MADV_FREE
++#endif
++
+ #ifndef MADV_FREE
+ #define MADV_FREE MADV_DONTNEED
+ #endif
diff --git a/chromium-cups-2.2.patch b/chromium-cups-2.2.patch
new file mode 100644
index 000000000000..85559e13167f
--- /dev/null
+++ b/chromium-cups-2.2.patch
@@ -0,0 +1,31 @@
+commit 5132ca58a0a3ada1aee99732fd30d53ebe5af984
+author saiarcot895 <saiarcot895@gmail.com> Mon Aug 22 18:41:54 2016
+committer Commit bot <commit-bot@chromium.org> Mon Aug 22 18:44:13 2016
+tree b4783f1c90f2fdb001843ad83463e260de9b292c
+parent da7b21cac1ded0c70cb330e4f76a1f7915e38ccf
+
+Fix compiling with CUPS 2.2 backend.
+
+cupsGetPPD() and cupsGetPPD2() have been moved into the cups/ppd.h
+header starting with CUPS 2.2. This header file now needs to be included
+to use these functions. The header file also exists on older versions of
+CUPS, so a compile error will not occur.
+
+R=skau@chromium.org, thestig@chromium.org
+
+Review-Url: https://codereview.chromium.org/2258333004
+Cr-Commit-Position: refs/heads/master@{#413484}
+
+diff --git printing/backend/cups_helper.h printing/backend/cups_helper.h
+index fd7601d..b72903f 100644
+--- printing/backend/cups_helper.h
++++ printing/backend/cups_helper.h
+
+@@ -6,6 +6,7 @@
+ #define PRINTING_BACKEND_CUPS_HELPER_H_
+
+ #include <cups/cups.h>
++#include <cups/ppd.h>
+
+ #include "base/strings/string_piece.h"
+ #include "printing/printing_export.h"