summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIru Cai2016-03-29 13:01:58 +0800
committerIru Cai2016-03-29 13:01:58 +0800
commit9e19d030736480b08382ec287081da1c03abffa6 (patch)
treecc6cfc5b135de3ab4e9f65a5d0fb0a7d55f1b767
parentd09069391791932d8b8116363f09a5958b2d76af (diff)
downloadaur-9e19d030736480b08382ec287081da1c03abffa6.tar.gz
update to 49.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
-rw-r--r--chromium-fix-print-preview-on-en_GB-locale.patch17
-rw-r--r--chromium-use-non-versioned-icu-namespace.patch14
-rw-r--r--chromium-widevine.patch57
5 files changed, 58 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 097111a942e5..82c751121e05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Feb 23 02:00:56 UTC 2016
+# Tue Mar 29 04:59:33 UTC 2016
pkgbase = iridium
pkgdesc = a free, open, and libre browser modification of the Chromium code base
- pkgver = 48.2
+ pkgver = 49.0
pkgrel = 1
url = https://iridiumbrowser.de/
install = iridium.install
@@ -43,18 +43,14 @@ pkgbase = iridium
optdepends = gnome-keyring: for storing passwords in GNOME keyring
optdepends = kwallet: for storing passwords in KWallet
options = !strip
- source = https://downloads.iridiumbrowser.de/source/iridium-browser-48.2.tar.xz
+ source = https://downloads.iridiumbrowser.de/source/iridium-browser-49.0.tar.xz
source = chromium-launcher-3.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v3.tar.gz
source = chromium.desktop
- source = chromium-use-non-versioned-icu-namespace.patch
- source = chromium-fix-print-preview-on-en_GB-locale.patch
source = chromium-widevine.patch
- sha256sums = dfe5832086000f7a3b4878384a633ee96aa3e5dc88d8b1f8501f744f57f8162b
+ sha256sums = 21a9771f002d818cc160d51e9b3652447f64129b2815067b9d0e43d19043c395
sha256sums = 8b01fb4efe58146279858a754d90b49e5a38c9a0b36a1f84cbb7d12f92b84c28
sha256sums = 028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9
- sha256sums = e4192446cc0ab6a5c540599c8a149f4f2208f0014da2786ada6c9544913d7426
- sha256sums = 6fff45aafa31fb35a032b4e2175a341e08f9d2a9b37c5cf080c318180f558378
- sha256sums = 379b746e187de28f80f5a7cd19edcfa31859656826f802a1ede054fcb6dfb221
+ sha256sums = 4660344789c45c9b9e52cb6d86f7cb6edb297b39320d04f6947e5216d6e5f64c
pkgname = iridium
diff --git a/PKGBUILD b/PKGBUILD
index 2e15a329d827..f9a880f5bee5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Iru Cai <mytbk920423@gmail.com>
pkgname=iridium
-pkgver=48.2
+pkgver=49.0
pkgrel=1
_launcher_ver=3
pkgdesc="a free, open, and libre browser modification of the Chromium code base"
@@ -24,15 +24,11 @@ install=iridium.install
source=(https://downloads.iridiumbrowser.de/source/iridium-browser-${pkgver}.tar.xz
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
chromium.desktop
- chromium-use-non-versioned-icu-namespace.patch
- chromium-fix-print-preview-on-en_GB-locale.patch
chromium-widevine.patch)
-sha256sums=('dfe5832086000f7a3b4878384a633ee96aa3e5dc88d8b1f8501f744f57f8162b'
+sha256sums=('21a9771f002d818cc160d51e9b3652447f64129b2815067b9d0e43d19043c395'
'8b01fb4efe58146279858a754d90b49e5a38c9a0b36a1f84cbb7d12f92b84c28'
'028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9'
- 'e4192446cc0ab6a5c540599c8a149f4f2208f0014da2786ada6c9544913d7426'
- '6fff45aafa31fb35a032b4e2175a341e08f9d2a9b37c5cf080c318180f558378'
- '379b746e187de28f80f5a7cd19edcfa31859656826f802a1ede054fcb6dfb221')
+ '4660344789c45c9b9e52cb6d86f7cb6edb297b39320d04f6947e5216d6e5f64c')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
# Note: These are for Arch Linux use ONLY. For your own distribution, please
@@ -57,12 +53,6 @@ prepare() {
# https://code.google.com/p/chromium/issues/detail?id=541273
sed -i "/'target_name': 'libvpx'/s/libvpx/&_new/" build/linux/unbundle/libvpx.gyp
- # https://codereview.chromium.org/1505763002
- patch -Np1 -i ../chromium-use-non-versioned-icu-namespace.patch
-
- # https://code.google.com/p/chromium/issues/detail?id=480415
- patch -Np1 -i ../chromium-fix-print-preview-on-en_GB-locale.patch
-
# Enable support for the Widevine CDM plugin
# The actual libraries are not included, but can be copied over from Chrome:
# libwidevinecdmadapter.so
@@ -143,6 +133,7 @@ build() {
-Dusb_ids_path=/usr/share/hwdata/usb.ids
-Duse_mojo=0
-Duse_gconf=0
+ -Duse_sysroot=0
-Denable_hangout_services_extension=1
-Ddisable_fatal_linker_warnings=1
-Ddisable_glibc=1)
diff --git a/chromium-fix-print-preview-on-en_GB-locale.patch b/chromium-fix-print-preview-on-en_GB-locale.patch
deleted file mode 100644
index 9ebc089cb756..000000000000
--- a/chromium-fix-print-preview-on-en_GB-locale.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Index: chrome/browser/ui/webui/print_preview/print_preview_handler.cc
-diff --git a/chrome/browser/ui/webui/print_preview/print_preview_handler.cc b/chrome/browser/ui/webui/print_preview/print_preview_handler.cc
-index 6cfd861387c9f8b145fb33472b10025537986213..c936a9c1dadb13c00418e8ae79a8a1987c1d36cd 100644
---- a/chrome/browser/ui/webui/print_preview/print_preview_handler.cc
-+++ b/chrome/browser/ui/webui/print_preview/print_preview_handler.cc
-@@ -1222,7 +1222,10 @@ void PrintPreviewHandler::GetNumberFormatAndMeasurementSystem(
- UErrorCode errorCode = U_ZERO_ERROR;
- const char* locale = g_browser_process->GetApplicationLocale().c_str();
- UMeasurementSystem system = ulocdata_getMeasurementSystem(locale, &errorCode);
-- if (errorCode > U_ZERO_ERROR || system == UMS_LIMIT)
-+ // On error, assume the units are SI.
-+ // Since the only measurement units print preview's WebUI cares about are
-+ // those for measuring distance, assume anything non-US is SI.
-+ if (errorCode > U_ZERO_ERROR || system != UMS_US)
- system = UMS_SI;
-
- // Getting the number formatting based on the locale and writing to
diff --git a/chromium-use-non-versioned-icu-namespace.patch b/chromium-use-non-versioned-icu-namespace.patch
deleted file mode 100644
index f7b0b6d80517..000000000000
--- a/chromium-use-non-versioned-icu-namespace.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Index: components/autofill/core/common/autofill_l10n_util.cc
-diff --git a/components/autofill/core/common/autofill_l10n_util.cc b/components/autofill/core/common/autofill_l10n_util.cc
-index 2ee517faf82b1feb224f83ae533092ae3b31f5af..c29b0a299b7215895874adf9241e4705247161ab 100644
---- a/components/autofill/core/common/autofill_l10n_util.cc
-+++ b/components/autofill/core/common/autofill_l10n_util.cc
-@@ -22,7 +22,7 @@ CaseInsensitiveCompare::CaseInsensitiveCompare(const icu::Locale& locale) {
- // library. This could be due to a device-specific issue (has been seen in
- // the wild on Android devices). In the failure case, |collator_| will be
- // null. See http://crbug.com/558625.
-- icu_54::UnicodeString name;
-+ icu::UnicodeString name;
- std::string locale_name;
- locale.getDisplayName(name).toUTF8String(locale_name);
- LOG(ERROR) << "Failed to initialize the ICU Collator for "
diff --git a/chromium-widevine.patch b/chromium-widevine.patch
index 45048cada875..569ad4c88bfe 100644
--- a/chromium-widevine.patch
+++ b/chromium-widevine.patch
@@ -1,12 +1,53 @@
-diff -upr chromium-42.0.2311.90.orig/third_party/widevine/cdm/widevine_cdm_version.h chromium-42.0.2311.90/third_party/widevine/cdm/widevine_cdm_version.h
---- chromium-42.0.2311.90.orig/third_party/widevine/cdm/widevine_cdm_version.h 2015-04-15 01:18:59.000000000 +0300
-+++ chromium-42.0.2311.90/third_party/widevine/cdm/widevine_cdm_version.h 2015-04-15 09:09:49.157260050 +0300
-@@ -14,4 +14,8 @@
- // - WIDEVINE_CDM_VERSION_STRING (with the version of the CDM that's available
- // as a string, e.g., "1.0.123.456").
+diff -upr chromium-48.0.2564.82.orig/chrome/common/chrome_content_client.cc chromium-48.0.2564.82/chrome/common/chrome_content_client.cc
+--- chromium-48.0.2564.82.orig/chrome/common/chrome_content_client.cc 2016-01-20 22:01:20.000000000 +0200
++++ chromium-48.0.2564.82/chrome/common/chrome_content_client.cc 2016-01-21 20:02:02.788936626 +0200
+@@ -158,7 +158,12 @@ void ComputeBuiltInPlugins(std::vector<c
+ #if defined(WIDEVINE_CDM_AVAILABLE) && defined(ENABLE_PEPPER_CDMS) && \
+ !defined(WIDEVINE_CDM_IS_COMPONENT)
+ static bool skip_widevine_cdm_file_check = false;
+- if (PathService::Get(chrome::FILE_WIDEVINE_CDM_ADAPTER, &path)) {
++ bool widevine_cdm_present =
++ skip_widevine_cdm_file_check ||
++ (PathService::Get(chrome::FILE_WIDEVINE_CDM, &path) &&
++ base::PathExists(path));
++ if (widevine_cdm_present &&
++ PathService::Get(chrome::FILE_WIDEVINE_CDM_ADAPTER, &path)) {
+ if (skip_widevine_cdm_file_check || base::PathExists(path)) {
+ content::PepperPluginInfo widevine_cdm;
+ widevine_cdm.is_out_of_process = true;
+diff -upr chromium-48.0.2564.82.orig/chrome/common/chrome_paths.cc chromium-48.0.2564.82/chrome/common/chrome_paths.cc
+--- chromium-48.0.2564.82.orig/chrome/common/chrome_paths.cc 2016-01-20 22:01:20.000000000 +0200
++++ chromium-48.0.2564.82/chrome/common/chrome_paths.cc 2016-01-21 19:18:51.287978456 +0200
+@@ -375,6 +375,11 @@ bool PathProvider(int key, base::FilePat
+ return false;
+ cur = cur.AppendASCII(kWidevineCdmAdapterFileName);
+ break;
++ case chrome::FILE_WIDEVINE_CDM:
++ if (!GetInternalPluginsDirectory(&cur))
++ return false;
++ cur = cur.AppendASCII(kWidevineCdmFileName);
++ break;
+ #endif // defined(WIDEVINE_CDM_AVAILABLE) && defined(ENABLE_PEPPER_CDMS)
+ case chrome::FILE_RESOURCES_PACK:
+ #if defined(OS_MACOSX) && !defined(OS_IOS)
+diff -upr chromium-48.0.2564.82.orig/chrome/common/chrome_paths.h chromium-48.0.2564.82/chrome/common/chrome_paths.h
+--- chromium-48.0.2564.82.orig/chrome/common/chrome_paths.h 2016-01-14 03:49:22.000000000 +0200
++++ chromium-48.0.2564.82/chrome/common/chrome_paths.h 2016-01-21 19:18:51.287978456 +0200
+@@ -99,6 +99,7 @@ enum {
+ DIR_COMPONENT_WIDEVINE_CDM, // Directory that contains component-updated
+ // Widevine CDM files.
+ FILE_WIDEVINE_CDM_ADAPTER, // Full path to the Widevine CDM adapter file.
++ FILE_WIDEVINE_CDM, // Full path to the Widevine CDM file.
+ FILE_RESOURCES_PACK, // Full path to the .pak file containing
+ // binary data (e.g., html files and images
+ // used by internal pages).
+diff -upr chromium-48.0.2564.82.orig/third_party/widevine/cdm/stub/widevine_cdm_version.h chromium-48.0.2564.82/third_party/widevine/cdm/stub/widevine_cdm_version.h
+--- chromium-48.0.2564.82.orig/third_party/widevine/cdm/stub/widevine_cdm_version.h 2016-01-14 01:05:17.000000000 +0200
++++ chromium-48.0.2564.82/third_party/widevine/cdm/stub/widevine_cdm_version.h 2016-01-21 19:18:51.287978456 +0200
+@@ -12,4 +12,6 @@
+
+ #define WIDEVINE_CDM_AVAILABLE
-+#include "third_party/widevine/cdm/widevine_cdm_common.h"
-+#define WIDEVINE_CDM_AVAILABLE
+#define WIDEVINE_CDM_VERSION_STRING "@WIDEVINE_VERSION@"
+
#endif // WIDEVINE_CDM_VERSION_H_