summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIru Cai2015-12-10 23:38:07 +0800
committerIru Cai2015-12-10 23:38:07 +0800
commitbac665fdc485f4db3ce5f41f2fe2ddb3569fbb28 (patch)
tree8d9a5fd2ea8a5d2b98143cf17446fe3519fc31ee
downloadaur-bac665fdc485f4db3ce5f41f2fe2ddb3569fbb28.tar.gz
initial iridium package
-rw-r--r--.SRCINFO60
-rw-r--r--PKGBUILD203
-rw-r--r--chromium-fix-print-preview-on-en_GB-locale.patch17
-rw-r--r--chromium-widevine.patch12
-rw-r--r--chromium.desktop112
-rw-r--r--iridium.install14
6 files changed, 418 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0baead10f5f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,60 @@
+# Generated by mksrcinfo v8
+# Thu Dec 10 15:37:59 UTC 2015
+pkgbase = iridium
+ pkgdesc = a free, open, and libre browser modification of the Chromium code base
+ pkgver = 46.0
+ pkgrel = 1
+ url = https://iridiumbrowser.de/
+ install = iridium.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = python2
+ makedepends = gperf
+ makedepends = yasm
+ makedepends = mesa
+ makedepends = ninja
+ depends = gtk2
+ depends = nss
+ depends = alsa-lib
+ depends = xdg-utils
+ depends = bzip2
+ depends = libevent
+ depends = libxss
+ depends = icu
+ depends = libexif
+ depends = libgcrypt
+ depends = ttf-font
+ depends = systemd
+ depends = dbus
+ depends = flac
+ depends = snappy
+ depends = speech-dispatcher
+ depends = pciutils
+ depends = libpulse
+ depends = harfbuzz
+ depends = libsecret
+ depends = libvpx
+ depends = perl
+ depends = perl-file-basedir
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ optdepends = kdebase-kdialog: needed for file dialogs in KDE
+ optdepends = gnome-keyring: for storing passwords in GNOME keyring
+ optdepends = kwallet: for storing passwords in KWallet
+ options = !strip
+ source = https://downloads.iridiumbrowser.de/source/iridium-browser-46.0.tar.xz
+ source = chromium-launcher-3.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v3.tar.gz
+ source = chromium.desktop
+ source = chromium-fix-print-preview-on-en_GB-locale.patch
+ source = chromium-widevine.patch
+ sha256sums = 13783ef0325f6f6ff65ac2ceb546af549403975d76ee528cebe07a0e8a5383a2
+ sha256sums = 8b01fb4efe58146279858a754d90b49e5a38c9a0b36a1f84cbb7d12f92b84c28
+ sha256sums = 028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9
+ sha256sums = 6fff45aafa31fb35a032b4e2175a341e08f9d2a9b37c5cf080c318180f558378
+ sha256sums = 379b746e187de28f80f5a7cd19edcfa31859656826f802a1ede054fcb6dfb221
+ makedepends_x86_64 = lib32-gcc-libs
+ makedepends_x86_64 = lib32-zlib
+
+pkgname = iridium
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73feb60d5013
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,203 @@
+# $Id$
+# Maintainer: Iru Cai <mytbk920423@gmail.com>
+
+pkgname=iridium
+pkgver=46.0
+pkgrel=1
+_launcher_ver=3
+pkgdesc="a free, open, and libre browser modification of the Chromium code base"
+arch=('i686' 'x86_64')
+url="https://iridiumbrowser.de/"
+license=('BSD')
+depends=('gtk2' 'nss' 'alsa-lib' 'xdg-utils' 'bzip2' 'libevent' 'libxss' 'icu'
+ 'libexif' 'libgcrypt' 'ttf-font' 'systemd' 'dbus' 'flac' 'snappy'
+ 'speech-dispatcher' 'pciutils' 'libpulse' 'harfbuzz' 'libsecret'
+ 'libvpx' 'perl' 'perl-file-basedir' 'desktop-file-utils'
+ 'hicolor-icon-theme')
+makedepends=('python2' 'gperf' 'yasm' 'mesa' 'ninja')
+makedepends_x86_64=('lib32-gcc-libs' 'lib32-zlib')
+optdepends=('kdebase-kdialog: needed for file dialogs in KDE'
+ 'gnome-keyring: for storing passwords in GNOME keyring'
+ 'kwallet: for storing passwords in KWallet')
+options=('!strip')
+install=iridium.install
+source=(https://downloads.iridiumbrowser.de/source/iridium-browser-${pkgver}.tar.xz
+ chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
+ chromium.desktop
+ chromium-fix-print-preview-on-en_GB-locale.patch
+ chromium-widevine.patch)
+sha256sums=('13783ef0325f6f6ff65ac2ceb546af549403975d76ee528cebe07a0e8a5383a2'
+ '8b01fb4efe58146279858a754d90b49e5a38c9a0b36a1f84cbb7d12f92b84c28'
+ '028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9'
+ '6fff45aafa31fb35a032b4e2175a341e08f9d2a9b37c5cf080c318180f558378'
+ '379b746e187de28f80f5a7cd19edcfa31859656826f802a1ede054fcb6dfb221')
+
+# We can't build (P)NaCL on i686 because the toolchain is x86_64 only and the
+# instructions on how to build the toolchain from source don't work that well
+# (at least not from within the Chromium 39 source tree).
+# https://sites.google.com/a/chromium.org/dev/nativeclient/pnacl/building-pnacl-components-for-distribution-packagers
+_build_nacl=0
+if [[ $CARCH == i686 ]]; then
+ _build_nacl=0
+fi
+
+prepare() {
+ cd "$srcdir/iridium-browser-$pkgver"
+
+ # https://groups.google.com/a/chromium.org/d/topic/chromium-packagers/9JX1N2nf4PU/discussion
+ touch chrome/test/data/webui/i18n_process_css_test.html
+
+ # https://code.google.com/p/chromium/issues/detail?id=541273
+ #sed -i "/'target_name': 'libvpx'/s/libvpx/&_new/" build/linux/unbundle/libvpx.gyp
+
+ # https://code.google.com/p/chromium/issues/detail?id=480415
+ patch -Np1 -i ../chromium-fix-print-preview-on-en_GB-locale.patch
+
+ # Enable support for the Widevine CDM plugin
+ # The actual libraries are not included, but can be copied over from Chrome:
+ # libwidevinecdmadapter.so
+ # libwidevinecdm.so
+ # (Version string doesn't seem to matter so let's go with "Pinkie Pie")
+ sed "s/@WIDEVINE_VERSION@/Pinkie Pie/" ../chromium-widevine.patch |
+ patch -Np1
+
+ # Remove bundled ICU; its header files appear to get picked up instead of
+ # the system ones, leading to errors during the final link stage.
+ # https://groups.google.com/a/chromium.org/d/topic/chromium-packagers/BNGvJc08B6Q
+ find third_party/icu -type f \! -regex '.*\.\(gyp\|gypi\|isolate\)' -delete
+
+ # Use Python 2
+ find . -name '*.py' -exec sed -i -r 's|/usr/bin/python$|&2|g' {} +
+ # There are still a lot of relative calls which need a workaround
+ mkdir "$srcdir/python2-path"
+ ln -s /usr/bin/python2 "$srcdir/python2-path/python"
+
+ # Download the PNaCL toolchain on x86_64; i686 toolchain is no longer provided
+ if (( $_build_nacl )); then
+ python2 build/download_nacl_toolchains.py \
+ --packages nacl_x86_newlib,pnacl_newlib,pnacl_translator \
+ sync --extract
+ fi
+}
+
+build() {
+ cd "$srcdir/chromium-launcher-$_launcher_ver"
+
+ make PREFIX=/usr
+
+ cd "$srcdir/iridium-browser-$pkgver"
+
+ export PATH="$srcdir/python2-path:$PATH"
+
+ # CFLAGS are passed through release_extra_cflags below
+ export -n CFLAGS CXXFLAGS
+
+ local _chromium_conf=(
+ -Dgoogle_api_key=$_google_api_key
+ -Dgoogle_default_client_id=$_google_default_client_id
+ -Dgoogle_default_client_secret=$_google_default_client_secret
+ -Dwerror=
+ -Dclang=0
+ -Dpython_ver=2.7
+ -Dlinux_link_gsettings=1
+ -Dlinux_link_libpci=1
+ -Dlinux_link_libspeechd=1
+ -Dlinux_link_pulseaudio=1
+ -Dlinux_strip_binary=1
+ -Dlinux_use_bundled_binutils=0
+ -Dlinux_use_bundled_gold=0
+ -Dlinux_use_gold_flags=0
+ -Dicu_use_data_file_flag=0
+ -Dlogging_like_official_build=1
+ -Dtracing_like_official_build=1
+ -Dfieldtrial_testing_like_official_build=1
+ -Drelease_extra_cflags="$CFLAGS"
+ -Dlibspeechd_h_prefix=speech-dispatcher/
+ -Dffmpeg_branding=Chrome
+ -Dproprietary_codecs=1
+ -Duse_gnome_keyring=0
+ -Duse_system_bzip2=1
+ -Duse_system_flac=1
+ -Duse_system_ffmpeg=0
+ -Duse_system_harfbuzz=1
+ -Duse_system_icu=1
+ -Duse_system_libevent=1
+ -Duse_system_libjpeg=1
+ -Duse_system_libpng=1
+ -Duse_system_libvpx=1
+ -Duse_system_libxml=0
+ -Duse_system_snappy=1
+ -Duse_system_xdg_utils=1
+ -Duse_system_yasm=1
+ -Duse_system_zlib=0
+ -Dusb_ids_path=/usr/share/hwdata/usb.ids
+ -Duse_mojo=0
+ -Duse_gconf=0
+ -Denable_hangout_services_extension=1
+ -Ddisable_fatal_linker_warnings=1
+ -Ddisable_glibc=1)
+
+ if (( ! $_build_nacl )); then
+ _chromium_conf+=(
+ -Ddisable_nacl=1
+ -Ddisable_pnacl=1
+ )
+ fi
+
+ build/linux/unbundle/replace_gyp_files.py "${_chromium_conf[@]}"
+ build/gyp_chromium --depth=. "${_chromium_conf[@]}"
+
+ ninja -C out/Release chrome chrome_sandbox chromedriver
+}
+
+package() {
+ cd "$srcdir/chromium-launcher-$_launcher_ver"
+
+ make PREFIX=/usr DESTDIR="$pkgdir" install-strip
+ install -Dm644 LICENSE \
+ "$pkgdir/usr/share/licenses/chromium/LICENSE.launcher"
+
+ cd "$srcdir/iridium-browser-$pkgver"
+
+ install -D out/Release/chrome "$pkgdir/usr/lib/chromium/chromium"
+
+ install -Dm4755 out/Release/chrome_sandbox \
+ "$pkgdir/usr/lib/chromium/chrome-sandbox"
+
+ install -D out/Release/chromedriver "$pkgdir/usr/lib/chromium/chromedriver"
+
+ cp out/Release/{*.pak,*.bin} "$pkgdir/usr/lib/chromium/"
+
+ # Manually strip binaries so that 'nacl_irt_*.nexe' is left intact
+ strip $STRIP_BINARIES "$pkgdir/usr/lib/chromium/"{chromium,chrome-sandbox} \
+ "$pkgdir/usr/lib/chromium/chromedriver"
+
+ if (( $_build_nacl )); then
+ cp out/Release/nacl_helper{,_bootstrap} out/Release/nacl_irt_*.nexe \
+ "$pkgdir/usr/lib/chromium/"
+ strip $STRIP_BINARIES "$pkgdir/usr/lib/chromium/"nacl_helper{,_bootstrap}
+ fi
+
+ cp -a out/Release/locales "$pkgdir/usr/lib/chromium/"
+
+ install -Dm644 out/Release/chrome.1 "$pkgdir/usr/share/man/man1/chromium.1"
+
+ install -Dm644 "$srcdir/chromium.desktop" \
+ "$pkgdir/usr/share/applications/chromium.desktop"
+
+ for size in 22 24 48 64 128 256; do
+ install -Dm644 "chrome/app/theme/chromium/product_logo_$size.png" \
+ "$pkgdir/usr/share/icons/hicolor/${size}x${size}/apps/chromium.png"
+ done
+
+ for size in 16 32; do
+ install -Dm644 "chrome/app/theme/default_100_percent/chromium/product_logo_$size.png" \
+ "$pkgdir/usr/share/icons/hicolor/${size}x${size}/apps/chromium.png"
+ done
+
+ ln -s /usr/lib/chromium/chromedriver "$pkgdir/usr/bin/chromedriver"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/chromium/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/chromium-fix-print-preview-on-en_GB-locale.patch b/chromium-fix-print-preview-on-en_GB-locale.patch
new file mode 100644
index 000000000000..9ebc089cb756
--- /dev/null
+++ b/chromium-fix-print-preview-on-en_GB-locale.patch
@@ -0,0 +1,17 @@
+Index: chrome/browser/ui/webui/print_preview/print_preview_handler.cc
+diff --git a/chrome/browser/ui/webui/print_preview/print_preview_handler.cc b/chrome/browser/ui/webui/print_preview/print_preview_handler.cc
+index 6cfd861387c9f8b145fb33472b10025537986213..c936a9c1dadb13c00418e8ae79a8a1987c1d36cd 100644
+--- a/chrome/browser/ui/webui/print_preview/print_preview_handler.cc
++++ b/chrome/browser/ui/webui/print_preview/print_preview_handler.cc
+@@ -1222,7 +1222,10 @@ void PrintPreviewHandler::GetNumberFormatAndMeasurementSystem(
+ UErrorCode errorCode = U_ZERO_ERROR;
+ const char* locale = g_browser_process->GetApplicationLocale().c_str();
+ UMeasurementSystem system = ulocdata_getMeasurementSystem(locale, &errorCode);
+- if (errorCode > U_ZERO_ERROR || system == UMS_LIMIT)
++ // On error, assume the units are SI.
++ // Since the only measurement units print preview's WebUI cares about are
++ // those for measuring distance, assume anything non-US is SI.
++ if (errorCode > U_ZERO_ERROR || system != UMS_US)
+ system = UMS_SI;
+
+ // Getting the number formatting based on the locale and writing to
diff --git a/chromium-widevine.patch b/chromium-widevine.patch
new file mode 100644
index 000000000000..45048cada875
--- /dev/null
+++ b/chromium-widevine.patch
@@ -0,0 +1,12 @@
+diff -upr chromium-42.0.2311.90.orig/third_party/widevine/cdm/widevine_cdm_version.h chromium-42.0.2311.90/third_party/widevine/cdm/widevine_cdm_version.h
+--- chromium-42.0.2311.90.orig/third_party/widevine/cdm/widevine_cdm_version.h 2015-04-15 01:18:59.000000000 +0300
++++ chromium-42.0.2311.90/third_party/widevine/cdm/widevine_cdm_version.h 2015-04-15 09:09:49.157260050 +0300
+@@ -14,4 +14,8 @@
+ // - WIDEVINE_CDM_VERSION_STRING (with the version of the CDM that's available
+ // as a string, e.g., "1.0.123.456").
+
++#include "third_party/widevine/cdm/widevine_cdm_common.h"
++#define WIDEVINE_CDM_AVAILABLE
++#define WIDEVINE_CDM_VERSION_STRING "@WIDEVINE_VERSION@"
++
+ #endif // WIDEVINE_CDM_VERSION_H_
diff --git a/chromium.desktop b/chromium.desktop
new file mode 100644
index 000000000000..05788f7135da
--- /dev/null
+++ b/chromium.desktop
@@ -0,0 +1,112 @@
+[Desktop Entry]
+Name=Chromium
+# Only KDE 4 seems to use GenericName, so we reuse the KDE strings.
+# From Ubuntu's language-pack-kde-XX-base packages, version 9.04-20090413.
+GenericName=Web Browser
+GenericName[ar]=متصفح الشبكة
+GenericName[bg]=Уеб браузър
+GenericName[ca]=Navegador web
+GenericName[cs]=WWW prohlížeč
+GenericName[da]=Browser
+GenericName[de]=Web-Browser
+GenericName[el]=Περιηγητής ιστού
+GenericName[en_GB]=Web Browser
+GenericName[es]=Navegador web
+GenericName[et]=Veebibrauser
+GenericName[fi]=WWW-selain
+GenericName[fr]=Navigateur Web
+GenericName[gu]=વેબ બ્રાઉઝર
+GenericName[he]=דפדפן אינטרנט
+GenericName[hi]=वेब ब्राउज़र
+GenericName[hu]=Webböngésző
+GenericName[it]=Browser Web
+GenericName[ja]=ウェブブラウザ
+GenericName[kn]=ಜಾಲ ವೀಕ್ಷಕ
+GenericName[ko]=웹 브라우저
+GenericName[lt]=Žiniatinklio naršyklė
+GenericName[lv]=Tīmekļa pārlūks
+GenericName[ml]=വെബ് ബ്രൌസര്‍
+GenericName[mr]=वेब ब्राऊजर
+GenericName[nb]=Nettleser
+GenericName[nl]=Webbrowser
+GenericName[pl]=Przeglądarka WWW
+GenericName[pt]=Navegador Web
+GenericName[pt_BR]=Navegador da Internet
+GenericName[ro]=Navigator de Internet
+GenericName[ru]=Веб-браузер
+GenericName[sl]=Spletni brskalnik
+GenericName[sv]=Webbläsare
+GenericName[ta]=இணைய உலாவி
+GenericName[th]=เว็บเบราว์เซอร์
+GenericName[tr]=Web Tarayıcı
+GenericName[uk]=Навігатор Тенет
+GenericName[zh_CN]=网页浏览器
+GenericName[zh_HK]=網頁瀏覽器
+GenericName[zh_TW]=網頁瀏覽器
+# Not translated in KDE, from Epiphany 2.26.1-0ubuntu1.
+GenericName[bn]=ওয়েব ব্রাউজার
+GenericName[fil]=Web Browser
+GenericName[hr]=Web preglednik
+GenericName[id]=Browser Web
+GenericName[or]=ଓ୍ବେବ ବ୍ରାଉଜର
+GenericName[sk]=WWW prehliadač
+GenericName[sr]=Интернет прегледник
+GenericName[te]=మహాతల అన్వేషి
+GenericName[vi]=Bộ duyệt Web
+# Gnome and KDE 3 uses Comment.
+Comment=Access the Internet
+Comment[ar]=الدخول إلى الإنترنت
+Comment[bg]=Достъп до интернет
+Comment[bn]=ইন্টারনেটটি অ্যাক্সেস করুন
+Comment[ca]=Accedeix a Internet
+Comment[cs]=Přístup k internetu
+Comment[da]=Få adgang til internettet
+Comment[de]=Internetzugriff
+Comment[el]=Πρόσβαση στο Διαδίκτυο
+Comment[en_GB]=Access the Internet
+Comment[es]=Accede a Internet.
+Comment[et]=Pääs Internetti
+Comment[fi]=Käytä internetiä
+Comment[fil]=I-access ang Internet
+Comment[fr]=Accéder à Internet
+Comment[gu]=ઇંટરનેટ ઍક્સેસ કરો
+Comment[he]=גישה אל האינטרנט
+Comment[hi]=इंटरनेट तक पहुंच स्थापित करें
+Comment[hr]=Pristup Internetu
+Comment[hu]=Internetelérés
+Comment[id]=Akses Internet
+Comment[it]=Accesso a Internet
+Comment[ja]=インターネットにアクセス
+Comment[kn]=ಇಂಟರ್ನೆಟ್ ಅನ್ನು ಪ್ರವೇಶಿಸಿ
+Comment[ko]=인터넷 연결
+Comment[lt]=Interneto prieiga
+Comment[lv]=Piekļūt internetam
+Comment[ml]=ഇന്റര്‍‌നെറ്റ് ആക്‌സസ് ചെയ്യുക
+Comment[mr]=इंटरनेटमध्ये प्रवेश करा
+Comment[nb]=Gå til Internett
+Comment[nl]=Verbinding maken met internet
+Comment[or]=ଇଣ୍ଟର୍ନେଟ୍ ପ୍ରବେଶ କରନ୍ତୁ
+Comment[pl]=Skorzystaj z internetu
+Comment[pt]=Aceder à Internet
+Comment[pt_BR]=Acessar a internet
+Comment[ro]=Accesaţi Internetul
+Comment[ru]=Доступ в Интернет
+Comment[sk]=Prístup do siete Internet
+Comment[sl]=Dostop do interneta
+Comment[sr]=Приступите Интернету
+Comment[sv]=Gå ut på Internet
+Comment[ta]=இணையத்தை அணுகுதல்
+Comment[te]=ఇంటర్నెట్‌ను ఆక్సెస్ చెయ్యండి
+Comment[th]=เข้าถึงอินเทอร์เน็ต
+Comment[tr]=İnternet'e erişin
+Comment[uk]=Доступ до Інтернету
+Comment[vi]=Truy cập Internet
+Comment[zh_CN]=访问互联网
+Comment[zh_HK]=連線到網際網路
+Comment[zh_TW]=連線到網際網路
+Exec=chromium %U
+Terminal=false
+Icon=chromium
+Type=Application
+Categories=GTK;Network;WebBrowser;
+MimeType=text/html;text/xml;application/xhtml+xml;text/mml;x-scheme-handler/http;x-scheme-handler/https;
diff --git a/iridium.install b/iridium.install
new file mode 100644
index 000000000000..c7a5da3595e8
--- /dev/null
+++ b/iridium.install
@@ -0,0 +1,14 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim:set ts=2 sw=2 et: