summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNichlas Severinsen2018-04-07 23:55:40 +0200
committerNichlas Severinsen2018-04-07 23:56:34 +0200
commit06f9295c0c9b874274a115ad9e2effe5c46ba7a9 (patch)
treea4dd53b9d5e74a256410b2ebc13298514a5d95fe
downloadaur-06f9295c0c9b874274a115ad9e2effe5c46ba7a9.tar.gz
Initial commit
-rw-r--r--.SRCINFO37
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16626a746542
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = iridium-deb
+ pkgdesc = An attempt at creating a safer, faster, and more stable browser (Stable Channel)
+ pkgver = 61.0
+ pkgrel = 1
+ url = https://iridiumbrowser.de/
+ arch = x86_64
+ license = BSD
+ depends = alsa-lib
+ depends = desktop-file-utils
+ depends = flac
+ depends = gconf
+ depends = gnome-themes-standard
+ depends = gtk2
+ depends = harfbuzz
+ depends = harfbuzz-icu
+ depends = hicolor-icon-theme
+ depends = icu
+ depends = libpng
+ depends = libxss
+ depends = libxtst
+ depends = nss
+ depends = opus
+ depends = snappy
+ depends = speech-dispatcher
+ depends = ttf-font
+ depends = xdg-utils
+ optdepends = kdialog: needed for file dialogs in KDE
+ optdepends = ttf-liberation: fix fonts for some PDFs
+ options = !emptydirs
+ options = !strip
+ source = https://downloads.iridiumbrowser.de/ubuntu/iridium-browser_current_amd64.deb
+ sha256sums = a5c00da23c4fd86e3a85dcfbc158338c056aca1a0e0da722bd4dc3544d4387fe
+ sha384sums = 9a9c49a0a1ea38351310cb10ce68eccbfff12ded5cbf9a947bdc9ca9803b0368266f43967dd48d83f2efb88ace252542
+ sha512sums = 51933bd4d6ef0054246358c36554dcf98711ec3e770560d76b847ee081eef478e416118278a1e818d66839eaf0a5f71405c2dfc7f250ee85677eae14b20421d7
+
+pkgname = iridium-deb
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9d4473d89d1b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar.xz
+*.deb \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5d80c05ef68
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Current Maintainer: necklace <ns@nsz.no>
+# Original Packager: sunnaryt <joshd@protonmail.com>
+# Contributors: Det, t3ddy, Lex Rivera aka x-demon, ruario
+
+pkgname=iridium-deb
+pkgver=61.0
+pkgrel=1
+pkgdesc="An attempt at creating a safer, faster, and more stable browser (Stable Channel)"
+arch=('x86_64')
+url="https://iridiumbrowser.de/"
+license=('BSD')
+depends=('alsa-lib' 'desktop-file-utils' 'flac' 'gconf' 'gnome-themes-standard' 'gtk2' 'harfbuzz' 'harfbuzz-icu'
+ 'hicolor-icon-theme' 'icu' 'libpng' 'libxss' 'libxtst' 'nss' 'opus' 'snappy' 'speech-dispatcher'
+ 'ttf-font' 'xdg-utils')
+optdepends=('kdialog: needed for file dialogs in KDE'
+ 'ttf-liberation: fix fonts for some PDFs')
+options=('!emptydirs' '!strip')
+
+source=("https://downloads.iridiumbrowser.de/ubuntu/iridium-browser_current_amd64.deb"
+)
+
+sha256sums=('a5c00da23c4fd86e3a85dcfbc158338c056aca1a0e0da722bd4dc3544d4387fe')
+sha384sums=('9a9c49a0a1ea38351310cb10ce68eccbfff12ded5cbf9a947bdc9ca9803b0368266f43967dd48d83f2efb88ace252542')
+sha512sums=('51933bd4d6ef0054246358c36554dcf98711ec3e770560d76b847ee081eef478e416118278a1e818d66839eaf0a5f71405c2dfc7f250ee85677eae14b20421d7')
+
+package() {
+ msg2 "Extracting the data.tar.xz..."
+ bsdtar -xf data.tar.xz -C "$pkgdir/"
+}