summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2019-06-28 16:53:08 +0300
committerYour Name2019-06-28 16:53:08 +0300
commitae441e35f01151c7512e3c76b12fd9527e1654d7 (patch)
tree6af38a23d81b33f7edef840b30c2b94b853096a4
downloadaur-ae441e35f01151c7512e3c76b12fd9527e1654d7.tar.gz
Init
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4db98c6773d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = iris-flower
+ pkgdesc = Eye protection utility. Change brightness, color temperature and color scheme on X11
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/ueberchild/iris-flower
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = libx11
+ depends = libxrandr
+ source = https://github.com/ueberchild/iris-flower/blob/master/iris-flower.c
+
+pkgname = iris-flower
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c00f0cc1598
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+pkgname=iris-flower
+pkgver=1.0
+pkgrel=1
+pkgdesc="Eye protection utility. Change brightness, color temperature and color scheme on X11"
+arch=('i686' 'x86_64')
+url="https://github.com/ueberchild/iris-flower"
+license=('GPL3')
+depends=('libx11' 'libxrandr')
+source=("https://github.com/ueberchild/iris-flower/blob/master/iris-flower.c")
+
+build() {
+ cd "$srcdir/"
+ cc -Wall -std=c99 -o iris-flower iris-flower.c -lX11 -lXrandr
+}
+
+package() {
+ cd "$srcdir/"
+ install -D iris-flower "$pkgdir/usr/bin/sct"
+} \ No newline at end of file