summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2017-07-06 19:00:02 +0000
committerAntonio Rojas2017-07-06 19:00:02 +0000
commit2bcba919991c7a9f3839b3b1b4c34d5fc5e06c66 (patch)
tree3025314af0c5119a46d84fd400ef6aae205b6c55
parent1cae7fd356af13fd9c716f7088f8756a0f5037a0 (diff)
downloadaur-ironpython.tar.gz
Drop from repos
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD66
2 files changed, 49 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c76e4268c5d..01eecac8a289 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,13 @@
pkgbase = ironpython
pkgdesc = Python implementation for the .NET framework
pkgver = 2.7.5
- pkgrel = 1
+ pkgrel = 3
url = http://ironpython.net
arch = any
license = Apache
- makedepends = xz
- depends = mono>=2.10.0
- options = !strip
- options = emptydirs
- options = libtool
+ depends = mono
source = https://github.com/IronLanguages/main/archive/ipy-2.7.5.zip
- source = site.patch
md5sums = 85951a4125fb733cdeaced19f3ff7157
- md5sums = dd484ca6dfe03277d8a13e7b1cfe6662
pkgname = ironpython
diff --git a/PKGBUILD b/PKGBUILD
index e19db4e4b1c4..e4c0bef911ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,63 @@
-# Maintainer: Michael Schubert <mschu.dev at gmail>
+# $Id: PKGBUILD 153111 2015-12-12 09:19:10Z fyan $
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Michael Schubert <mschu.dev at gmail>
# Contributor: Di "thc_flow" Abel <nospam@weedsmoker.im>
+
pkgname=ironpython
pkgver=2.7.5
-pkgrel=1
+pkgrel=3
pkgdesc="Python implementation for the .NET framework"
arch=("any")
url="http://ironpython.net"
license=("Apache")
-depends=('mono>=2.10.0')
-makedepends=('xz')
-options=('!strip' 'emptydirs' 'libtool')
-source=("https://github.com/IronLanguages/main/archive/ipy-$pkgver.zip"
- site.patch)
-md5sums=('85951a4125fb733cdeaced19f3ff7157'
- 'dd484ca6dfe03277d8a13e7b1cfe6662')
+depends=('mono')
+source=("https://github.com/IronLanguages/main/archive/ipy-$pkgver.zip")
+md5sums=('85951a4125fb733cdeaced19f3ff7157')
prepare() {
- cd "$srcdir/main-ipy-$pkgver"
- sed -i "/TreatWarningsAsErrors/s|true|false|" Solutions/Common.proj
+ cd "$srcdir/main-ipy-$pkgver"
+
+ # Workaround errors during Stage
+ # https://github.com/IronLanguages/main/issues/1156
+ # TODO: make this less ugly...
+ mv Languages/IronPython/Public/License.{R,r}tf
+
+ mkdir -p bin/{Silverlight5Release/DLLs,v45Release/DLLs,v2Release/DLLs}
+ touch \
+ bin/Silverlight5Release/Microsoft.{Dynamic,Scripting}.{xml,dll} \
+ bin/Silverlight5Release/Microsoft.Scripting.Silverlight.dll \
+ bin/Silverlight5Release/IronPython{,.Modules}.{xml,dll} \
+ bin/Silverlight5Release/DLLs/IronPython.SQLite.{xml,dll} \
+ bin/v45Release/Microsoft.{Dynamic,Scripting}.{xml,dll} \
+ bin/v45Release/Microsoft.Scripting.{Metadata,AspNet}.{xml,dll} \
+ bin/v45Release/IronPython{,.Modules}.{xml,dll} \
+ bin/v45Release/DLLs/IronPython.SQLite.{xml,dll} \
+ bin/v2Release/Microsoft.{Dynamic,Scripting}.{xml,dll} \
+ bin/v2Release/Microsoft.Scripting.{Metadata,AspNet,Core}.{xml,dll} \
+ bin/v2Release/IronPython{,.Modules}.{xml,dll} \
+ bin/v2Release/DLLs/IronPython.SQLite.{xml,dll}
}
build() {
- cd "$srcdir/main-ipy-$pkgver"
- xbuild Solutions/IronPython.sln /p:Mono=true /p:Configuration="Release"
+ cd "$srcdir/main-ipy-$pkgver"
+ xbuild /t:Stage '/p:BaseConfiguration=Release;Mono=true' /verbosity:minimal /nologo
+}
+
+check() {
+ cd "$srcdir/main-ipy-$pkgver"
+ # Not really runable now
+ # make test-ipy
}
package() {
- mkdir -p "$pkgdir/"{opt/ipy,usr/bin}
- cp -r $srcdir/main-ipy-$pkgver/bin/Release/* "$pkgdir/opt/ipy"
- for bin in ipy ipy64 ipyw ipyw64; do
- echo -e "#!/bin/sh\nmono /opt/ipy/$bin.exe \$*" > "$pkgdir/usr/bin/$bin"
- chmod +x "$pkgdir/usr/bin/$bin"
- done
+ cd "$srcdir/main-ipy-$pkgver"
+ install -d "$pkgdir"/usr/{lib,bin}
+
+ rm -r Stage/Release/IronPython-$pkgver/{Silverlight,Platforms}
+ cp -r Stage/Release/IronPython-$pkgver "$pkgdir/usr/lib/ipy"
+
+ for bin in ipy ipy64 ipyw ipyw64; do
+ echo -e "#!/bin/sh\nmono /usr/lib/ipy/$bin.exe \$*" > "$pkgdir/usr/bin/$bin"
+ chmod +x "$pkgdir/usr/bin/$bin"
+ done
}