summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlan Witkowski2015-09-19 17:59:34 -0600
committerAlan Witkowski2015-09-19 17:59:34 -0600
commite883af280b8d2e920f1f5d08a2f82d1f9c5ee938 (patch)
tree65dbc1010c2d6b2e758eb64016bde63472329d26
parentbf07b8065b1a034c0f435d47e6331866c63c0e1c (diff)
downloadaur-e883af280b8d2e920f1f5d08a2f82d1f9c5ee938.tar.gz
0.2.0
-rw-r--r--.SRCINFO21
-rw-r--r--Changelog15
-rw-r--r--PKGBUILD43
3 files changed, 25 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2d5a1a2df15..10cb015d65b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,24 @@
pkgbase = irrlamb
- pkgdesc = 3D game involving physics & frustrating gameplay
- pkgver = 0.1.1
- pkgrel = 2
- url = http://code.google.com/p/irrlamb/
- changelog = Changelog
+ pkgdesc = a 3D game that probably involves a lot of physics and frustrating gameplay.
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/jazztickets/irrlamb
arch = i686
arch = x86_64
license = GPL3
makedepends = cmake
- depends = bullet
depends = gcc-libs
+ depends = bullet
depends = irrlicht
- depends = lua51
+ depends = freetype2
+ depends = lua
+ depends = sqlite
depends = openal
+ depends = libvorbis
+ depends = libogg
depends = sh
- source = http://irrlamb.googlecode.com/files/irrlamb-0.1.1-src.tar.gz
- sha256sums = 2fbb30ee6cd0c65fc84acf6d260da468f0a1663af6f019ec4baf8177980ab96b
+ source = https://github.com/jazztickets/irrlamb/archive/v0.2.0.tar.gz
+ sha256sums = 1d50639cef5e93a91260ca55f456d5a95fd30b2305d35e8e2060eb8c6ee1105e
pkgname = irrlamb
diff --git a/Changelog b/Changelog
deleted file mode 100644
index b8c9c05cb2d3..000000000000
--- a/Changelog
+++ /dev/null
@@ -1,15 +0,0 @@
-2015-04-24 Alan Witkowski <alan.witkowski+aur@gmail.com>
-
- 0.1.1-2:
- * added pthreads dependency
-
-2013-05-11 Mariusz Libera <mariusz.libera@gmail.com>
-
- 0.1.1-1:
- * new maintainer
- * new upstream release
- * updated PKGBUILD
- * fixed dependencies
- * dropped irrlamb.sh
- * added Changelog
-
diff --git a/PKGBUILD b/PKGBUILD
index 4bc82f417b47..5740da7a70a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,31 @@
# Maintainer: Alan Witkowski <alan.witkowski+aur@gmail.com>
-# Contributor: Mariusz Libera <mariusz.libera@gmail.com>
-# Contributor: Ray Rashif <rayrashif@gmail.com>
-# Contributor: Ronan RABOUIN <darkbaboon@gmail.com>
pkgname=irrlamb
-pkgver=0.1.1
-pkgrel=2
-pkgdesc="3D game involving physics & frustrating gameplay"
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="a 3D game that probably involves a lot of physics and frustrating gameplay."
arch=('i686' 'x86_64')
-url="http://code.google.com/p/irrlamb/"
+url="https://github.com/jazztickets/irrlamb"
license=('GPL3')
-depends=('bullet' 'gcc-libs' 'irrlicht' 'lua51' 'openal' 'sh')
+depends=('gcc-libs' 'bullet' 'irrlicht' 'freetype2' 'lua' 'sqlite' 'openal' 'libvorbis' 'libogg' 'sh')
makedepends=('cmake')
-changelog=Changelog
-source=("http://irrlamb.googlecode.com/files/$pkgname-$pkgver-src.tar.gz")
-sha256sums=('2fbb30ee6cd0c65fc84acf6d260da468f0a1663af6f019ec4baf8177980ab96b')
+source=("https://github.com/jazztickets/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('1d50639cef5e93a91260ca55f456d5a95fd30b2305d35e8e2060eb8c6ee1105e')
prepare() {
- cd $srcdir/$pkgname-$pkgver-src
-
- # linking fix
- sed -i 's/${OPENAL_LIBRARY}/${OPENAL_LIBRARY} ${CMAKE_THREAD_LIBS_INIT} ${CMAKE_DL_LIBS}/' CMakeLists.txt
- sed -r -i 's/find_package\(Bullet REQUIRED\)/find_package(Bullet REQUIRED)\nfind_package(Threads REQUIRED)/' CMakeLists.txt
-
- # script fix
- sed -i 's|/local||' deployment/irrlamb
+ cd $srcdir/$pkgname-$pkgver
}
build() {
- cd $srcdir/$pkgname-$pkgver-src
+ cd $srcdir/$pkgname-$pkgver
cmake -DCMAKE_INSTALL_PREFIX=/usr .
make
}
package() {
- cd $srcdir/$pkgname-$pkgver-src
-
- make DESTDIR=$pkgdir install
-
- # it's a standard license, rm it
- rm $pkgdir/usr/share/doc/$pkgname/license.txt
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
- # place starting script where it's supposed to be
- install -dm755 $pkgdir/usr/bin
- mv $pkgdir/usr/games/$pkgname $pkgdir/usr/bin/$pkgname
- rmdir $pkgdir/usr/games
+ # remove standard license
+ rm $pkgdir/usr/share/doc/$pkgname/LICENSE
}